TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC
Start a Discussionhttps://teslamotorsclub.com/tmc/tags/

17.9.3 AP2 behavior

Discussion in 'Model S' started by kg7jo-, Mar 15, 2017.

Tags:
  1. kg7jo-

    kg7jo- Member

    Joined:
    Dec 9, 2016
    Messages:
    44
    Location:
    Salt Lake City


    Just noticed this behavior on the way home last night. Stopped at a traffic light, and the car keep switching back and forth between following the lane vs the car in front. Every time when going thru an intersection, the car will try to pull to the left. I think the last firmware (17.7.2) was way better on local roads. what's your experience with 17.9.3?
     
  2. HX_Guy

    HX_Guy Member

    Joined:
    Sep 1, 2012
    Messages:
    487
    Location:
    Phoenix, AZ
    Odd, I have never seen my HW2 car on 17.9.3 highlight the car in front in blue.

    And mine pulls to the right every time it goes through an intersection.
     
  3. googleiscoul

    googleiscoul Member

    Joined:
    Mar 13, 2017
    Messages:
    91
    Location:
    Aldie VA
    That's weird it's flashing back and forth and I have heard people saying AP pulls to the right on intersections but never left.
     
  4. t3slaMS

    t3slaMS Member

    Joined:
    Jan 18, 2017
    Messages:
    24
    Location:
    California
    Yeah, never seen the car highlighted in blue before. Another thing I noticed is that using autosteer or TACC on 17.9.3, it follows the car in front and randomly accelerates hard and then slows down once it detects its gotten too close to it. I have my distance set to a setting of 6 and it feels like it would go to a setting of 3-4 before realizing its too close to it.

    This never happened while I was on 17.7.2 and earlier versions; the car followed the car in front very smoothly, drove 2000 miles using autopilot and didn't run into this.
     
    • Like x 1
  5. croman

    croman Active Member

    Joined:
    Nov 21, 2016
    Messages:
    1,832
    Location:
    Chicago, IL
    I've seen blue on 17.9.3 but only briefly. I think it happens when car has only visual lock and not radar. I don't experience any sudden turns but I've only recently gotten 17.9.3. A week isn't sufficient to really see all the situations.
     
  6. gghahram

    gghahram Member

    Joined:
    Dec 20, 2016
    Messages:
    20
    Location:
    Lawrence
    I have also had the acceleration issue with the new release but autopilot has been the best I've ever experienced.
     
    • Informative x 1
  7. norm

    norm Vendor

    Joined:
    May 12, 2016
    Messages:
    122
    Location:
    RIO VERDE, AZ
    When I stop and there is a car in front does not show up on display until we start moving again ??
     
  8. disagree

    disagree hos epi to polu

    Joined:
    Feb 20, 2016
    Messages:
    394
    Location:
    chicago, il
    #8 disagree, Mar 15, 2017
    Last edited: Mar 15, 2017
    It still wants to drive me into the back of semi trucks at stops.

    Although today was the first time AP2 successfully navigated an intersection that I go by routinely. At the time my X appeared to be using the "Blue Car Method". Alas, the next time I went through the intersection, my X was following the "Blue Line Method" and got wobbly, and then I got too nervous and had to disengage.
     
  9. croman

    croman Active Member

    Joined:
    Nov 21, 2016
    Messages:
    1,832
    Location:
    Chicago, IL
    I've gotten that. I just don't use it behind them now. AP thinks the truck is 2 cars and that they are moving all over and sometimes loses them altogether and that's when it lurches forward at the (still existing) truck. Something about the metal underbelly creates issues.
     
  10. disagree

    disagree hos epi to polu

    Joined:
    Feb 20, 2016
    Messages:
    394
    Location:
    chicago, il
    Kind of funny (not at all funny) that our cars slow down for signs 50 feet over the highway, but still want to drive us under trucks.
     
    • Funny x 3
  11. croman

    croman Active Member

    Joined:
    Nov 21, 2016
    Messages:
    1,832
    Location:
    Chicago, IL
    Have you gotten any more sign/bridge issues with 17.9.3? I've been OK so far but they were always random so until a month passes, I can't really let my guard down.
     
  12. disagree

    disagree hos epi to polu

    Joined:
    Feb 20, 2016
    Messages:
    394
    Location:
    chicago, il
    I haven't yet had a chance to drive on the highway with 17.9.3. But I have to go from 94 down to Hyde Park tomorrow, so will let you know.
     
  13. Haxster

    Haxster Member

    Joined:
    Apr 4, 2016
    Messages:
    604
    Location:
    Silicon Valley
    Maybe Bluetooth is trying to pair with the car in front.o_O
     
    • Funny x 2
  14. dknisely

    dknisely Member

    Joined:
    Dec 4, 2016
    Messages:
    166
    Location:
    Seattle, WA
    I've never seen the car turn blue. I guess under the theory that this means radar + visual is never lost, that's a good thing.
     
  15. croman

    croman Active Member

    Joined:
    Nov 21, 2016
    Messages:
    1,832
    Location:
    Chicago, IL
    I used to live there for undergrad. Not the most fun drive but I'd be excited to see a Tesla had any existed way back then. Hopefully no issues.
     
  16. OBX John

    OBX John Autonomous Driving Enthusiast

    Joined:
    Nov 20, 2016
    Messages:
    401
    Location:
    Outer Banks, North Carolina
    The sun position seems to be a pretty big factor - last night on a curvy road with the sun at my back and two well marked lines on either side, autopilot did better than it ever has with sharp curves.

    But then this morning, with the sun rising from the right side, traffic stopped in the left turn lane really gave the TACC fits. It hit the brakes hard a couple of times where it would have just kept going at midday.
     
  17. BestRadar

    BestRadar Member

    Joined:
    Nov 14, 2013
    Messages:
    434
    Location:
    NJ
    Same here. For some reason it only seems like it can see moving cars. What was scary was I was coming up on a light and there was a car at the light a great distance from me so it was not shown and I was testing local AP and I figured when it would get close it would slow down but I was getting very close and I dont think the car was going to slow down and I waited as long as I could before I had to hard break because it was apparent it was not going to slow down. I dont know why it does not seem to see cars that are not moving.
     
  18. croman

    croman Active Member

    Joined:
    Nov 21, 2016
    Messages:
    1,832
    Location:
    Chicago, IL
    When you drop below 5mph and don't have TACC engaged the display doesn't show any cars. It can see stopped cars (or you'd crash in stop and go traffic since you'd be all "Go" and no stop).
     
  19. JRMW

    JRMW Member

    Joined:
    Nov 13, 2016
    Messages:
    256
    Location:
    Minneapolis
    Ditto.

    Actually, mine never does this.
    However: My city streets are all straight (true grid)
     
  20. JRMW

    JRMW Member

    Joined:
    Nov 13, 2016
    Messages:
    256
    Location:
    Minneapolis
    Although non-highway Autosteer works great for me:

    -my car is back to zooming and braking in stop/go traffic on highway.
    -it works BETTER in slow steady traffic that slows/speeds... like 20 to 50 mph on highway

    unfortunately:
    Last night my TACC was useless in the dark. (AS was off)

    I was driving in middle lane. empty traffic to my left, and behind me.
    Cars going slower than me in the right lane.

    It went back to slamming on the brakes constantly. I think it was doing this based on cars in right lane.
    (I did see once that the car in the lane to my front left flashed "red" when the braking happened)

    Once I went from 68 mph to 55 before I could get my foot on the accelerator.

    I had 4 slamming on brakes events in about 2 miles, so had to disengage even though there was nobody behind me.
    (I was afraid of what the cars in the right lane would do based on the brake-slamming)
     

Share This Page