TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

2015 Model S 85D MCU 1. 2020.36.31 update installation stuck at 80%

Discussion in 'Model S' started by T3MTLCanada, Sep 11, 2020.

  1. T3MTLCanada

    T3MTLCanada Member

    Joined:
    Nov 22, 2017
    Messages:
    32
    Location:
    Montreal
    Hi
    My 2015 Model S 85D MCU 1. 2020.36.31 update installation stuck at 80%.

    Is it save to reboot it ?
     
  2. BrownOuttaSpec

    Joined:
    May 13, 2019
    Messages:
    376
    Location:
    Raleigh, NC
    I would think to just let it sit for a while has it been 1 hour since you started the upgrade? 2 hours?

    i think the last time I did mine (2016 90D AP1/MCU1) it was stuck on 90% for longer than I would have thought was normal. I didnt time it but I think it went pretty quick and then stuck on 90% for 30-45 minutes.
     
  3. Rsilb3

    Rsilb3 New Member

    Joined:
    Jul 25, 2020
    Messages:
    2
    Location:
    Colorado
    I had similar situation and a reboot followed by update repeat download install worked.
     
  4. T3MTLCanada

    T3MTLCanada Member

    Joined:
    Nov 22, 2017
    Messages:
    32
    Location:
    Montreal
    I had to reboot twice and now I got MCU back so now I can’t give the car. But when I check for update it said no update. I’m still on 2020.36.

    my car got some error like
    Software update require contact Tesla and
    Center display unavailable. Driving and user setting cannot be restore.

    I try to drive the car and still work.
     
  5. ucmndd

    ucmndd Well-Known Member

    Joined:
    Mar 10, 2016
    Messages:
    5,920
    Location:
    California
    Your MCU is dying and the Tegra board needs to be replaced.
     
  6. Mhoepfin

    Mhoepfin Member

    Joined:
    Mar 18, 2019
    Messages:
    160
    Location:
    Atlanta, GA
    MCU about to die or dead.
     
  7. T3MTLCanada

    T3MTLCanada Member

    Joined:
    Nov 22, 2017
    Messages:
    32
    Location:
    Montreal
    After couple of test,

    the map work, all setting work on the MCU.
    What not working is I can’t use the scroll wheel on the right side. the 3G is disable but wifi work.

    Tesla only open on Monday.

    I’ll call in first to push the update again so I can reinstall it first.

    i believe the MCU Was change last year because of the bubble on the side.
     
  8. themacs

    themacs Member

    Joined:
    Nov 28, 2014
    Messages:
    113
    Location:
    san clemente, CA
    It happened to me about 7 weeks ago. Tesla towed the car in and "re did" the update installation. All was fine. Then 6 weeks later all went black again. They towed it in again and replaced the daughter board. I just got it back last Night. We will see.
     
  9. Spacey73

    Spacey73 Member

    Joined:
    Nov 2, 2019
    Messages:
    226
    Location:
    United Kingdom
    Damn this is exactly what mine is doing, 4 times they have sent me the update and it gets stuck at 80%

    Just had CCS upgrade last week so I thought it might be something to do with that. Had my suspicions that the MCu is on its way out S85 Dec 2014
     
  10. T3MTLCanada

    T3MTLCanada Member

    Joined:
    Nov 22, 2017
    Messages:
    32
    Location:
    Montreal
    They repush the update today and the update when fine and complete everything. Only issue now is the 3G that doesn’t work. bar signal with a slash through it

    First time the 3G issue happen when it fail the software update and when reboot it was like that.
    SC will check what happen.

    No idea how much that can cost to fix it.
     
  11. 98ramair

    98ramair P85D

    Joined:
    Oct 2, 2019
    Messages:
    18
    Location:
    Massachusetts
    Hi, similar but different issue with the 80% update. I have a 2015 P85D with 48k miles.

    Car went into service center for a door handle replacement and was there over a week. The SC kept saying they "were having an issue" with the software update and the mothership was involved. Finally got the call that software update took place and my car was ready.

    Fast forward a week. I got another software update and it stuck at 80% and received the same message "Software update needed, call service". I opened a service request and a few days later a new software update was sent and WORKED! However, after that update I lost 3g connectivity. Back to the app to open another request.

    I got an email yesterday and they ordered the 4g upgrade kit to solve the issue of no 3g connectivity.

    If this is indeed the signs of a failing MCU1 then I guess I am on borrowed time.

    upload_2020-10-7_9-29-31.png
     
  12. Spacey73

    Spacey73 Member

    Joined:
    Nov 2, 2019
    Messages:
    226
    Location:
    United Kingdom
    I have had the same thing, 7 attempts now and a service center visit to reset the 12v whatever that means, and every tiume the update freezes at 80%.

    No satnav on driver console, no 3g and half the functions like volume control and temp readout are completely messed up. It was not this way before I had the mobile CCS upgrade done last month. They want me down for another diagnostic (was a 5hr wait last time in a small room) now it's a 1st thing in the morning and could be all day.

    I've basically just said can we skip the diagnostics and just install a new motherboard as MCU memory chip has to be on its way out.

    Looks like they are ordering the part.

    Funny thing though whilst supercharging...my screen went all funny and then the 3G started working? 20201007_190836.jpg
     
  13. Jamesus

    Jamesus Member

    Joined:
    Feb 18, 2019
    Messages:
    60
    Location:
    CA
    I had this exact same issue with my 2015 70. I tried using different internet connections, hotspots, rebooting, and nothing worked. I scheduled a service request and a remote tech pushed a new update and reset something in my MCU.

    The update worked but the following month I got signs of a failing MCU (e.g. no video feed from the reverse camera when backing up, internet losing connection when using nav, MCU not responsive, etc.). My car is now getting diagnosed at the SC.
     
  14. T3MTLCanada

    T3MTLCanada Member

    Joined:
    Nov 22, 2017
    Messages:
    32
    Location:
    Montreal
    It's strange we all have same issue.
    I didn't want to believe it was Daughter board issue or the 3G module.
    Heck it work prior to 2020.36.31 with no issue at all.
    I believe is the software update that cause all this issue. When the software update failed at 80% and reboot the MCU, i believe some stuff did not install correctly like the 3G, the temps reading, the MAP on the IC doesn't move, right scroll doesn't work well to change temperature, those Artifact (weird graphic on the MCU).
    Anyways, they receive my part and my appointment is this Saturday and they will borrow me a rented loaner for the day.
    cost to replace the Daughter board and change to LTE and labor: 600$ CDN tax inc.
     
  15. PWlakewood

    PWlakewood Active Member

    Joined:
    Jan 9, 2019
    Messages:
    1,713
    Location:
    US
    We just picked up an S for my wife that had 3g and it worked for a week then when there was an update available it got stuck at 80% then after hours of waiting and many reboots later the 3g would not come back and the update would not finish. The tech I talked to at telsa said there was an error and the 3g modem was not responding anymore. We just said screw it and did the LTE upgrade sooner than planned and now everything is back to normal.
     
  16. 98ramair

    98ramair P85D

    Joined:
    Oct 2, 2019
    Messages:
    18
    Location:
    Massachusetts
    It is very interesting that this is happening to multiple vehicles after a software update and the solution seems to be upgrade to 4g and not fix the software problem itself. I would be curious to see how many vehicles still have 3g service as of today. Perhaps Tesla wants out of the 3g contract they are in and this is a way out!!
     
    • Like x 1
  17. PWlakewood

    PWlakewood Active Member

    Joined:
    Jan 9, 2019
    Messages:
    1,713
    Location:
    US
    I thought I read somewhere 3g was ending in 2022.....of course tesla is causing these issues to force everyone to do the upgrade....tesla is known for these type of shenanigans so no one should be surprised. The only thing that bugs me is were on the mcu2 upgrade list and that comes with lte so we basically did the lte upgrade just so we can have connectivity until they replace our mcu. So 350 bucks down the drain
     
  18. Georgeyang

    Georgeyang Member

    Joined:
    Jul 13, 2020
    Messages:
    7
    Location:
    San Ramon
    My 2015 car is same as
     
  19. Kandiru

    Kandiru Active Member

    Joined:
    Oct 20, 2014
    Messages:
    1,095
    Location:
    USA
    Good luck convincing the misers at the SC about that:)
     
  20. Spacey73

    Spacey73 Member

    Joined:
    Nov 2, 2019
    Messages:
    226
    Location:
    United Kingdom
    They seem ok about it, my local SC have ordered the newer daughter board for me and are just awaiting delivery before they can fit it. Will be nice to have satnav, heating and driver console functioning properly oh and 3g
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC