TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

2019.40.50.7 Strange bug: need card next to cup holder

Discussion in 'Model 3: User Interface' started by DS369, Jan 2, 2020.

  1. DS369

    DS369 Member

    Joined:
    Oct 7, 2019
    Messages:
    62
    Location:
    Montreal
    My phone is registered with the car.
    Car lets me unlock it and get in, pressing break.
    I enter my pin code and click allow.
    All check lights come up and turn off.
    I press the right stock down and instead of D I get a message on screen to put the card in front of the cup holder and press break.
     
  2. flyingowl

    flyingowl Member

    Joined:
    Sep 25, 2019
    Messages:
    274
    Location:
    NY
    Hmm.. mine didn't do that and I got same version as you. Did you try to do hard reboot? If that doesn't work, try to program your phone again as a key.
     
  3. linux-works

    linux-works Active Member

    Joined:
    Dec 23, 2019
    Messages:
    1,609
    Location:
    mtn view, ca
    try this: get out of the car, get it to auto-lock and all that, then walk up, have it unlock and immediately hit the brake like you are going to move it. does it ask for the card, then?
     
  4. linux-works

    linux-works Active Member

    Joined:
    Dec 23, 2019
    Messages:
    1,609
    Location:
    mtn view, ca
    mine (for a few versions, now) has been asking for the card even though I use my BT phone. I think its because I got in the car, didn't start it (go forward or backward) and it 'timed out' its authentication. that's my hunch, at least.
     
  5. eli_

    eli_ Member

    Joined:
    May 14, 2018
    Messages:
    274
    Location:
    Bellevue, WA
    #5 eli_, Jan 2, 2020
    Last edited: Jan 2, 2020
    One way to troubleshoot is this... There's four different beacons on the car that the phone will "see" for it to unlock doors or allow drive mode, if you look at Bluetooth devices on iPhones at least, they show up in the devices list. There will be four Bluetooth devices with a bunch of random numbers and letters but the last letter is always one of these four...

    D = Driver Door
    P = Passenger Door
    C = Console
    R = Rear/trunk

    Those are the car's four beacons, if the phone sees the driver's door (D), but not the console (C), the doors may unlock but it won't think it's "inside the car" and enable driving. I've had times in the past where sometimes the phone will stop seeing one of these, like the driver door, and toggling Bluetooth on the phone fixes it. But I feel the reliability has been 100% for a long time, either due to fixes to iOS or Tesla's software. The reliability is just dependent on the phone you use unfortunately.
     
    • Informative x 4
  6. DS369

    DS369 Member

    Joined:
    Oct 7, 2019
    Messages:
    62
    Location:
    Montreal
    Thanks for suggestions, I will experiment to get a clearer picture.
     
  7. Jefla

    Jefla Member

    Joined:
    May 27, 2019
    Messages:
    27
    Location:
    Chicagoland
    I have been noticing I have to take out my phone and open the Tesla app when it prompts me to use the key card.

    My android phone recently has an OS upgrade to Android 10 which changes some of the permissions apps can do. I am wondering if it is preventing the app from being active in background.

    I need to experiment with it to see though.

    I have come to the car and gone to the trunk to open it but it wont open, until I open the app and then the trunk opens.

    I also see sentry mode picking me up as an event so that is a hint it is not detecting the phone.
     
  8. brushless3

    brushless3 Member

    Joined:
    Sep 28, 2019
    Messages:
    27
    Location:
    Mississauga
    On my iphone I once had to turn off my bluetooth and back on to get it working again.
     
  9. FielderJones

    FielderJones Member

    Joined:
    May 17, 2019
    Messages:
    139
    Location:
    Chicagoland
    This always works for me if the car starts demanding the key card. Somehow the bluetooth connection has a glitch. Happens to me most often after a car software update or a phone software update.
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC