Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

2021 Y CCS Upgrade DIY: My experiance

Tldr version: I upgraded my 2021 Model Y to be CCS compatible and I’m now happy!

First off, thanks to @FalconFour and others for all of their research in figuring out how this needs to happen.

When I bought my Model Y I knew that I was going to need CCS charging ability because I travel a lot in southeastern Oklahoma where there are no Tesla superchargers. So before I had even received my Y, I had ordered the Setec CCS adapter, knowing that it had it quirks. It served me well and was used many times to ensure that I could get to family in OK without running out of electrons.

Fast forward to 2022 and updates to the Model Y that began to show a CCS status in the information screen as well as news from South Korea that a CCS1 adapter was now available. This was followed by my disappointment when I found that for a period in 2021, due to the chip shortage, cars were not delivered with the necessary chips for CCS compatibility, and my Y was one of the unlucky ones. I was bummed, but I certainly did not expect Tesla to provide a free upgrade for something that I was not originally promised,

Then a bright point started shining on the horizon and I began reading about people who had upgraded their vehicles with the necessary parts to be CCS compatible. After reading their stories over a period of months and hearing of their success, I decided I was ready to give it a try. I got all the information I needed from this thread: Retrofit CCS compatibility onto earlier (NA) Model 3 - DIY approach

The good news was that for the 2021 vehicles that lacked the chip only the charge port ECU part needed to be swapped out while others with slightly older vehicles needed a “bundle of wires” to make the new part work with their vehicles. I simply needed to upgrade the Gen4 (P/N 1537264-80-B) with the CCS version (P/N 1537264-00-B). The challenging part was to get the part. I tried my local service center and they were unable or unwilling to get the part for me. I then opened a service request for a service center in Plano TX and they were more than willing to order the part for me. As luck would have it I would be traveling through there and would be able to pick it up. The date came and SCORE! I had the new part.

Of course, that part would not work without the adapter, and Tesla has thus far decided not to sell said adapter in North America. More reading in the forums here found that people were being successful in getting the adapter through a proxy service in South Korea called Harumio. Get your Tesla's CCS1 Adapter From Korea! I figured they were having success, so I gave it a try. At that time, it was required to provide your Tesla account login for them to order, but I understand that is no longer needed. I ordered, the adapter showed up in about 2 weeks and boom, I now had the adapter as well as the needed part. Now all that was left was to install the new ECU! The catch is that once it is installed, you MUST perform a firmware update to the vehicle before you’ll be able to charge the vehicle. There are two choices, either go to a service center and place your vehicle in “service mode” so you can force the install or wait for the next update to be delivered and then install the ECU and then perform the update. I opted for the latter since I was not in a great hurry. Within another week, I was notified of the pending update, so I headed out to the garage to take my chances.

Step one was the scariest, pulling apart the cargo area to get to the ECU. Strangely enough, for a $60K vehicle, everything pretty much just snaps together. I think there was one “bolt” that needed to be removed and everything else was snaps and clips. Having read that for the Model Y, the service manual did not say anything about disconnecting the battery, I did use the menu to turn the vehicle off and then proceeded to remove the current ECU. I removed the bolt but it was still adhered to the vehicle, so I pulled and then heard a “SNAP!”! Oops. Come to find out there are (or were) a couple of tabs on the back of the ECU part that locks into a couple of slots on the vehicle body. Well, there aren’t on this one anymore. Luckily, the damage was just to the ECU I was replacing and not the body. Note that after you remove the 10mm bolt, you must slide the ECU to get the tabs out of the slots before pulling it away from the vehicle. Once that was done, there are 3 wire plugs that remove fairly easily, plug them into the new ECU and reverse the process to 1) slide the tabs into the slots on the body, 2) replace the 10mm bold to secure the ECU, and then replace all of the body parts you have to remove to get to the ECU. I opted to do that part later once I finished with the software install.

Next was to get into the driver’s seat, notice a few warning notifications due to the new hardware, and then to apply the waiting software update to the vehicle. This seemed to take a little longer than usual. I’m not sure if it was just this update or the fact that it was having to apply updates specific to this new part. Once complete the vehicle rebooted and first check was to see that there were no warnings! Great! Next, check the “more info” tab and see that rather than “CCS Compatible: Not Installed” now says “CCS Compatible: Enabled”! Another win! Next check, will it charge with my level 2 charger in the garage? Yes! Another win!! So far so good. Now I reassemble the back end of the vehicle. Next check will be the next time I’m out and have to stop at a supercharger.

Fast forward 2 weeks and a trip into Dallas. Once there it will be necessary to charge at a supercharger to make it back home. We’re down to 38% and pull into a station I hadn’t been at before because the usual ones are already backed up. This one is an “urban” supercharger and the stations only to 70kW, so not a normal SC that we usually use. I plug in, it starts to charge, and then I get a warning, “CP_a140: Unable to charge – Supercharger reports an error”!! Yikes!!! I unplug and try again. Same message. One more time. It starts charging. Phew! My wife and I take a walk around the shopping center there to get something cool to drink and maybe a snack. While doing that I check my phone and see that I have a notification that charging had stopped. Dang! We get back to the vehicle and sure enough, same error. I see someone has left and there is another spot open so I move to rule out that stall. Plug in… charging begins. And it continues until we have enough power to get home. While charging, I see someone in an older Model S P75 pull into the same stall and they don’t appear to have any issue charging. Not feeling completely confident in my upgrade, we finish charging and head home.

Since we are planning a road trip in a few weeks I decided that I need to do a full test of supercharging, including CCS charging, so on our next free Saturday, I map out a round trip to hit the closest CCS and Superchargers, about a 200 mile round trip. We get to the CCS charger with 75% SOC, I plug in the cable to the CCS adapter, plug it into the car, start charging on the Electrify America app, and after a few seconds, charging begins. Not a great test because at 75% I’m only able to pull about 40kW from the charger, which is about the same speed I used to get with the Setec adapter. I charge up to about 80%, comfortable that it does in fact work, and head off to the Supercharger. We get there with about 60% SOC, plug in, and charging starts up like normal and we are getting closer to 70kW with this lower SOC. I add enough to make sure we make it home and are comfortable that it is not going to error out and then we head home.

So, after all this, I am now comfortable that I did not break my car and everything is working as it should. I now have a car that natively supports CCS charging, so I am now able to more comfortably travel to visit family members in the Tesla wasteland of eastern OK. So, if you are interested in doing the upgrade yourself and have the patience to get the parts, it is doable and fairly simple. The actual ECU install took me less than an hour, and that included the software update. The link at the beginning of this story has all information you need in the very first post so you don’t even need to read all 40+ pages to get what you need.

Cheers!
 
For cars that cost what they do these days, spending about $600 all in (ecu+🐦wires+🇰🇷Adapter) to double or triple the number of locations where someone can DC fast charge, makes a ton of sense. And while tesla never promised me CCS when I bought the car in 2019, waiting for "CCS compatability soon", was taking too long.

I now have a car that natively supports CCS charging, so I am now able to more comfortably travel to visit family members in the Tesla wasteland of eastern OK.

It may not make sense for tesla to install 8+ superchargers (drawing 1-2 MW of power) in a small town in rural America (yet) but it might be possible for local businesses or an electrical co-op to install 1-2 lower powered 50-200kw CCS station (Francis Energy in OK),

Also a lot of the old legacy v2 tesla locations are in crappy locations compared to EA stations (Kingman AZ, quartzsite AZ, Holbrook az... :cough:)
 
I did all of what he said, but I replaced my broken 80 with an 80 that was yanked from a wrecked 21 model 3. It did NOT fix the issue. I re-flashed the car but it still refused to charge (but no longer gave me error messages about the FW mismatch). The chances of me getting another bad 80 seem really slim..but I guess it could happen?? who knows. But yesterday, the service center swears they only needed to replace my bad 80 with a new 00 and now I have CCS capability (and well, I can finally charge at level 2 without "charging equipment not ready")...so a win! LOL
 
  • Like
Reactions: ArtK and MSHampton
Next somebody does this please take pictures of the step by step as well as anything interesting on the display.
Check out this thread. It is where I got all the info I needed.

 
  • Like
Reactions: rlzalusky

SteelClouds

Member
Supporting Member
Nov 12, 2021
325
480
CA
I love the write up and the details. But I took the easy way although more expensive way and bought a used Setec CCS adapter which gets the job done for me. I will say there are some caveats about. The dash complains about a flash hazard but works. And so far, the best I’ve gotten out of it is 45kw. But it works on my model 3. The fact is my 2019 will probably require significantly more work to upgrade using tesla parts assuming they even support it. So for now, I’m sticking with this adapter vs the much cleaner Tesla adapter
 
  • Like
Reactions: MSHampton

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top