Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • The final cut of the 9th episode of the Tesla Motors Club Podcast, featuring Chad Schwitters, the former president of Plug In America, is now available. You can watch it now on YouTube or listen to it on all major podcast networks.

21 MS - Browser not working

Looked to see if i can find any info on this, but on my 21 Model S Refresh, my browser does not work.. all that shows up after entering the website is a white screen. I tried both on LTE and also on WIFI hotspot. I also tried doing a reboot of the car.

Note that this did work properly when i first got the car in Sept 2021.

I am on 2021.44.30.8 and this is a Canadian Car.
 
The browser on my June 2020 has been flaky, along with SiriusXM, since I got the car. Likely Tesla software that is not very good at infotainment components, except games. Maybe it will work for awhile after the next update, or maybe it will be worse.
Thanks but I thought having the refresh model is different than the older generations (AMD?)... I cant understand why i cannot browse anything anymore.. just plain white.
 

DerbyDave

Active Member
Jul 2, 2020
2,279
1,325
Kentucky
It IS different, and they had to program a whole new interface for the browser and other things on your car -- bunches of even newer bugs. They still haven't gotten my 2020 Browser interface to work well. Hopefully your browser will get fixed sooner than the 1 1/2 years I have been waiting. It sort of works sometimes, but it is very clunky. You should be getting something on the screen, but then again, your programming is entirely new and untested.
 
Looked to see if i can find any info on this, but on my 21 Model S Refresh, my browser does not work.. all that shows up after entering the website is a white screen. I tried both on LTE and also on WIFI hotspot. I also tried doing a reboot of the car.

Note that this did work properly when i first got the car in Sept 2021.

I am on 2021.44.30.8 and this is a Canadian Car.
I have a MY not a MS so I want to qualify my comments. It is not possible for the user to either modify permissions or easily delete the cache used by the Tesla browser. One thing that I have noticed is that the browser in my car thinks its location is CA even though I'm in NY. hulu and YouTube TV both show their program guides early by 3 hours. The location permission is locked.

The browser also remembers the last website visited. If the browser doesn't close properly, the browser will open weirdly (or often not display anything at all) the next time it is opened. I can usually fix this by opening either Netflix, Disney+, etc., which use a full screen version of the browser. I then close one of those WebApps and then I open a URL in the browser.
 

DerbyDave

Active Member
Jul 2, 2020
2,279
1,325
Kentucky
Tesla Servers in California are servicing your browser, so the browser thinks you are in California. None of the connections from the car are straight to the Internet. They all use the cellular connection to Tesla for connection to the Internet when you are driving. When you are connected to WiFi, the connection still goes to Tesla California for in car functions.
 

brkaus

Well-Known Member
Jul 8, 2014
8,507
7,141
Austin, TX
I noticed Dish Anywhere along with other live TV and recorded material no longer plays, even though it was not that well played before. Now it tells you the browser does not support that source. No one can say if this a software glitch or a new limitation. Time will tell.
Probably restricted because the browser can be used while driving. But who knows.
 
Ugh. The web browser in my 2019 model 3 used to always open to the last opened page whether I was parked or driving. It worked perfectly until about a week ago. Now it always opens to Tesla.com. Worse, on any other page I am looking at it will reset to Tesla.com after about a minute. This is really annoying. Has anyone found a workaround? I can't find any way to change settings or empty the cache. Also I haven't changed any software updates since this started to happen, so this is a really bizarre and frustrating annoyance. It is useless in it's current state.


Like



Comment
 
I have a 2019 MS with MCU upgrade for FSD. My experience is similar to others. I can say that I have done the double scroll wheel reboot and the browser works a little better for a short time (doesn't crash on the first website). But it seems that the next day it doesn't work again. Not doing anything too fancy on the web. Just checking weather when stuck in traffic. I agree with others that there is probably some cache problem and there seems to be no easy way to clear it.
 
Just an update. My web browser works perfectly now after a visit to the SC. This is what they did. Did they really replace the comptuer?
1648143439180.png
 
  • Informative
Reactions: brkaus

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top