Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

240V electrical noise causes charging problem

Ran into an odd one couple days ago that had me panicked for a while. I have a 2013 Model S85. Returned home to my garage and tried to charge using the Tesla Gen 2 mobile connector on 240V 14-50 outlet, which I've done for ~3 years. This time is different though:
  1. Before charging, Tesla shows 245V (good)
  2. Initially started charging at 32A/241V (good)
  3. After ~5-15 seconds, the mobile charger clicks off, Tesla display goes to 0V, and car stopped charging (beginning of bad)
  4. After ~3-5 seconds, mobile charger clicks on, voltage as shown on the Tesla display goes to 245V
  5. It does the whole ~1A "test" voltage, mobile charger clicks off, and voltage goes to 0V
  6. Steps 3-4 repeat ~5-10 times before
    1. charge port does the "clunk" sound (like it's locking or unlocking)
    2. Tesla does the beep beep beep warning
    3. Yellow exclamation warning pops up on the instrument panel "Charging disabled when using manual release Close charge port door and retry" In the error logs, it also says "CP_w035"
    4. Charger stays off and voltage reading in the car stays at 0V
  7. At some point I also got the error "CHG_u007 Charging equipment reports error. Check Equipment for error code or message"
I tried a bunch of debugging steps:
  1. Rebooted MCU and Instrument panel
  2. Unplugged charger from 240V and replugged
  3. Swapped out mobile charger for a second spare charger I have
  4. Cleaned charge port pins with alcohol
  5. Turned down charger current limit from 32A to 5A
None helped.

Here's the fun part. I have a GPU mining rig in the garage on a 20A/240V circuit, and that day I had installed a new (used) server power supply. Both the Tesla Charger and mining rig connect to the same 100A subpanel. While debugging the Tesla I noticed the mining rig server power supply fans were increasing/decreasing wildly. For the fun of it, I shut off the mining rig. Guess what? Tesla started charging on the first try!

I touched the server power supply, and it was HOT (could barely touch it). I swapped out the server power supply for another power supply, which didn't run hot. I've successfully charged the Tesla for a couple days now while the newer server power supply was running. My hunch is that server power supply is bad, which was putting electrical noise on the 240V bus.

So, lesson learned is that the Tesla chargers are picky about electrical noise. Hope this might help someone debug in the future.
 

LoudMusic

Active Member
Jul 21, 2020
1,455
1,716
Arkansas
Electrical systems are like the respiratory system. If any part of it is upset or out of balance it's all going to be upset and out of balance. It's why we put breakers everywhere. The Brits are even more aggressive with their breakers and fuses.

Great troubleshooting skills and write up! Thanks for sharing. 👍👍
 
You got it. Your GPU's switching mode power supply is injecting harmonics back onto the line, and Tessie does not like it. You could introduce an isolation transformer (or online UPS) between your wall outlet and GPU to quench the harmonics, but maybe a higher quality GPU power supply would be better option.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top