Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

540 Vehicle Server Error

DarthStar

MYP MSM Tow
Supporting Member
Jul 7, 2021
189
280
SoCal
Shortly after leaving the house today I got an alert that my phone was no longer connect and I would not be able to continue driving once I stopped. I opened up the app and saw it was disconnected with a 540 error (see pic). Since I wasn't far from the house, I turned around and grabbed my fob and continued the day.

When I got to my destination and parked, I tried the two-button reset. That cleared it and my phone reconnected.

Anyone else have the issue before? I'm on SW version 2021.11.102.
IMG_1255.jpeg
 

SanTella

Member
Dec 8, 2020
7
1
Estonia
Shortly after leaving the house today I got an alert that my phone was no longer connect and I would not be able to continue driving once I stopped. I opened up the app and saw it was disconnected with a 540 error (see pic). Since I wasn't far from the house, I turned around and grabbed my fob and continued the day.

When I got to my destination and parked, I tried the two-button reset. That cleared it and my phone reconnected.

Anyone else have the issue before? I'm on SW version 2021.11.102.
View attachment 711517
This just happened to my Model S. Very strange.
 

djinmn

Member
Sep 2, 2021
10
13
Saint Paul
I just got the error on my Model 3. It was fixed after a reboot, but the reboot took quite a bit longer than usual. And I am really disappointed that I know how long the reboot usually takes.
 
  • Like
Reactions: DarthStar

Jimrb123

New Member
Oct 3, 2021
1
0
Kenora, ontario
I had this error when car was parked and i was trying to connect remotely. I had a different program for car with same problem.
I solved this with a software reset in car.
Hold both steering whell buttons in until screen goes blank and reboots
 

Pagemakers

Member
Dec 25, 2016
670
286
Manchester UK
This is what Tesla have just replied. I am only logged into the same apps as I’ve been logged into for years….


Hello, remote diagnosis has confirmed that the issue being caused by repeated data requests from a third party. A third party application is spamming your Model 3 for status updates, preventing communication with the Tesla APP.
Even if the third party had the credentials and was then deleted, your Tesla will still be under the control of a third party as the credentials are still stored in their databases.
We can remotely resolve this issue for you by completing the following steps;
1. Change your myTesla password and discontinue use of the apps.
2. The security credentials then need resetting to prevent the vehicle from being woken.
Please provide consent to reset the credentials, this will sign out all accounts.
Once this is complete, sign back into the APP and the connection should then be restored.
Please could you reply to this message once step 1 is complete if you give your consent to reset the credentials.
Kind regards , Tesla Service.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top