TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Advice on ICU / MCU issues (S90D 2017)

Discussion in 'Model S' started by Axael, May 16, 2018.

  1. Axael

    Axael Member

    Joined:
    Feb 15, 2017
    Messages:
    130
    Location:
    Belgium
    Hey all,

    I own a S90D from early 2017. I began having issues a few months ago when the sides of my MCU screen started to show a yellow shadow (apparently, a common problem on cars produced in this timeframe).

    A few weeks ago, I began driving and saw that my airbag light on the ICU was lit. Also I had no sound coming from the turn signals or AP functions anymore. I rebooted (two thumbs reboot) and everything went back fine so I just reported to the SC that what experienced, together with issues with Spotify connectivity so they could check.

    SC said they would be doing a "pre-diagnose" remotely, and a few days later, told me they will "change the MCU to fix the issues" and that the part was ordered.

    Though on Sunday evening I took a 100km trip, and after around 10km, the airbag light went on again, the sound of the turn signals and AP functions dissapeared as well... but this time, external temperature wasn't displaying anymore, same for power consumption and the 70km I did before rebooting the system weren't included in the car ODO meter (so to be clear, I drove about 100km but the car says I drove around 30km).

    I went back to the SC and told them about it. I said I was going on holidays with my kids soon, and that I wanted the issue to be fixed before that. They said the MCU was ordered but that receiving it takes a lot of time. Thus I asked if that was the entire MCU they ordered or just the screen, and they said it was just the screen.

    So, here's the advice I'm searching for, because I'm not familiar with the way Tesla's are made, but: how the hell could a new main screen fix any issue with data being interpreted / sent to the ICU, etc.? I mean, is there ANY chance my issues would be fixed by changing the screen only?

    Thanks for any help / advice.

    [​IMG]
     
  2. kdday

    kdday Member

    Joined:
    Oct 29, 2016
    Messages:
    633
    Location:
    AZ
    No.
     
    • Informative x 1
  3. kdday

    kdday Member

    Joined:
    Oct 29, 2016
    Messages:
    633
    Location:
    AZ
    What firmware version are you on?
     
  4. Axael

    Axael Member

    Joined:
    Feb 15, 2017
    Messages:
    130
    Location:
    Belgium
    Latest : 2018.18.2

    But the first time this issue appeared was on a previous firmware, do not remember which one (though it was "only" the airbag light being on and system sounds not working anymore).
     
  5. brkaus

    brkaus Active Member

    Joined:
    Jul 8, 2014
    Messages:
    4,961
    Location:
    Austin, TX
    The screen will fix the yellow bar.

    The screen kit comes with the MCU or without. Depending on what is available.

    I’ve had the missing sound too.
     
  6. Axael

    Axael Member

    Joined:
    Feb 15, 2017
    Messages:
    130
    Location:
    Belgium
    According to the guy from the SC, only the screen itself has been ordered because "the technician said that'll fix the issues", not the kit / MCU behind it. So indeed, I don't think that changing the screen will fix anything else than the yellow bars - but I might be wrong, which is why I'm asking advice here.
     
  7. brkaus

    brkaus Active Member

    Joined:
    Jul 8, 2014
    Messages:
    4,961
    Location:
    Austin, TX
    Here is what they replaced on mine. No idea what is really included in the part number.

    Concern: Customer states: there is a yellow border around my touchscreen.
    Corrections: Media Control Unit (Touchscreen)
    Removed and replaced Media control unit touch screen. Verified screen is operating as designed.
    Parts Replaced or Added
    Part Quantity
    MCU NA PREMIUM - Model S and Model X 1 (1045006-00-E)
    Pay Type: Warranty
     
  8. Axael

    Axael Member

    Joined:
    Feb 15, 2017
    Messages:
    130
    Location:
    Belgium
    Thanks brkaus.

    I think "touchscreen" really means it's only the screen, and nothing else (not the actual MCU kit). Did this replacement fix your issue with the sounds from turn signals / AP missing?
     
  9. Axael

    Axael Member

    Joined:
    Feb 15, 2017
    Messages:
    130
    Location:
    Belgium
    I didn't have any news from the SC though they promised to call me back. So I wrote a note on Tesla's website using the "escalate this issue to a manager" option. Wait & see.
     
  10. brkaus

    brkaus Active Member

    Joined:
    Jul 8, 2014
    Messages:
    4,961
    Location:
    Austin, TX
    I’ve had the “quiet” problem twice in 3 months. Both before the replacement. I’ve had can’t stop beeping problem twice recently, after replacement.

    Reboot resolved in all cases. I’m guessing firmware bug.
     
  11. Axael

    Axael Member

    Joined:
    Feb 15, 2017
    Messages:
    130
    Location:
    Belgium
    Well, it's not because rebooting your computer helps that the issue comes from the software. :)

    I had a prompt answer from a Tesla representative (about 2 hours after my mail using the "escalate issue" option) who told me they were reaching out to the SC to check that with them and that they'll insist on them taking this seriously, getting back to me, etc.

    I asked about the replacement and they told me it was indeed the whole MCU and not the flatscreen only which was ordered.

    Today I had a call from the SC asking me to do some tests because they think my issues will be fixed by the latest update I received (on Monday).
     
  12. jpaz

    jpaz Member

    Joined:
    Feb 11, 2018
    Messages:
    83
    Location:
    Phoenix, AZ
    Just noticed the "yellow" border around my screen yesterday. I was thinking it was just a shadow from the surround but based on this thread it is real.
     
  13. brkaus

    brkaus Active Member

    Joined:
    Jul 8, 2014
    Messages:
    4,961
    Location:
    Austin, TX
    It’s real. :(
     
  14. Axael

    Axael Member

    Joined:
    Feb 15, 2017
    Messages:
    130
    Location:
    Belgium
    It is. And they finally gave me an appointement at the SC for July, 17th. Which is after my holidays.

    Of course when I reported the issue back in March, I asked it to be fixed before my holidays, thinking that 3-4 months would be enough. Apparently it's not. And since then, I've got quite a few new issues to report...
     
  15. Axael

    Axael Member

    Joined:
    Feb 15, 2017
    Messages:
    130
    Location:
    Belgium
    Well, after using the "escalate this issue..." feature on the website a few times, I spoke with a representative which allowed my appointement to be moved forward to June, 13th.

    They said they've got the flatscreen itself as well as the MCU in case it was necessary to change it.
     
  16. Axael

    Axael Member

    Joined:
    Feb 15, 2017
    Messages:
    130
    Location:
    Belgium
    Well just a quick update on this one.

    I dropped my car at the SC this morning and received a P90D as a loaner. That's nice. :)

    What's not very nice, is that they just called me to tell me that they did tests, and that they'll have to change the main high voltage battery of my car, which will definitely take longer than expected.
     
  17. AustinP

    AustinP Member

    Joined:
    Apr 6, 2015
    Messages:
    411
    Location:
    Belgium
    I had this also with 18.2 and it went away since the last upgrade. But it’s only installed since Monday, so fingers crossed.
     
  18. Axael

    Axael Member

    Joined:
    Feb 15, 2017
    Messages:
    130
    Location:
    Belgium
    Thanks for your input. I experienced this particular issue multiple times (4, actually). Not with the latest update yet, but with multiple previous firmwares.
     
  19. TSLA Pilot

    TSLA Pilot Member

    Joined:
    Mar 12, 2013
    Messages:
    672
    Location:
    United States
    Axael,

    Not to derail your thread, but would you mind sharing the details on the symptoms you had that now necessitate the replacement of your HV battery?

    Quite curious.

    Thanks!

    p.s. Also: Is this an 85, 90 or 100 kWh battery? Distance traveled? Number of SC visits? Typical charge level?
     
  20. Axael

    Axael Member

    Joined:
    Feb 15, 2017
    Messages:
    130
    Location:
    Belgium
    Hey TSLA Pilot, no worries.

    As said in the thread title, it's a 90 kWh battery.
    The car was delivered late March or early April last year (production at Freemont factory early January 2017 I think).
    I did a bit less than 30k kilometers with it.
    Typical charge level is between 60 and 80. I charged it to max capacity (100%) maybe 4 times in a year, when I really needed max range to travel.
    Car went to SC some thing like 3 times + this one, I think.

    Now onto the symptoms, I had quite a few issues that I thought were related to the MCU failing. Aside from a lot of Spotify connection issues, I had 4 times a more general failure which consisted of a lot of "small" issues happening together: external temperature reading not available, tire pressure reading unavailble, power consumption frozen, pano roof unresponsive, air suspension setting unresponsive, system sounds (turn signals, AP, etc) disabled, airbag icon ON on the dashboard. Everytime this happened, kilometers ridden weren't taken into account on the ODO meter, and I had to reboot to 'fix' the issues.

    Now, I don't know if this issue is directly linked to the battery failing. What they told me on the phone is that they changed the main screen (they didn't specify if it was the flatscreen only or the whole MCU) and that they did measures while doing this. It appeared, as far as I understood, that signals (voltages?) coming out of the high voltage battery weren't within spec and that it was a "serious" issue that needed the battery to be replaced.

    Battery part number is 1088790-00-A.
     
    • Informative x 1

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC