TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC
Start a Discussionhttps://teslamotorsclub.com/tmc/tags/

And now the GPS...

Discussion in 'Model S' started by JetKit, Dec 29, 2016.

Tags:
  1. JetKit

    JetKit Member

    Joined:
    Nov 16, 2016
    Messages:
    63
    Location:
    Florida
    Not a surprise, as most of the things on MS are sub-par, but the Navigation is driving me crazy.
    It frequently shows my car on a different road, sometimes more than a block away.
    Using the maps any of my phones yields the correct position on them, but my MS really things we are somewhere else.
    Has anyone else experienced this?
     
    • Disagree x 3
  2. HX_Guy

    HX_Guy Member

    Joined:
    Sep 1, 2012
    Messages:
    447
    Location:
    Phoenix, AZ
    No issues here. I've been quite impressed with the navigation...super easy to use, I love the "live" search that auto populates as you type in the address. I'd say best navigation I've used in any vehicle so far (previous cars were M235i and Audi A4).

    Sorry I was of no help.
     
  3. robby

    robby Member

    Joined:
    Aug 25, 2014
    Messages:
    461
    Location:
    Andover, MA
    Never in New England where I live, but I recently experienced this on our drive to Mont Tremblant, just north of Montreal. Maybe they have different providers for different regions.
     
  4. msnow

    msnow Active Member

    Joined:
    Jul 14, 2015
    Messages:
    4,962
    Location:
    SoCal
    Yes all the time since I've owned it. Plenty of threads on how terrible Nav is on this forum. Most of us just use our phones if it's critical to get somewhere. Sad.
     
  5. Eclectic

    Eclectic Member

    Joined:
    Nov 8, 2014
    Messages:
    447
    Location:
    Bay Area & Montana
    Nav is so bad on mine that I could have sworn that it showed me driving on Mars a few days ago.
     
    • Funny x 5
    • Like x 1
  6. GuyGadois

    GuyGadois Member

    Joined:
    Oct 5, 2015
    Messages:
    134
    Location:
    SLO
    never one issue here
     
  7. LoL Rick

    LoL Rick Like Buttah

    Joined:
    Apr 21, 2014
    Messages:
    722
    Location:
    Land O Lakes, FL
    Mine will occasionally do that for a few minutes after spending the night in the garage. When it happens it takes 5-10 minutes to get a GPS fix. Days with heavy cloud cover are worse. If it persists, try a screen reboot.
     
  8. byt

    byt Member

    Joined:
    Nov 26, 2012
    Messages:
    224
    Location:
    Redwood City, CA
    Like I've said on other threads, I depend on Waze on my phone for navigating. It's accurate, faster, calculated based on real world traffic and even gives me a heads up on objects, cars stalled and police ahead on my route. So much wish I had the full blown Waze app on the 17" screen that's not on the browser. Works fine in my small iPhone screen for now.
     
  9. dweeks

    dweeks Member

    Joined:
    Aug 26, 2014
    Messages:
    170
    Location:
    Flagstaff, AZ
    No, not ever, in 2 ½ years of MS driving.
     
  10. jbcarioca

    jbcarioca Active Member

    Joined:
    Feb 3, 2015
    Messages:
    2,666
    Mine too. Luckily I spotted familiar topography from my college astronomy class so I managed to navigate back pretty well.
     
    • Funny x 1
  11. jbcarioca

    jbcarioca Active Member

    Joined:
    Feb 3, 2015
    Messages:
    2,666
    Since your car is so sub-par, is it for sale?
     
    • Like x 1
    • Funny x 1
  12. AmpedRealtor

    AmpedRealtor Well-Known Member

    Joined:
    Jun 30, 2013
    Messages:
    5,404
    Location:
    Buckeye, AZ
    I've never had such issues in my three years of ownership. I've driven all over Arizona and California. Maybe you should ask your service center?
     
  13. C_A_Braun

    C_A_Braun Meet Voodoo, Our S75.

    Joined:
    Jul 19, 2016
    Messages:
    66
    Location:
    So Cal / So Nev
    Only problem I have with the NAV is I know it is near perfectly straight shot from my home to the interstate and for some reason the NAV wants me to drive almost 5 miles out of my way. Even when I go my way the NAV keeps telling my to do a U Turn and go back the way it wants me to go until I am about 1/2 mile from the highway at which time is says "OK, just go straight one more half mail and get on the freeway instead of now doubling back nearly 10 miles to get on the highway over there where I was telling you. a moment ago"

    These are roads that have been well established for at least 4 years and they show up on the NAV, just the NAV doesn't seem to want me to use them.
     
    • Like x 1
  14. gjunky

    gjunky Waiting for the Model ☰

    Joined:
    Mar 26, 2012
    Messages:
    831
    Location:
    Scottsdale, AZ
    Has been working fine for us as well. Does you mobile app show the car in the wrong location as well? (I assume it would)

    I agree with the previous suggestion: Take it to a service center. Take pictures of the Car's Nav showing you in the wrong position and a screen shot of your phone's Nav as proof.
     
  15. macbeth

    macbeth Member

    Joined:
    Nov 6, 2014
    Messages:
    29
    Location:
    United States
    My nav has been awesome, I have had the car since October 2012. The only problem is in the morning to get GPS fix while I am leaving my garage. I have driven all over the US and Canada. I have issues in Canada, especially Niagara Falls, as my cell signal sucks and the maps do not redraw fast enough.
     
  16. RAW84

    RAW84 Member

    Joined:
    Oct 6, 2014
    Messages:
    393
    Location:
    Boston
    Silly routes is why I stopped using NAV and rely on my phone. I haven't had an issue with it properly locating my car, tho.
     
  17. thimel

    thimel Member

    Joined:
    Feb 27, 2015
    Messages:
    410
    I love the Tesla Nav. I find the accuracy amazing. I sometimes zoom in on the map and it typically even shows me in the correct lane. I've had the problem the OP describes for short periods of time in another car I drive. It happens after I start the car and it doesn't have a good GPS lock. It uses inertial navigation during that time and will be somewhat off about the location.
     
  18. artsci

    artsci Sponsor

    Joined:
    May 10, 2012
    Messages:
    5,334
    Location:
    Timonium, Maryland
    Same for me. No problems. When I use Waze, which for many is the gold standard, at the same time it most often follows the same route. Curious: If you think so many things on the Model S are subpar, why did you buy one?
     
  19. rory breaker

    rory breaker Member

    Joined:
    Aug 11, 2016
    Messages:
    121
    Location:
    TX
    OP, I have had that issue happen 2x over the 6 months I've had the car. I know what you mean, it's like a few blocks off from where you really are. Takes 10m to get its bearings again. Rare occurrence.

    To other folks saying they get dumb routes, I get that as well. Will tell me to take an exit before the exit I want, to take back roads, when I can access the location directly off the next exit.

    Overall I give it a B, because the voice control is pretty rad.
     
  20. DMC-Orangeville

    DMC-Orangeville 85D and John Deere 5100E

    Joined:
    Feb 14, 2015
    Messages:
    366
    Location:
    NW of the 6ix Canada
    No issues in 2 years of driving in Canada and USA

    I suspect this is the change over of cell carriers. I have always found a few "holes" in LTE coverage when crossing the borders in either direction
     

Share This Page