Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • Want to remove ads? Register an account and login to see fewer ads, and become a Supporting Member to remove almost all ads.
  • The final cut of TMC Podcast #27 is available now with topics time-stamped. We discussed: Consolidation in LiDAR manufacturers; Volvo EX90 shipping with LiDAR; FSD Beta Full Release in N.A.; FSD detecting autopilot cheats, Gwen Shotwell directly overseeing SpaceX Starship; and more. You can watch it now on YouTube. We should have it published to podcast networks shortly.

Android 13 update phone key not working

M3 and MY here with a Pixel 6 and Android 13. Wish that I had read all of this before updating. Adding my 2 cents here so that I follow the thread.

The only reason I was able to get into the car was because the "walk away lock" that I was used to was no longer working either.

I experienced this but did not put together what was going on. Thanks @JD M3 for the putting it together for me. I will keep an eye on the lock.
 
I just updated my Pixel 5 to Android 13. Since that time I have been having issues with my phone key. At first it worked very sporadically. Now I can't even get it to connect. I've tried uninstalling the app, forgetting Bluetooth, rebooting the car, allowing all permissions etc. Is anybody else having this issue? Any advice would be greatly appreciated.
This happened to me as well. Tried everyone's ideas. Finally I just restarted my phone and it worked.
 
Been 24ish hours now. And it's been stable after I did the following.

Everything is still working (Garmin watch and phone key).

Uninstalled Tesla app.
Went into android settings > system > reset options > reset app preferences
Rebooted phone
Removed phone key and Bluetooth from car
Rebooted car
Installed app
Connected key and Bluetooth

FWIW I didn't uninstall my Garmin connect app this time around and it started to work after the 'reset app preferences' step.

Heads-up, you'll need to go into each of your apps and reset permissions (notifications, locations, contact access, camera etc). A pain, but so far worth it if the fix takes.
I had the same problem with my Pixel 6 Pro, the Tesla phone app and my Fitbit Sense. I followed Tymco's lead, but found it would only work after I turned off my VPN on my Pixel as Tesla suggested on their Support page. For now, phone key is working, Sense can sync again, and Powerwall app is on, but without continuously updated data flow. Will see how stable the fix is...
 
My Pixel 6 stopped working yesterday, and after trying some simple restarts, etc, I went through the procedure I've done so many times it's almost automatic (I have serveral drivers in my family, plus I have two phones, and have to reinstall the app a few times for other issues throughout the year).

Remember, there is the bluetooth connection, and then there's the key setup, which are separate.

Make sure you have a Tesla card key. Otherwise, you can't do anything.
1. Delete the phone as a car key in the Tesla locks section.
2. Forget the phone in the car's bluetooth settings.
3. Forget the Tesla in the phone's BT settings.
4. Add new BT device in Tesla's BT settings, making sure phone is in pairing mode.
5. Follow prompts to confirm pairing with phone.
6. Go to Tesla locks section, and add new key.
7. Follow prompt to run app and set up key.
8. Select the phone in the key list, and select your user profile from the top to associate it with the key.
 

dysys

Member
May 13, 2022
13
11
UK
To those having problems, is your phone already connected to a different Bluetooth device (e.g. a smart watch or other device) when trying to use the phone key? Phone key works flawlessly with MY / Pixel 6 Pro on Android 13 when I'm not wearing my Fossil watch. Yet it fails with the watch on.
 

Tex82

New Member
Aug 23, 2022
3
0
Baytown
I am having the same problem with my Pixel 6 pro in 22 MSLR. I never had a problem in my previous model Y. The bluetooth is not auto connecting to my phone for music (set as priority device). Also the door handles are not presenting upon approach. When I get in the car seems like it turns off. When I remotely turn the A/C on, then get in, it goes back to full blast like I haven't entered the car yet and the screen go dark. Foot on the brake and it comes back to life. I wouldn't know any different but my model Y never did that. I have only had it for a week so hopefully I can get this sorted out.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top