Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Android 9 (Pie) and Bluetooth

Avendit

Member
Apr 18, 2019
817
535
EDI
Not sure if this is specific to my one plus or more general for the latest Android. I was having real problems with using my phone as the master key for keyless entry, often left stranded yanking at the door handle like some Muppet. Kept finding I would have to at least manually wake my phone and often re-open the Tesla app.

Turns out it's the even more aggressive power saving in Pie that was killing it.

Pop over to settings/battery/battery optimisation/Tesla and set 'dont optimise'. Suddenly it works much better, and doesn't seem to have made any difference to my phone.

Anyone else with this problem, or isit just my phone?
 
  • Informative
Reactions: Roy W.

Jason71

Active Member
May 8, 2019
2,844
2,723
Shropshire
Not sure if this is specific to my one plus or more general for the latest Android. I was having real problems with using my phone as the master key for keyless entry, often left stranded yanking at the door handle like some Muppet. Kept finding I would have to at least manually wake my phone and often re-open the Tesla app.

Turns out it's the even more aggressive power saving in Pie that was killing it.

Pop over to settings/battery/battery optimisation/Tesla and set 'dont optimise'. Suddenly it works much better, and doesn't seem to have made any difference to my phone.

Anyone else with this problem, or isit just my phone?
Samsung seem to have removed the ability to do that via the battery settings in 9 on my S10 and I find my podcast app just stopping unless I leave it in the foreground now.
Eventually I found if I go to settings and search for "optimise" it takes me to a "special access" menu where I can select "Optimise battery usage" and do the same as you are suggesting select "don't optimise" for the app. Whether it works I don't know yet but for anyone with a Samsung having a similar problem to you this seems to be how you have to do it now.
It feels as if they are deliberately trying to bury that setting
 
  • Informative
Reactions: Avendit

Yev000

Active Member
May 3, 2019
1,334
909
Knaphill
Anyone else with this problem, or isit just my phone?

Yep, same.

Also if the car has no connectivity the phone app seems to keep checking for a bluetooth connection. Seems when the car can call home as it were there is no issue.

I was parked at work (no LTE signal, no WiFi) and in a meeting room with no LTE signal on the phone, but connected to wifi.... You can see the battery drain, 1% every ~5 min. Turning the bluetooth off fixed it.

Sometimes it works fine. My theory is that the phone panics that it cant connect to the car and keeps trying, turning off bluetooth makes it give up.

And the same issue with the car waking up. If you don't poke it in the morning, you can be standing there yanking on the door handle for about 15 secs. Some times there is no issue...
 

LukeT

Member
Apr 9, 2019
729
336
UK
I've had different app issues so thought I'd try the same. If it helps, on my Samsung S8 you can disable battery optimisation but the route to it is a bit messy. Go to Settings - apps - Tesla - Battery - optimise battery usage, then search for Tesla again and turn it off.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top