Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Android connects, music title displays but does not play

Alexgd

Member
Dec 10, 2018
15
4
Alexandria, VA
My moto X4 phone connects via Bluetooth to my car fine. I can receive calls via the phone & car successfully.

When I select "phone" on the car's audio menu, and then play something from the phone via Google Play or another app, the Tesla displays the name of the track, and the play/pause button goes to play. However, no sound comes out.

I have rebooted and reconnected and all that, still nothing.

any ideas? Thank you.
 

sceptic

Member
May 5, 2019
305
140
california
Has it ever worked? Have you tried another phone or connecting your phone to another Model 3?
Okay - I had exactly this problem after 3 months of it working fine. Tesla set up mobile apt which they then canceled the day before it was supposed to happen with no f/u service center apt. Out of frustration and doing all the various trouble shooting steps multiple times (and in my case a very old phone played properly but the one I had been using would not) I decided to see if I could pair to a different M3.

So.......... I drove to the Tesla showroom and was able to pair my phone with their Model 3 (not demo one but a loaner). Therefore demonstrating that it was NOT my phone that was the problem but the car!!!!!!
Luckily the guy that had cancelled the mobile apt was there and offered to help (after I lifted myself off the floor since I had been blown off so many times before here was someone willing to help!) we went to my car and he did all the same things (hard, soft reset, pair, etc),

No go, his phone paired to my car and played music but not mine. Last thing he did was disconnect the 12v battery and still no luck so he agreed to expedite SC apt (for some sort of ?indepth diagnostics). Walked back to my car 5 minutes later listening on bluetooth headset (which had worked all along) and when I opened the door THE SOUND PLAYED ON MY HEADSET AND THROUGH THE CAR!!!!!!!!!!!!!!!!!!

His explanation was that sometimes the computer gets "overloaded" (which I think was an I don't know why this happened) and the reset had apparently worked. (the double play was b/c he had enabled dual play on bt on my phone). I have a basic model with 900 miles so am a bit confused how the computer could have been overloaded but.......so far it still works after a few days.

My conclusion
1) The mobile apt should not have been cancelled - clearly the steps of seeing if my phone paired properly with his car and then trying the 12v disconnect could have been done by them
2) Had I not decided to see if the phone paired with another car AND been lucky enough to run into a helpful person I would have been days to weeks to get an apt for SC and then days without the car for diagnosis (which is what he said it would be when we thought the problem wasn't solved
3) There may be a fault or ongoing issue which hasn't been reported enough yet (so far you and I are the only reports I've seen)??????
4) DON'T TRY TO DISCONNECT THE BATTERY YOURSELF. It wasn't just the battery but another module beneath the rear seat that he disconnected - it took a few minutes but he definitely did not want me to do it myself if the problem reoccurred.
 

Alexgd

Member
Dec 10, 2018
15
4
Alexandria, VA
This is the first time I have tried to use Bluetooth music streaming with the car. Good thought, I will try my iPad and see if that works, and will report back. Thanks for your help and story. G
 

Alexgd

Member
Dec 10, 2018
15
4
Alexandria, VA
Update: Okay. I added my iPad as a Bluetooth device to my M3, and was able to play music from it through the car's speakers. Then I disconnected the iPad and connected my Android phone again. This time it worked, and the phone played over the car's speakers. I have no idea exactly what changed to make it work.

Thank you for your helping in getting to this outcome. Best, G
 

Alexgd

Member
Dec 10, 2018
15
4
Alexandria, VA
Okay, I spoke too soon. Tried again with the Android phone later in the day, same symptoms as before. The phone is connected via bluetooth, when I set an app to play music on the phone, the track title appears on the Tesla display, the play/pause buttons change, but no music comes out. So it looks like an intermittent problem.

I am back to asking for help. Thanks all.
 

sceptic

Member
May 5, 2019
305
140
california
So far mine has worked for a few days and mine never did work even after pairing with other phones until the complete reset so even though your problem was temporarily fixed I would think a mobile call to try the 12v cut off to reset the system would be in order.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top