TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Anyone else notice degraded Lane Change functionality with 2019.8.5?

Discussion in 'Model 3' started by Colgate2004, Apr 9, 2019.

  1. Colgate2004

    Colgate2004 Member

    Joined:
    Nov 2, 2018
    Messages:
    38
    Location:
    New England
    I got the 2019.8.5 update this past week (M3 LR AWD) then a day or two later was driving home from Boston and turned on auto steer and navigate on autopilot. Hoo boy.

    Every. Single. lane change failed. The car would begin to change lanes, cut back into the original lane, start to change lanes again, cut back into the first lane again, and repeat, each time getting jerkier and more violent until I yanked the steering wheel to override it and shut off autosteer.

    It's like it was sensing some phantom car in the other lane that wasn't actually there.

    Now, this was Boston traffic so there were lots of cars on the road, but in each case there was plenty of room for the car to change lanes.

    Unfortunately I still have limited experience with auto lane changes when there are other cars on the road (thus far other than that day I've really only used it when I was by myself on the road) so I don't really have much experience to compare it to and can't be sure if it was the software update or if it would have behaved the same way in the same traffic conditions beforehand. Maybe it wasn't malfunctioning and it always does that if there are other cars on the road?

    But it seems like starting to change lanes then jerking back, repeatedly, is not a good thing.

    (EDIT: Once I got out of traffic and was the only car on the road, lane change worked again as expected.)
     
  2. Hobari

    Hobari Member

    Joined:
    Oct 3, 2018
    Messages:
    17
    Location:
    Denver, CO
    Just drove 2,000 miles in NM and TX with very little traffic and I had the same experience, but for only about 10% of my lane changes.
     
  3. McCaesar

    McCaesar Member

    Joined:
    Apr 27, 2018
    Messages:
    135
    Location:
    Oakville, Ontario, Canada
    I've had similar on prior versions, and only on the right ride of the car. I cleaned the cameras from road salt and dirt and it worked better after that.
     
    • Informative x 1
  4. Hobari

    Hobari Member

    Joined:
    Oct 3, 2018
    Messages:
    17
    Location:
    Denver, CO
    Great point. I was being bombarded with bugs. The insect kind.
     
    • Funny x 1
  5. Ludalicious

    Ludalicious Member

    Joined:
    Feb 22, 2018
    Messages:
    617
    Location:
    Vancouver
    Also noted I was getting allot of warnings that my side camera couldn't read. Definitely need to keep the cameras clean and clear, even the smallest amount of water effected them
     
  6. Waltjo

    Waltjo Member

    Joined:
    Mar 28, 2019
    Messages:
    19
    Location:
    San Jose, CA 95120
    I see the aborted lane changes at about the rate as I did before the 8.5 SW. In my case it's not dirty sensors. But maybe more frequent with heavier traffic.
     
    • Informative x 1
  7. brandonee916

    brandonee916 Member

    Joined:
    Aug 8, 2018
    Messages:
    271
    Location:
    Sacramento, CA
    Actually my experience has been quite the opposite. Lane changes hardly ever fail now.... reboot the car and see if it improves.
     
  8. Colgate2004

    Colgate2004 Member

    Joined:
    Nov 2, 2018
    Messages:
    38
    Location:
    New England
    Hm, yeah, pretty sure my issue wasn't dirty sensors/cameras, but I'll clean them and try again!

    LOL, um, okay, super noob question here but... how do you reboot the car? :rolleyes:
     
  9. sdrevik

    sdrevik Member

    Joined:
    Jul 14, 2018
    Messages:
    107
    Location:
    Knoxville, TN
    Not degraded, but I turned off auto-lane-change on NOAP. It kept moving back towards lanes with on-ramping cars when i knew it was safer to stay in the left lane.
     
  10. LPLP

    LPLP Member

    Joined:
    Feb 22, 2019
    Messages:
    10
    Location:
    Los Angeles
    I also turned off auto lane change on NOAP. It kept trying to get me into the carpool lane every single time even though the lane I was in was actually going faster than the carpool lane. Or sometimes, I just want to be in the regular lanes if the traffic is light and move around instead of being stuck in the carpool lane.
     
  11. LPLP

    LPLP Member

    Joined:
    Feb 22, 2019
    Messages:
    10
    Location:
    Los Angeles
    For hard reboot, hold down the 2 controls on the steering wheel at the same time for 10 seconds, with your foot pressing on the brake. The monitor should go black and come back.
     
    • Informative x 1
  12. Fernand

    Fernand Member

    Joined:
    Mar 22, 2019
    Messages:
    389
    Location:
    Northern california
    Some people say that if you feel the car is getting wonky,
    and you want to reboot it, wait until you're stuck in bumper
    to bumper traffic -- and a good song comes on ;-) ;-) ;-) ;-)
     
  13. Fernand

    Fernand Member

    Joined:
    Mar 22, 2019
    Messages:
    389
    Location:
    Northern california
    As the AI gets more autonomous, might we expect
    the individual personality of each car to emerge?
    My Nikki has been mostly friendly, wise and obedient ...
    ... so far. Do we need to praise and reward them?
    Does waxing or sealing please them more? Do they
    like being buffed? Maybe some just get annoyed.
     
    • Like x 1
  14. m3tx

    m3tx Member

    Joined:
    Jul 3, 2018
    Messages:
    70
    Location:
    Houston, TX
    Had a long drive this morning, first half of the drive NOA did pretty good, changing lanes to the left and the right. Then I tapped to cancel a lane change to the right and that got the autopilot to go completely wonky for the rest of the drive, car initiated a violent lane change to the right 30 sec after I canceled that change, and with no signal. I turned off autopilot, then back on but car would be unable to complete a lane change to the right for the rest of the drive. On the drive tonight, things had gotten back to normal, which in my case means decent NOA behavior in moderate traffic, terrible in heavy traffic
     
  15. Colgate2004

    Colgate2004 Member

    Joined:
    Nov 2, 2018
    Messages:
    38
    Location:
    New England
  16. jdcollins5

    jdcollins5 Member

    Joined:
    Aug 14, 2018
    Messages:
    424
    Location:
    Wilmington, NC
    I have seen nothing but continued improvements.
     
    • Like x 1
  17. Lovethe3

    Lovethe3 New Member

    Joined:
    May 19, 2018
    Messages:
    2
    Location:
    Usa
    I am in the Early Access Program (got my 3 and EAP last June) and got the NOA auto lane change without stalk confirmation 2 months ago. When I got that, I had the same issue with lane change, but I figured out that it was because of the cameras going through calibration. You can even see the percentage of calibration if you go to the Autopilot page. Things should go back to normal when the calibration is done. Long drive is nothing but pure joy after that.
     
  18. M109Rider

    M109Rider Member

    Joined:
    Apr 8, 2018
    Messages:
    537
    Location:
    Kitchener, Ontario
    I used NOA a lot yesterday while out and about.
    Worked really well all around. 95% of my trip was on NOA.
    Love it.
     
  19. Snuffysasa

    Snuffysasa Member

    Joined:
    Feb 24, 2017
    Messages:
    267
    Location:
    Minneapolis

    I have this same firmware version on my Model 3, and I have the exact same experience...

    I know I driven other Teslas on several older firmwares and the lane changes were waaaay better. Hopefully its just an issue with this update.

    Did this issue go away? Hopefully when I get an update it goes away.
     
  20. OCR1

    OCR1 Active Member

    Joined:
    Jan 28, 2018
    Messages:
    1,470
    Location:
    Southern California
    On a morning drive today my car twice attempted to change lanes to the left and violently jerked back to the current lane. There was a car behind me in the left lane but there was plenty of room for me to enter the lane. I had to turn off AP to make the lane change.

    It also kept telling me I need to change lanes to the left even though I was within 2 miles of my exit and there was no traffic. I’m not sure why but I just ignored it. I get a lot of lane change requests that don’t seem to make any sense to me.

    I like AP, but I’m not that comfortable with the rest of the features personally. I know others feel differently.
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC