Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • The final cut of the 9th episode of the Tesla Motors Club Podcast, featuring Chad Schwitters, the former president of Plug In America, is now available. You can watch it now on YouTube or listen to it on all major podcast networks.

AP 1 removed feature?

Not sure when this occurred but I lost ability to automatic change lanes by using the signal stalk. This was always available before. I have a 2016 AP 1 software 2020.48.37.1

Looked under "Autopilot" settings but didn't see the option to activate it. Was it removed or am I missing something? If I'm not mistaken this was an advertised feature upon purchase.
 
Not sure when this occurred but I lost ability to automatic change lanes by using the signal stalk. This was always available before. I have a 2016 AP 1 software 2020.48.37.1

Looked under "Autopilot" settings but didn't see the option to activate it. Was it removed or am I missing something? If I'm not mistaken this was an advertised feature upon purchase my 2016 AP1 car
Hi @odguy ,

My wife's AP1 car shows "Autosteer" and "Summon" on the Autopilot tab.

On the Software screen it shows "Highway Autopilot."

Shawn
My 2016 AP1 car still does auto lane change. Not sure why yours wouldn’t be. I’m on 2021.4.10.1.
 
Hi @odguy ,

My wife's AP1 car shows "Autosteer" and "Summon" on the Autopilot tab.

On the Software screen it shows "Highway Autopilot."

Shawn
Yes I have those same options. It used to have an option to toggle something like "auto lane change (beta)". does her car still auto lane change?

@LateToTheParty does your autopilot tab have a toggle button for auto lane change? Perhaps I just need to wait for an update.
 
Hi, I have also ‘16 Model S with the same SW and my drives take place in Europe. Tesla have tweaked AP here to comply with EU regulations and as of this we can’t (at least it’s on certain type of roads) use this function any more. I believe it happened around the end of 2019 but it was only the case here in EU. So your situation is interesting now.
Coincidentally I have screenshot of the autopilot menu from NA car (courtesy to Fred Lambert) from that time so it shows that there is not such selection you suggest:
4015692D-24F2-4736-9AFE-698B17D38EEE.jpeg
 
Yes I have those same options. It used to have an option to toggle something like "auto lane change (beta)". does her car still auto lane change?

@LateToTheParty does your autopilot tab have a toggle button for auto lane change? Perhaps I just need to wait for an update.
Here you go!

I just got the infotainment upgrade completed this week. Prior to the upgrade, I was still on the same software that you are running and at that time, I still was able to auto lane change while AP1 was turned on.
 

Attachments

  • IMG_0721.jpeg
    IMG_0721.jpeg
    462.6 KB · Views: 43
  • Informative
Reactions: David29
My AP1 2015 P85D still auto lane changes after the MCU2 upgrade.
I still had it after the MCU2 upgrade but it is gone now, I'm not sure when it went away but yesterday i was out on the freeway and it wouldn't move over when i hit the turn signal. But it def was there after the upgrade because i remember using it like a month ago while traveling. but the setting is gone now for some reason. 2014 P85D 112k miles, software v 2021.4.12
 
  • Informative
Reactions: David29
Perhaps someone can use this tip, I was able to use auto lane change once last year November but it was just one lucky time... If you start the manoeuvre by turning on the turn-signal then a bit later slightly ”help” the car by turning the wheel, but very slightly... This was the thing that I did helped me, unfortunately only once...
 
Hi @odguy ,

The screen you show says the car is on a software trial...
Did you buy the software? Or did it expire?

Shawn

Edit: Mine is also on MCU2 like @LateToTheParty
I found that image online just to show there was a dedicated toggle for the option. Current software does not have a toggle any longer but appears is activated for auto lane change.
I still had it after the MCU2 upgrade but it is gone now, I'm not sure when it went away but yesterday i was out on the freeway and it wouldn't move over when i hit the turn signal. But it def was there after the upgrade because i remember using it like a month ago while traveling. but the setting is gone now for some reason. 2014 P85D 112k miles, software v 2021.4.12
I'm on MCU1 I think its unrelated to MCU version? Both on they way to and from work today it worked right away upon using turn signal. I only activate when its clear in the next lane and gave ample time but it didn't do anything yesterday and the day prior. Not sure why but in any event hopefully yours will return too.
 
I'm on MCU1 I think its unrelated to MCU version? Both on they way to and from work today it worked right away upon using turn signal. I only activate when its clear in the next lane and gave ample time but it didn't do anything yesterday and the day prior. Not sure why but in any event hopefully yours will return too.
You're also running some old ass software version according to your OP, you're on 2020.48.37.1 Where as I'm on 2021.4.12
I'm going for a drive today and I'll hot the freeway for a bit so I'll try it again. Maybe it was a fluke the other day, let the testing commence 🤯😎
 
  • Helpful
Reactions: kavyboy
You're also running some old ass software version according to your OP, you're on 2020.48.37.1 Where as I'm on 2021.4.12
I'm going for a drive today and I'll hot the freeway for a bit so I'll try it again. Maybe it was a fluke the other day, let the testing commence 🤯😎
1)to the op. I’m running the same software as you are and mine works just fine. I’ve noticed when things don’t work a quick reboot will usually take care of the issue. (I have mcu1 as well and mine randomly reboots itself several times a week (eemc failure) so I always do a reboot myself after that happens.
2)us mcu1 cars that HAVE NOT gotten the mcu2 or the new eemc as of yet are stalled on what you referred to as old software. It’s not. They’re purposefully holding us back to try to keep our MCU’s stable.
 
I have a 2014 85 S in the UK. Last week, I was on night shift and driving home, the road was empty. So I tried autopilot at 70 mph on the dual carriageway, including changing lanes to the right and back to the left. It worked perfectly. The next night, it would not change lanes at all. The only difference I could think of was that on the second night it was very windy. Perhaps it reduced the efficiency of the ultrasonic sensors so it wouldn't perform the lane change.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top