TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC
Start a Discussionhttps://teslamotorsclub.com/tmc/tags/

AP Issues

Discussion in 'Model X: Driving Dynamics' started by Dr Doom, May 18, 2017.

  1. Dr Doom

    Dr Doom Member

    Joined:
    Jul 10, 2016
    Messages:
    262
    Location:
    NYC
    Loving my MX so far. About 500 miles in and trying to use AP 2.0, I have run into numerous issues with it.

    When I turn on the auto steer, the car will jerk to the left and cross the left line and do a slight correction but be driving in the middle of two lanes. On highways, this issue is a deal breaker where I will turn autosteer as soon as this happen. I'm afraid that at higher speeds, cars around me will collide into me when I'm on autosteer. this happens almost close to 100% of the time when I am using autosteer.

    On local roads, the autopilot will still steer me more left and drift so close to the left line. But it's not as drastic as the highway. Is this a camera calibration issue? Should I take it to the center and get it looked at?

    I have 17.17.4 installed too.
     
    • Informative x 1
  2. Mark Z

    Mark Z Active Member

    Joined:
    Mar 12, 2013
    Messages:
    1,670
    Location:
    North Orange County
    Many are reporting the left sided lane line hugging. I am now on 17.17.17 and with every new release there is some improvement. Lately the vehicle uses the radar to see the vehicles on the left and right and moves closer to center.

    What is strange is how the display shows the vehicle hugging the left paint lines and doesn't move towards center when no cars are around. Worse is when it gets too bad and I disengage AP, the steering wheel shakes as if I had something to do with not being centered in the lane when the Tesla vehicle was at fault!
     
  3. Dr Doom

    Dr Doom Member

    Joined:
    Jul 10, 2016
    Messages:
    262
    Location:
    NYC
    yes. this must be a system issue. I am only turning AP on when I am clearly marked lines and the car will definitely try to cross the left lines often. I am hoping that I can get the 17.17.17 update soon. I can't get my MX to connect to wifi.
     
  4. COrich

    COrich Member

    Joined:
    Jan 5, 2017
    Messages:
    33
    Location:
    Colorado
    Dr Doom, you should take the car in to a service center. I have never seen this behavior with my X. It tracks just about perfectly in the center of the lane almost all the time. Fast, tight curves are the only time I get a drift to one side of the lane. I have 17.17.17 installed now, but 17.17.4 behaved about the same.
     
  5. wesley888

    wesley888 Member

    Joined:
    Oct 22, 2016
    Messages:
    517
    Location:
    Huntington Station, NY
    Yea, Dr Doom, sounds like something wrong with your car. I never have problem like you described.
     
  6. HookBill

    HookBill Member

    Joined:
    Dec 28, 2015
    Messages:
    561
    Location:
    The OC, CA
    I am currently on 17.17.4 AP2 MX. Have enjoyed every mile of AS and watching it improve with each update. However........over the last four days it has become a slightly different animal as it struggles to initiate lane- keep when AS is activated. Doesn't matter if it is day or night when I activate it begins steering to the left and heading over the lane line until it deactivates on its own. It takes 5-6 tries before it can center itself and settle in. Very frustrating because it has never behaved this way before under the newer AP FW. I have checked all cameras and sensors for debris but so far all are clean. Whatever it is that has inhabited my car I wish it would go somewhere else. Perhaps the next upgrade will contain an exorcist.
     
  7. Dr Doom

    Dr Doom Member

    Joined:
    Jul 10, 2016
    Messages:
    262
    Location:
    NYC
    I will try to bring it into service center. I mentioned it last time I brought it in for other things for the service people to look at but they said the firmware update should fix some of my problems.
     
  8. mrvtjh

    mrvtjh New Member

    Joined:
    Nov 1, 2016
    Messages:
    3
    Location:
    Illinois
    I have been enjoying the improvments in AP2 since the 17.17.4 update - however, today when I got in my X, cruise control and AP2 are not available. I tried a reset - no change.
    Anyone else experencing this?
    I plan on calling the SC tomorrow.
     
  9. rush6410

    rush6410 Member

    Joined:
    Sep 26, 2016
    Messages:
    234
    Location:
    Montgomery TX
    Mine pulls to the left every time as well. But, I discovered that I tend to drive to the right of the lane. With out AS when looking at the lines the display has me in the right side of the lane. So, I get jerked to the left when engaging AS. I feel like the car is scolding me to ride more center you dumb a$$.
     
  10. Alanvw

    Alanvw Member

    Joined:
    Dec 9, 2016
    Messages:
    17
    Location:
    Delaware
    I'm seeing the same left line hugging on 17.17.17 on my AP2 MX - it has definitely gotten worse with this release. Seeing it both on the highway and on smaller roads - it seems to get a little better the longer its on.
    Also, has anyone noticed that it seems to be doing worse when coming up on stopped traffic with very late breaking - scary as hell to be going 50 mph so close to stopped cars....and then slamming on the brakes at the last minute.
     
    • Informative x 1
  11. Dr Doom

    Dr Doom Member

    Joined:
    Jul 10, 2016
    Messages:
    262
    Location:
    NYC
    I don't know if I'm driving more to the right but to me, I tend to be in middle before the car will get jerked left when I engage the autosteer.

    I am noticing too that the car is more abrupt with deceleration when it's on autopilot. it'll stop short and not a gradual deceleration when I am going highway speed.
     
    • Informative x 1
  12. Mark Z

    Mark Z Active Member

    Joined:
    Mar 12, 2013
    Messages:
    1,670
    Location:
    North Orange County
    AP2 is an adventure. If the left lane line hugging with tires occasionally crossing over the dashed lines doesn't improve, there is less reason to buy this technology. The familiar problems mentioned in previous posts make it clear that it's not my car, it's the software.
     
  13. Alanvw

    Alanvw Member

    Joined:
    Dec 9, 2016
    Messages:
    17
    Location:
    Delaware
    I had the alignment on my Model X 75 fixed and the SC reinstalled the firmware (currently on 17.17.17) - AP2 auto steer is greatly improved now - no issues with left lane hugging or crossing over the center line when first engaging auto steer. Looking forward to the 'silky smooth' update...
     
  14. chillaban

    chillaban Active Member

    Joined:
    May 5, 2016
    Messages:
    2,049
    Location:
    Bay Area
    Similar thing happened to me -- the alignment on my car was a little off on delivery, and I found AP2 had a really tough time dealing with that. It would always pull hard to the side with the steering bias and then straddle the lane for seconds before finally correcting itself. And that repeated every drive.

    When they fixed my alignment, AP2 started behaving normally again. Definitely, anyone seeing an issue where AP2 consistently pulls to one side on engagement, go have your alignment checked!
     
  15. rush6410

    rush6410 Member

    Joined:
    Sep 26, 2016
    Messages:
    234
    Location:
    Montgomery TX
    I hit a curb last week that knocked my alignment pretty far off. Pull to the right pretty hard. I immediately observed the jumping of AP to the right when engaged crossing the line before straightening out. SC realigned the car. No jumping any more. Folks should check their alignment if they are having this problem.
     
    • Informative x 1
  16. Dr Doom

    Dr Doom Member

    Joined:
    Jul 10, 2016
    Messages:
    262
    Location:
    NYC
    Thanks everybody for the input and help. Going to take it to SC. Just got back from vacation so will try to get it checked out. Have a big road trip scheduled soon.
     
  17. Dr Doom

    Dr Doom Member

    Joined:
    Jul 10, 2016
    Messages:
    262
    Location:
    NYC
    So big update. I took to service center a couple days ago and they fixed the steering. It was likely a problem with the steering wheel and camera alignment. Now when autopilot is engaged, car remains in center of lane. It's buttery smooth. :) AP2 is catching up to AP1 big time.

    Any people with AP issues like I described- jerking to the left or right should take to SC and get it looked at. It's something that they can fix the hardware.
     
    • Like x 1
  18. Zelik

    Zelik Member

    Joined:
    Jul 4, 2017
    Messages:
    5
    Location:
    Taiwan
    I'm having weird issue during lane changes, the car will cross one line and halfway through the change pull back then continue completing the lane change. Scary, won't use ap for lane changing for now
     
  19. Dr Doom

    Dr Doom Member

    Joined:
    Jul 10, 2016
    Messages:
    262
    Location:
    NYC
    lane changing problems may be an issue with the camera alignment. I would record the times when it happen and then bring it in to SC and see if they can fix it.

    I have 17.24.30. Drove about 200 miles with autopilot engaged and for the most part- lane changes weren't bad. the car would be a little abrupt on accelerating into the lane it was changing into. I'm hoping the next firmware update will smooth this out. pretty impressed with how autopilot is getting.
     
  20. FlyF4

    FlyF4 Member

    Joined:
    Mar 21, 2017
    Messages:
    384
    Location:
    Sparks NV (Giga-Town)
    Uh, I will put some money on the fact that the acceleration into the lane change is likely due to the fact that you are behind a vehicle that is going slower than the max speed at which you manually set.
     

Share This Page