Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • The TMC Podcast team will be live streaming a Tesla AI Day watch party today at 4:30PM PDT. Check out this podcast clip for more details. You will be able to watch the stream on YouTube.

App log in problem

Glan gluaisne

Active Member
Supporting Member
Sep 11, 2019
2,782
2,921
UK
Bit of a weird one. I run the app on an old Sony Android tablet, that's fixed to the wall and used solely to do things like precondition the car. Periodically it's asked me to log in again, using my account password, and did this again this morning. I have tried to log in several times, each time I get an error message saying "there was an issue verifying your password".

I have the app on my iPhone and that seems to be working fine. I've tried all the usual stuff, like closing things down and restarting them, to no avail, the Tesla app on the table still refuses to accept the password.

Anyone else had anything similar, and know of a fix, please? I'm a bit concerned unless the same thing happens to the phone as well.
 

Medved_77

TM3 SR+ | MSM+Black | No FSD
Jan 20, 2020
2,219
2,397
Scotland
Are you able to run the latest version of the Tesla app if the Sony Tablet is running an old version of Android? I wonder if this is related to MFA. My app version is 3.10.9-433 if that helps?

You could also try clearing the app cache from the memory section of the app info.
 

Glan gluaisne

Active Member
Supporting Member
Sep 11, 2019
2,782
2,921
UK
It is an older version of Android, so perhaps that's the problem. Seems odd that it's only failing on the password, though.

I've tried logging on to my Tesla account, in a browser, and that works fine, no password problem at all.

I'll try the nuclear option next, uninstalling the app, clearing everything out and reinstalling it, to see if that fixes it.

So far I've seen no outward sign of 2FA being implemented - the iPhone and account log in from a browser still seem to be working just on username (email address) and password, with no additional verification that I can see.
 

Glan gluaisne

Active Member
Supporting Member
Sep 11, 2019
2,782
2,921
UK
OK, seemed to have fixed it, or it's fixed itself, not sure which.

I completely uninstalled the Tesla app, and deleted all data. Then, just to be sure, shut the tablet right down, and did a cold start. I then re-installed the app, but had exactly the same error message when verifying the password. I closed the app down, restarted it, and for whatever reason it then accepted the password and seems to be running as normal.

No external indication that there was any sort of 2FA, the app just asked for my email address and password. For now, at least, it seems to be working again, but it would be nice to understand what actually caused the problem.
 

Glan gluaisne

Active Member
Supporting Member
Sep 11, 2019
2,782
2,921
UK
The authentication flow has had big changes made behind the scenes, only recent versions of the tesla app will work from now on.

if you have the latest tesla app from the App Store you should be fine

Thanks, yes it was the latest version I re-installed. Pity the app didn't just flag up that it needed updating - would have been very useful to just have a "please update" message rather than have the thing inform me that there was a password problem.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top