TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

bluetooth/iphone problem - any ideas?

Discussion in 'Model S: User Interface' started by David.85D, Nov 18, 2016.

  1. David.85D

    David.85D Member

    Joined:
    Oct 29, 2016
    Messages:
    99
    Location:
    USA
    I am the new owner of a CPO 2015 85D. The first couple of days I didn't have this problem, but now I get a weird problem every time I get in the car. The car thinks my iphone 6 is making a call (which means it mutes the radio and brings up the call screen) yet won't let me disconnect through the car interface. The car display shows a call in progress to "My Number", but doesn't let me end the call. The iphone itself shows no call in progress.

    If I turn bluetooth off from either end (car or phone), the radio goes back to playing normally and all is well, except I have lost phone access.

    Any ideas? Think this needs to go in for service?
     
  2. hawaii118

    hawaii118 New Member

    Joined:
    Nov 19, 2016
    Messages:
    1
    Location:
    Germany
    Hi David, since 8.0 I have the same issue using an iPhone 6 plus. But rest assured it doesn't have to do with your Tesla because I have got the same problem in our BMW. I think it's an iOS issue.

    Short work around: start a phone call from the centercreen and immediately break the dial-up.
     
    • Helpful x 1
  3. simonog

    simonog Member

    Joined:
    Jan 9, 2014
    Messages:
    394
    Location:
    United Kingdom
    @david: we used to see this issues, though not for some months.

    Ensure your iPhone is running the very latest iOS. If it is, talk to the Service Centre through whom you bought the car to ensure that you have the latest car software. They can arrange a remote download if you haven't.

    I'd be pretty sure it's one of the two, and it would be helpful if you let the forum know which update cleared the error. Good luck!
     
  4. David.85D

    David.85D Member

    Joined:
    Oct 29, 2016
    Messages:
    99
    Location:
    USA
    Thanks! Tried your suggestion and it worked. Slightly modified... I was not able to initiate a new call from the center console, so I couldn't do exactly as you said, but once the car was confused, I started a new call from my iphone and then ended that call on the iphone. That seemed to allow the car to reset. So far I have been in and out of the car about 5 times and the issue has not come back.
     
  5. EK123

    EK123 Member

    Joined:
    Mar 2, 2015
    Messages:
    10
    Location:
    Reno, NV
    I bet you have an iPhone 7. . ..

    Since iOS 10 and an iphone 7 I've had bluetooth problems including intermittent connection loss, phantom calls and the recent call list not updating. Bluetooth from the phone with some other devices don't work properly. Been waiting on an apple update. 10.1.1 currently...

    I think it's apples issue.
     
  6. David.85D

    David.85D Member

    Joined:
    Oct 29, 2016
    Messages:
    99
    Location:
    USA
    I have an iphone 6. I keep it up to date. It is currently on iOS 10.1.1. The car is on v8.0 (2.44.130).

    Initiating and ending the call from the phone seems to have done the trick. 10-15 trips in the car since then and it hasn't tried to make a phantom call again. Here's hoping that my streak continues....
     
  7. Pantoot

    Pantoot Member

    Joined:
    Jun 25, 2014
    Messages:
    58
    Location:
    Arizona
    Same problem with 10.2 beta 1 and 2. Just got beta 3, hopefully this fixes it.
     
  8. Pantoot

    Pantoot Member

    Joined:
    Jun 25, 2014
    Messages:
    58
    Location:
    Arizona
    On 10.2 beta 6 and still losing bluetooth intermittently. I am beginning to wonder if its just me.
     
  9. f-stop

    f-stop Member

    Joined:
    Jul 31, 2015
    Messages:
    862
    Location:
    Vancouver BC, Canada
    strange... I just had this same problem this morning for the first time ever. Up to now (car is 1yr old) I've had zero problems with Bluetooth, whether receiving calls, bluetooth music, or syncing/displaying the calendar each morning.

    The car's last firmware update was back on Oct 31 (2.42.40), and my iPhone (7+) hasn't had its software updated for 3 or 4 weeks, so nothing has changed in that timeframe, then suddenly today this issue.
     
  10. flipb

    flipb Member

    Joined:
    Aug 31, 2016
    Messages:
    25
    Location:
    Annandale, VA
    Forgive the thread hijack, but I'm having a different iPhone/Bluetooth issue and didn't want to start a separate thread.

    I have no trouble with my iPhone connecting via BT, and I sometimes stream media from the iPhone without trouble. However, the first time (per drive) that I get an incoming call, I answer via the touchscreen, and cannot hear the other party at all. I've confirmed each time that my iPhone is outputting the call to the car via Bluetooth. Typically, the other party hangs up within a few seconds - I'm not sure whether they hear me saying "Hello? I can't hear you!" or if they hear nothing.

    Then, if they call me back, or if I call them back, BT works fine. It seems to happen only on the first incoming call of any given drive.

    Anybody had a similar experience? Recommendations?
     
  11. donv

    donv Member

    Joined:
    Jul 15, 2013
    Messages:
    594
    Location:
    Lake Jeanclia, OR
    I have this exact problem with my iPhone 5S. While I think it's an iPhone problem, I have to admit that it doesn't do it in any of my other bluetooth equipped cars.
     
  12. ethune

    ethune Member

    Joined:
    Aug 7, 2015
    Messages:
    48
    Location:
    Los Gatos, CA
    Shut off the "Hey Siri" option. With Hey siri the phone is constantly listening hence why it thinks it's on a call. This fixed all the issues for me.
     
    • Like x 1
  13. f-stop

    f-stop Member

    Joined:
    Jul 31, 2015
    Messages:
    862
    Location:
    Vancouver BC, Canada
    sounds like this may be the likely culprit, good call. I mentioned a few posts above that I've had this problem exactly once (though not again since then), but a while before I had the problem I actually was trying something with "hey Siri" turned on - something that I'm not normally using but was that day. Turned it off just now, hopefully solved.
     
  14. donv

    donv Member

    Joined:
    Jul 15, 2013
    Messages:
    594
    Location:
    Lake Jeanclia, OR
    I already have that shut off. I don't think I've ever had that turned on.

     
  15. donv

    donv Member

    Joined:
    Jul 15, 2013
    Messages:
    594
    Location:
    Lake Jeanclia, OR
    I tried making a call using the car's phone UI, and after hesitating for a few seconds, that seemed to fix it. At least for the rest of the day. We'll see what happens tomorrow.
     
  16. Lmredcar

    Lmredcar New Member

    Joined:
    May 21, 2017
    Messages:
    1
    Location:
    Saratoga CA
    I also have been having problems with my iPhone 7 since I got it. I have my hey Siri turned off and everything is updated.
    I will make a phone call from the car everything fine. One of next phone calls I make hands free they can't hear me even though iohone shows Tesla. I then need to put it on speaker this also includes incoming calls
    It is very intermittent and very annoying
    I will call service and try dialing from console
     
  17. David.85D

    David.85D Member

    Joined:
    Oct 29, 2016
    Messages:
    99
    Location:
    USA
    My issue went away when I upgraded my phone from 6 to 7. Both had the most recent version of iOS. Left me wondering if something wasn't wrong with the Bluetooth on the iPhone. If you have access to another iPhone 7, I would try it and see if you have the same problem
     
  18. eschummer

    eschummer Member

    Joined:
    May 31, 2016
    Messages:
    48
    Location:
    San Francisco, CA
    I've experienced similar problems intermittently on my year-old S90D. I currently drive an older loaner S85 and no problems so far. Not sure what gives..I have an iPhone 7 plus - latest iOS...
     

Share This Page