Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Bluetooth problems after 5.9 update

Mordi

Member
May 25, 2013
15
0
Following my update to firmware version 5.9, my iPhone will not connect to the media app. It shows a "Restoring Connection" message on the top right corner of the screen but does not connect or allow me to access the drop down button.

My phone is connected via Bluetooth (I can make calls) but I can't play music or podcasts from my phone. I've reset the system twice and see no improvement.

Help anyone?
 

dmunjal

Active Member
Aug 17, 2012
1,185
1,257
Following my update to firmware version 5.9, my iPhone will not connect to the media app. It shows a "Restoring Connection" message on the top right corner of the screen but does not connect or allow me to access the drop down button.

My phone is connected via Bluetooth (I can make calls) but I can't play music or podcasts from my phone. I've reset the system twice and see no improvement.

Help anyone?

Had the same problem. Go into Favorites and select the iPhone in the devices section. It should then work in the drop down.
 

Zythryn

Model Y custom Warming Stripes wrap.
Mar 18, 2009
2,169
1,189
Minnesota
I had a similar problem.
I told the Tesla to "forget" my device, then reboot the car, then service did a hard reboot (pulled a fuse) and then I powered down, and powered back on my device.
One of the last two steps seemed to clear it up. Try shutting off your phone and powering it back up.
 

TrevorSStone

Member
Feb 24, 2014
40
1
Atlanta, GA
I had a similar issue, and it seems to be fixed now, but if it is showing, go on your device and start the music playing. That seemed to help for me with my android phone.
 

pgiralt

Supporting Member
Jun 16, 2013
1,520
154
Cary, NC
Funny story... This morning I noticed my iPhone wasn't connecting via Bluetooth. I thought maybe the issue wasn't fixed in .94 after all. First I rebooted my iPhone because it's been known to act flakey at times so wanted to rule that out first. After the phone came back, it still wouldn't connect. At that point, I figured I'd reboot the center screen and see if that would help. That didn't help either. Hmm... so I was thinking I was already heading down the highway and the service center was close by, so I figured I'd just stop by and have them see it failing. A few minutes later, it occurred to me to check and see if Bluetooth was actually enabled on my phone. Lo and behold, it was turned off. Turned it on and it connected without a problem. Good thing I didn't make it to the service center because I would have felt really dumb.
 

jacobp

Member
Aug 30, 2013
343
44
Potomac, Maryland, United States
Bluetooth problem with 5.9

For the first time, i am having problems with my bluetooth connection to my iphone -- specifically, i cannot stream music to the car. I am running 5.9 (.94) on the car and i have an iphone 5s with the latest software.

Here's the issue. When i pull up the media player in the car, i then click on the media shortcut button to display my available media options (i.e, am, fm, xm, slacker, iphone, etc.). When i click on the iphone option the car responds with a "Restarting Connection" or something like that, message. And then it never connects to the iphone. I am able to use my iphone through bluetooth to make calls, but not to stream media. All other media options work fine.

I've tried rebooting the center and instrument panel screens and I've tried disconnecting the bluetooth pairing to the iphone and then repairing. Nothing seems to work. I've alerted the service center but i wanted to see if anyone else has experienced the problem or has a fix suggestion.

Thanks
Jacob
 

Mordi

Member
May 25, 2013
15
0
OP here - I finally took my car to the service center. They reset in diagnostic mode and it finally worked after a few attempts. (Next step was to pull a fuse but we didn't have to go that far.). Hope others who are having the same problem will have success at Tesla service.
 

jacobp

Member
Aug 30, 2013
343
44
Potomac, Maryland, United States
I had the same problem. At the SC's suggestion, I paired my wife's phone to the car and she had no problem with media streaming. I then tried to use my phone and it magically started working again.

I noticed that others in the Tesla forum reported the same problem as identified in this thread. Here is the solution that several posters indicated fixed the problem:

"Ok here is the bullet proof way to resolve the iPhone music streaming not working. Go to the browse option in the media screen. Then select the devices tab after which press on the bluetooth service and press a song to play. That fixes the issue where the drop down selection does not select the phone. "

I have not tried this but hopefully it works.
 

ModelS1079

Member
Jun 23, 2012
871
139
Suburban Boston
"Restoring Connection" iPhone problem:

be sure your phone is connected/bluetoothed;
On your TeslaPad, touch the orange music note icon at the top, touch browse, touch your phone name (should show it there), touch media - should be all set.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top