TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Bluetooth - Streaming

Discussion in 'Model 3: User Interface' started by theredviper, Jun 25, 2018.

  1. theredviper

    theredviper Member

    Joined:
    Aug 16, 2013
    Messages:
    19
    Location:
    Vancouver, British Columbia
    Does anybody else have disconnect problems while streaming BT audio from their phones?

    My phone (OnePlus 3, BT 4.2, Android 8.0.0) works nearly perfectly as a key, I've never really had that common issue. However, while listening to audio, sometimes it will stop, the display shows "disconnected" for a few seconds, then reconnects, and I have to push "play" again. This does not happen with BT headphones I use on the same phone.

    My Model 3 is on 2018.21.9. I've had it less than 3 weeks, seems to have happened on both SW versions I've been on so far.

    This can go 20-30 minutes without happening, or happen every 5 seconds for a few minutes. It's very strange. I've disabled "BT discovery" on my phone, since I thought it was being tripped up by other devices coming in range.

    My wife has a OnePlus 5, BT 5.0, Android 8.0.0 and doesn't seem to have any issues. Hers works well as a key too.

    Any ideas? Anybody else have something similar?
     
  2. Sly27

    Sly27 Member

    Joined:
    Oct 18, 2017
    Messages:
    23
    Location:
    Maryland
    I have had the exact same issue on my MS with an iphone 6, and my ipad 4 for a few months. I intially thought the issue was my personal devices, until i noticed the car sometimes showed 'bluetooth initializing' when i attempted to reconnect.

    I brought this up with the service shop a few times, the suggested fix was to delete the device from the bluetooth list (and vice versa)....that did not fix the issue.

    Now i just grind my teeth everytime it happens...which is about every 5-30 minutes, or whenever it feels like messing up a streak.
     
  3. flashflooder

    flashflooder Member

    Joined:
    Apr 8, 2016
    Messages:
    235
    Location:
    Charlotte, NC
    My BT doesn't have any issues, other than occasional slight stutter.

    The issue I do have, is the phone sometimes not connecting when I get in (seems to happen most often when I've just gotten in and back out, e.g. strapping my kids into their seats and then getting in the driver's seat). It's clearly connected to the "car" portion, since it'll let me drive off, but for some reason I have to manually connect it via the BT menu to get it to stream audio. weird.
     
  4. jym626

    jym626 New Member

    Joined:
    Jul 10, 2018
    Messages:
    4
    Location:
    Atlanta
    I am a new owner, but have also had bluetooth connectivity issues. This is further complicated by the fact that in addition to my iphone, I have an apple watch and bluetooth enabled hearing aids, which is supposed to stream the sound to my ears. Thoughts? Ideas? There is no way to disconnect the hearing aids from bluetooth (they aren't listed on the bluetooth menu) without un-pairing them another way form the phone, and that's very inconvenient. Anyone having issues just caused by an apple watch?
     
  5. peachfuzz0

    peachfuzz0 Member

    Joined:
    Jul 22, 2018
    Messages:
    11
    Location:
    Montreal, Canada
    Just wanted to let you know my wife's phone has the exact same problem. She has a OnePlus 3T with the latest stock software. Apparently it's some sort of bug with Android Oreo's implementation of Bluetooth. I heard that the lastest beta fixes it but my wife doesn't want beta software on her phone.
     
    • Like x 1
  6. theredviper

    theredviper Member

    Joined:
    Aug 16, 2013
    Messages:
    19
    Location:
    Vancouver, British Columbia
    Well I'm glad it's a reproducible error at least. My car upgraded to 26.1 the other day and the issue might be a little better. One time it actually started replaying the audio automatically once the connection came back on, which is a little better. It didn't do it the next time though, so I'm not sure what that setting was.
     
  7. peachfuzz0

    peachfuzz0 Member

    Joined:
    Jul 22, 2018
    Messages:
    11
    Location:
    Montreal, Canada
    Just wanted to update people who were having problems still, after a recent update (I forget which one but I'm at 34.1 now but since at least 28.2) I no longer have bluetooth streaming problems with my wife's OnePlus 3T.
     
  8. crackers8199

    crackers8199 Member

    Joined:
    May 31, 2015
    Messages:
    339
    Location:
    lake elsinore, ca
    i'd love to know what unicorn you've found here, because i have the exact same setup (except 8.0.1 on my OP5) and my phone almost never works as a key...

    bluetooth streaming has been solid, though. i did see the behavior you were talking about occasionally until i decided to wipe my phone and put a custom AOSP rom on...haven't seen it since (that i can recall, knock on wood). OxygenOS is extremely buggy, in my experience...it sucks, because the phones themselves are great.
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC