Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

BMS_w035 alert popped yesterday and this morning

The BMS_w035 alert popped up on my way home yesterday.. initial searches online have several different reasons for this alert. From the battery heater, to drive train, to HV battery, to it being a fluke.

This is on a 2016.5 S75D with 42K miles

Things I've done since getting the alert:
  • Performed a soft reboot (four finger/brake reboot)
  • Opened a service appt since it that alert showed up in the app. Scheduled for 12/3 at the Knoxville SC
  • Charged the battery last night to 100% (I usually charge it to 80%)
  • I have preconditioning setup for 7AM everyday
I woke up this morning to two more BMS_w035 alerts while the car was charging.

Has anyone gotten this alert? Is it safe to drive until my service appointment?
 

Attachments

  • 20211120_133436.jpg
    20211120_133436.jpg
    358.1 KB · Views: 687
  • 20211119_212407.jpg
    20211119_212407.jpg
    254.2 KB · Views: 289
  • 20211120_081733.jpg
    20211120_081733.jpg
    229.7 KB · Views: 341
Just posted a description of issue with 2016 X P90D in a thread begun by a model S owner.
 
I have the same thing going on, did a service appointment and they have already ordered a new battery heater per the invoice. (I have no regen at the moment, its about 40 degrees out, driving does not seem to get it to warm up and come back) SC contacted me just now when I asked if it was ok to drive until 12/2 and recommended I have roadside come pick it up and not to attempt to drive it to them with that code. Guess it's getting towed tomorrow, they said they would look at it Monday if I night dropped the keys.
 
Same code and car for me, late 2016 S 75D. Scheduled service center appointment. When I asked, they said "should be OK to drive. This alert is related to the coolant heater in the vehicle." Original appointment was 12/16. Rescheduled to 12/22 when loaner would be available. Never saw the alert again. They said they would get me in early "since your car is without heat". But my cabin heater is working fine. They said they would run more diagnostics before I brought it in. Then just this morning, got the same alert. Not sure what is going on. I guess I will take it in and let them figure it out. I just don't want to pay for an uneccessary repair. ** also, had 12V battery replaced about a month ago. Coincidence?
 
Last edited:
They're back. BMS_w172 and BMS_u008 appeared again today with associated "Acceleration and performance reduced" and "Vehicle may not restart" alerts.

For those keeping score at home, this vehicle returned from maintenance for this exact same issue less than six weeks ago after Bakersfield SC replaced the rear drive unit (RDU).

2016 X P90D
 
They're back. BMS_w172 and BMS_u008 appeared again today with associated "Acceleration and performance reduced" and "Vehicle may not restart" alerts.

For those keeping score at home, this vehicle returned from maintenance for this exact same issue less than six weeks ago after Bakersfield SC replaced the rear drive unit (RDU).

2016 X P90D
I literally had the rear drive unit replaced 5 weeks ago as well on 2017 S P100D and codes came back today BMS_f035 and BMS _w035 saying vehicle may not restart. This was done in Jacksonville FL
 
I literally had the rear drive unit replaced 5 weeks ago as well on 2017 S P100D and codes came back today BMS_f035 and BMS _w035 saying vehicle may not restart. This was done in Jacksonville FL
I recently got those, too. They are HV isolation errors. It could be your battery heater going bad, especially if it was in the cold and the heater was on, otherwise it is likely to be an issue with your drive unit (either connector or internal). Either way, the car thinks that HV might be able to go somewhere it shouldn't (like the chassis) and it disables the pack until it is happy again (good HV connections).

If it's the heater, it might go away, especially until you try to use the heater again.
 
I recently got those, too. They are HV isolation errors. It could be your battery heater going bad, especially if it was in the cold and the heater was on, otherwise it is likely to be an issue with your drive unit (either connector or internal). Either way, the car thinks that HV might be able to go somewhere it shouldn't (like the chassis) and it disables the pack until it is happy again (good HV connections).

If it's the heater, it might go away, especially until you try to use the heater again.
Battery heater was replaced in October 2021.

How am I feeling about reliability? We have had three (this will make four) battery/drivetrain repairs under warranty in the last nine months.
 
Dropped our 2016 X P90D at Bakersfield SC on Monday. Got diagnosis yesterday. BMS_w172 and BMS_u008 this time attributed to Heater - Front PTC

LHD GEN3 PTC HTR, EMC FIX (1060432-00-E) $550
Part info taken from SC estimate

The heater isn't a drive unit component so I get to pay for this one. Tricky, since the car won't drive properly while the heater is malfunctioning. Don't get me wrong, I'm a capitalist. I understand how warranties work.

Will update when we get it back.
 
  • Informative
Reactions: Wooloomooloo
What a nightmare. Tesla Bakersfield SC left my MX P90D at less than 10% SOC for the duration of its 11 day stay, even after I asked them to please charge it. SC representative reported that he asked and eventually pleaded with the technicians to plug it in and that they, "blew him off."

During that 11 day stay, SC responded to my update request by stating they would update me when the heater arrived. They didn't. A week later at 4:40pm I received a notification that my repair was complete.

PTC Heater was replaced. That addressed the BMS_u008 and BMS_w172 codes.

I also asked them to replace the charging port because the door open sensor is not working. The final invoice indicated that the charging port had been removed and replaced. Took me 10 seconds to confirm the charging port malfunction was still present. Unbelievable. They then sent me a "corrected" invoice that stated they had performed a recalibration and noted no problems. I called bullsh*t. They offered to schedule a mobile repair and discount the replacement, because they couldn't refund the money I'd already paid for the bogus "recalibration."

To top things off, they returned my vehicle at a 13% SOC. Sitting at the Buttonwillow supercharger, I noticed both my side mirrors had been damaged! I texted the SC customer service rep photos of the damage. He said the technician who had spoken with me at the SC would call me today. No phone call. I texted again just before close. "He'll call you Monday." I bet he will.

This kind of complete disregard for basic communication, professionalism, integrity, and customer service is inexcusable. I'm so sick of Tesla.
 
I'm in the same fix as y'all. Yesterday my 2015 MS P90D, under ESA, got error codes BMS_w035, BMS_w172, BMS_y008 and it went into limp mode. I wasn't far from the Ft Lauderdale, Florida SC so I dropped it off and I'm awaiting the diagnosis. My rep warned me that they are backed-up due to parts shortages and I should expect my car to be there for at least two weeks.
 

dark cloud

Active Member
Apr 14, 2018
2,347
2,787
BC
I'm in the same fix as y'all. Yesterday my 2015 MS P90D, under ESA, got error codes BMS_w035, BMS_w172, BMS_y008 and it went into limp mode. I wasn't far from the Ft Lauderdale, Florida SC so I dropped it off and I'm awaiting the diagnosis. My rep warned me that they are backed-up due to parts shortages and I should expect my car to be there for at least two weeks.
What was it in your case?

@misdemeanor you never posted back and explained the resolution.

I received this BMS_w035 message just once, made an appt, car drove and charged perfectly, I got a message on the app suggesting I bring the car in 1 week before the scheduled appt., and I am getting a "new" HV pack.
 
What was it in your case?

@misdemeanor you never posted back and explained the resolution.

I received this BMS_w035 message just once, made an appt, car drove and charged perfectly, I got a message on the app suggesting I bring the car in 1 week before the scheduled appt., and I am getting a "new" HV pack.

They replaced the battery heater back in December 2021. That was their "resolution".
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top