Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Browser Crashing

whitex

Well-Known Member
Sep 30, 2015
6,825
8,671
Seattle area, WA
MCU1 the browser started dying after a couple of years, then was almost completely abandoned when MCU2 came out. Now that MCU3 is out (new S), MCU2 is probably heading in the same direction. I'd just get used to the fact that it's useless. It took me a bit (mostly miss Waze), but I can say I haven't even started the browser in my car for many, many months now.
 

krsgio

Member
Nov 8, 2018
444
440
Colorado
Anyone else getting a consistent web browser crash after about 45 seconds on MCU 2 version 2021.12.25.7 ? Happens every time no matter what site I an on.
tried using teslawaze for the first time in awhile and it just kept crashing. wasn't sure if it was related to the site or the browser itself but I gave up after that. I'm on the same sw version and mcu2
 

Wol747

Active Member
Aug 26, 2017
1,278
726
Tea Gardens
My 2020 MS: the browser or any app like YouTube takes forever to load (never used to be like that when I got it) and recently when watching TV - which I tend to do when on a supercharger) some channels just crash the browser. (And no, they are not the naughty ones, mainly news sites.)
 
My model x browser crashes frequently too. On my last service center visit in November the tech did a factory reset as "the fix" (losing all settings) however it began crashing the next day again. Every morning commute i'm driving without gauges and assist leaving the house because i am rebooting the car to get some the browser to respond. After a reboot sites work for a while but not for 24hrs. Other than the safety concern - is there any down side to rebooting the car frequently? When i use the voice command "Bug report... Browser Crash" is that going anywhere where someone will do anything with it?
 
This is not encoraging. It happens to me constantly. The browser will open and scometimes it wll crash immediately and other times it crashes the minute I try to load a website. Often after it crashes when I open it again the page that is loaded is the Tesla Model S page, especially random since I have an X....

This is a 2019 Raven. I'm waiting for a 2022 supposedly to be delivered in February. Hope that doesn't have the same problem. The browser in my wife's new Y seems to work just fine.
 
  • Like
Reactions: Wol747 and viper2ko

viper2ko

Active Member
Aug 30, 2017
1,527
1,619
USA
This is not encoraging. It happens to me constantly. The browser will open and scometimes it wll crash immediately and other times it crashes the minute I try to load a website. Often after it crashes when I open it again the page that is loaded is the Tesla Model S page, especially random since I have an X....

This is a 2019 Raven. I'm waiting for a 2022 supposedly to be delivered in February. Hope that doesn't have the same problem. The browser in my wife's new Y seems to work just fine.

I have a 2017 S with MCU2 and this happens to me.as well. I've found out what may be causing the issue.

When on wifi in my garage the browser works fine. I tested sling and was able to watch tv on the browser just fine, no crashes.

As soon as I turn wifi off and go into LTE. The browser crashes after a minute each time.

So the issue is related to the the LTE connection. At first I thought maybe Tesla was trying to throttle cars with grandfathered data but since others are experiencing it definitely a software bug
 
  • Informative
  • Like
Reactions: Wol747 and AustinP
Probably just voodoo magic but mine was crashing like this every single time i started it and tried to load a page. Almost gave up then remembered some old posts about clearing the cache back when I was on MCU1…..(I’m MCU2 these days).
So I deleted all my old “recent“ addresses locations in the navigation system ( a years worth).
Did a quick reboot and the browser works again.
Its back to working as crappy as it is ever was. LOL
slow and glitchy. At least it isn’t immediately crashing.

Clearing the Nav system logs a coincidence? Who knows but that’s twice now in last year it’s worked
 
So, tentatively very good New Year surprise.

Yesterday when I got in my car the screen was displaying release notes for V. 2021.44.25.2. Dunno if that's on the Model S yet, but it makes major changes to the user interface. One of the most prominent of the new features is a redesigned and much improved bottom bar which, among other things, is now customizable.

Nothing was said in the notes about browser improvements but (fingers crossed I'm not jinxing this) I can tell you the browser is greatly improved. It is noticeably faster--the way it should be--and stability appears to have been resolved. I had no crashes whatsoever in several trips. Hope this continues....

Happy New Year!
 
  • Funny
Reactions: ucmndd

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top