Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

BT handsfree broken?

zentage

Member
Dec 29, 2014
54
40
Norway
Ever since I got 2018.12 my bluetooth handsfree has been a nightmare, EVERY damn call I make works fine for 2min tops, then spotify or radio (whatever that was on prior to the phone call) gets back on, while the call keeps on going on my phone (which I then have to manually switch from bluetooth over to speakermode).
Basicly, I havent been able to make any calls from my car for the last 6 weeks or so.
Android 7.1 phone.
Does anyone know it this is a firmware issue or should I book an appointment with SC?
 
  • Like
Reactions: 3s-a-charm

zentage

Member
Dec 29, 2014
54
40
Norway
I've seen about the same issues with my iPhone 8.

Do you have a heavy website 'open' in the browser? Try opening a very simple page there like IP Address - What is my IP address? What is an IP address?

The browser seems to refresh the website in the back and uses CPU. Once I switched the website my problems are history.

Neither my phone nor the car has any websites open when this occurs. Guess I should give wifey's phone a test to see if the same thing happens with her phone.
 

zentage

Member
Dec 29, 2014
54
40
Norway
Had a mate try with his phone at it worked flawlessly, so I guess this thread should be closed (obviously my phone thats the problem)
 

andrewket

Well-Known Member
Dec 20, 2012
5,704
1,525
We’ve had periodic issues with BT ever since upgrading to iPhone X’s. Half the time the caller can hear us, but we can’t hear them.
 
  • Like
Reactions: 3s-a-charm

3s-a-charm

Active Member
Jul 18, 2014
1,916
821
Calgary, Canada
I’m having all kinds of Bluetooth issues too. iPhone X here. I’ve found that the “fix” is that each software update I unpair and forget the Bluetooth from both iPhone and Tesla - then power cycle the phone and re-pair the device.
Yesterday every call was a challenge
 

zentage

Member
Dec 29, 2014
54
40
Norway
I did find a fix for my phone, Running Android 7.1, I had to Reset network settings and then pair with the car again. then it worked :
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top