Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • The final cut of the 9th episode of the Tesla Motors Club Podcast, featuring Chad Schwitters, the former president of Plug In America, is now available. You can watch it now on YouTube or listen to it on all major podcast networks.

Car forgetting phone key

Since getting my M3LR on 4/12/21 my car has now on three notable occasions not recognised my phone as a key. The screen lights up and says use key card. Of course I keep my key card in my wallet and all is well and I can enter the car to drive.

On exiting the car, it failed to lock and on trying to drive my car the car demanded presentation of the key card into the centre console.

On each occasion I’ve disassociated the key card and phone key and reinitiated them both.

Is this normal behaviour?

(As a side note and I expect unrelated my app will not wake the car without me Bluetoothing in and toggling the doors to unlock and lock or some other function). The sc appointment is arranged for 14/1 to change a “connectivity board”.
 
No

However this issue is perhaps your phone if it's Android. Sometimes you need to tell the phone to stop putting the Tesla app to sleep.
It’s an iPhone 11 Pro Max. Latest iOS and the phone is set to “always”.

Interestingly my phone reminded me last night that Tesla had tracked my location in the background on X number of times and asked me if I wanted to keep the app setting as “always” or change it to “whilst using”.
 

arnolddeleon

Member
Supporting Member
Jul 21, 2012
995
1,065
SF Bay Area
I think I discovered another situation that would cause a phone not to be be able to connect with "phone as key". I noticed that our Y was not recognizing my Pixel 6 XL as key when it previously did. I could see on the phone app that it was not connected. I did the usual "airplane mode" cycling and still no joy. I went into the car using the NFC feature and decided to look at what the car thought. I noticed that it was connected to three other phones, my wife's Samsung, my daughter's Pixel 6 and my *old* Pixel 3 XL. All three of these phones were in the house while I was in the car, a reasonable distance away. I had turned on my old Pixel 3 XL phone for testing an app (nothing Tesla related) the day before.

I went into the car UI and deleted my old phone as phone as key and my Pixel 6 XL immediately connected. I don't know if there is limit to the number of devices that car will connect to or it is specific to a profile having more than one phone key but that fixed my issue.
 
In general when people have problems like this, it's the phone configuration. The TEsla app needs to be allowed to run in the background, without ever being suspended by the phone system. It also needs location and bluetooth. Make sure you give the app all those rights and make it so it doesn't get suspended.
Not sure how much more access I can give the app. It’s set to “always

D44B3635-5DD8-47AC-AD5F-9E81A7813EAA.png
 

DoricJim

Member
Oct 26, 2021
124
103
UK
Having the same issue sporadically. In my case iPhone 13 running iOS 15.1.1 and Tesla app 4.4.2. All the correct permissions, background refresh etc. are set up.

Only happens sometimes and seems to be when the car has been parked up for a while. Wife also using an iPhone has the occasional issue as well.

Does still open using the manual app control itself oddly.
 
I got fed up with this, especially in the rubbish weather we have in winter. Last thing I need is herself bending my ear because the car won’t let us in & her hair is getting wet lol. Just went with buying the keyfob and open the car remotely so she can hop straight in🤣
 
My Y was delivered last week. The phone key worked for the first two days and I was able to upload my calendar and contacts as well. Then, after activating my wife’s phone as a key, my phone key stopped working and I couldn't pull up my calendar or contacts.

I’ve not been successful adding my phone back to the key list or reloading my calendar or contacts.
Any advice?
 
@HenryT, when you update the Tesla app on your phone, the app is stopped and then updated. It is not restarted unless you manually launch the app or reboot the phone. Therefore, immediately after an app update, the "phone as key" will not work. Launch the TEsla app manually once after the update and you'll be fine. That is how it works on my Android phone, and I am mostly sure it will behave the same way on an iphone.
 

HenryT

Active Member
Jan 29, 2020
1,093
978
Manchester
Thanks @GtiMart - I've been down the re-boot, re-start route a number of times, including re-booting the car as well. Last attempt included deleting the Tesla app and 'factory re-set' on the phone. Needless to say, it's still not having it. Naturally, my wife's phone (same phone as mine, earlier OS) continues to work without any problem.

I should add, I only added her phone as a key recently when mine started playing up.

I've admitted defeat and ordered a key fob. (I think it was either that or a new phone.)

Thanks everyone for suggestions.
 
Check iOS's Background App Refresh setting maybe? There might be other iOS mechanisms, I don't have an iPhone handy to check all of them.

EDIT: You must remember your phone's job is to last the whole day. It will do whatever it wants to achieve this, especially iPhones that give you less control over how things work. Every new iOS and Android version brings along new tricks to save some battery. Most apps will run just fine. Exceptions like the Tesla app that needs many rights and must be allowed to run all the time will suffer. Apple and Google don't implement the OS for those apps, they make it so it generally works for most people, and they add a few switches to let you configure things minimally for exceptions like this.
 

HenryT

Active Member
Jan 29, 2020
1,093
978
Manchester
I think I mentioned up thread that the phone will work immediately after turning BT off and on, but then ceases to work as it should soon after. Interestingly, when I do switch off BT I immediately get a notification that the Tesla app will no longer work - confirming that it was running in the background.

Background refresh and all the other appropriate permissions are set as they should be - the conclusion for me at least is either a BT malfunction /fault with the phone itself, and/or some conflict from OS 15.3
 

HenryT

Active Member
Jan 29, 2020
1,093
978
Manchester
As suspected, OS 15.3 seems to have been the problem.

15.4 has now downloaded and my phone key seems to be back to normal service, working exactly as you would hope. Co-incidentally, the BlueTooth connection to my phone no longer drops so far as my Apple watch or earbuds are concerned either.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top