TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Car in lock/unlock loop, reset by power down

Discussion in 'Model S' started by boaterva, Sep 22, 2019.

  1. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,521
    Location:
    Northern Virginia, USA
    This is the weirdest thing my Model X has ever done, posting here for more visibility (and I can't see why it would be X specific).

    Our X is on 2019.32.2.1, the 3 on 2019.32.2.2. Starting this week (and not when they both got these firmwares), the X has had two incidents of going into a lock/unlock loop. Literally. Walk-away honk starts going every 10-20 seconds. You can see the padlock flipping on the app.

    Note:. There is zero chance of this being a fob issue. Both are in Faraday bags, where they have always been for two years. It also can't be an app issue, as apps don't control S and X's. I even tried putting my (new iPhone) in airplane mode in case that's what it was (as I was thinking for a few minutes, as it started happening Friday night after my new iPhone 11 Pro Max arrived).

    The second time it started as soon as the 3 came home and triggered Homelink. The car was in the garage, awake and asleep at various times all day, no issues after the first power down, and was fine.

    Originally, a two-finger reboot did nothing, then the first time (when GF was getting pretty upset about the honking at night) (yes, I could disable that.....), I tried a menu power down, and that fixed it. That was Friday night. Last night, she went to an event with a friend and came back, and that started it again.

    Last night, I walked out to the garage to greet her, and the X is waking up. So, why is the X waking up? There is nothing to make it do so. It has never done so for two years. This obviously is part of the issue. What is waking up a sleeping X when the 3 opens the garage door and rolls in? Broken Homelink receiver? Sentry mode is always off at home (and still is, I checked). What else would do this?

    So, basic thing here is WTF. Is this some weirdness in the 32.x software? Homelink module failing? I'll be calling support Monday, and hope they can see something in the logs, but after the charger fiasco (still not replaced after two visits and discussion with Tesla Home Charging, since they haven't seen the behavior in the flesh), not too optimistic.

    Anyone seen this or have any ideas? This is truly strange.
     
  2. StarLog

    StarLog Supporting Member

    Joined:
    Mar 11, 2019
    Messages:
    405
    Location:
    MCO
    What if Geofence is some how activated, on your iPhone, and the X, knows about it. So strange. !
     
  3. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,521
    Location:
    Northern Virginia, USA
    Again, what impact does the phone have on an S or X? But I'll def try leaving the phone inside tonight when GF comes home and see. It's definitely a puzzler.

    I've never seen my phone wake up the car, ever (of course, you can use unlock, etc....).
     
  4. KwFTW

    KwFTW New Member

    Joined:
    Oct 4, 2019
    Messages:
    1
    Location:
    Washington
    The same thing is happening to my Model S after the latest update. It keeps unlocking by itself and flashing lights, them maybe 30 secs later it will lock itself. This repeats over and over.
     
    • Informative x 1
  5. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,521
    Location:
    Northern Virginia, USA
    “Glad” to have another victim. :D

    Did you try try the complete power down fix? That has worked for me each time. The issue seems to come back after each update. Which is very strange.

    Turn power off from the menu, and wait about five minutes, touching nothing while you sit in the car. Then open a door to wake it up. And it should be cured. No idea what it resets but it does (in this case).
     
  6. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,521
    Location:
    Northern Virginia, USA
    Update on this. Still happens after each update. So now I reboot and power down also. Jeez.

    Also, I was out in the garage just now, torquing wheels on both cars (since both had had state inspections and needed the wheels checked as always). And as I was doing the X, it woke up. Again, fob is nowhere nearby, phone wasn’t with me.

    Sounds like Sentry almost woke the car up but Sentry has home turned off and it sure is. But what else would wake up a car with no phone or fob present?!

    Completely weird. And it’s not Sentry since the car unlocks and then relooks. Like the OP but not a continuous cycle.

    More weirdness. Both cars are on 2019.32.11.1, the 3 has never done this.

    At some point I’ll have to call support and they will probably say take it in and that will get us nowhere (like with the charger saga, still not duplicated for them so still not fixed).

    Good thing I didn’t name the car Christine...
     
  7. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,521
    Location:
    Northern Virginia, USA
    Sooo... after this starting again today and a power down not fixing it, called Tesla. Even though they don’t have formal tech support today, the folks at roadside were willing to help. They and advanced tech support couldn’t find anything and escalated the ticket to Engineering for (I assume) Monday analysis.

    Just before this last occasion I even removed my phone from Bluetooth (media/phone) in case somehow new iPhone was doing something. Nope. Still did it.

    Told them even stranger because it did it before v10 and after; on all 3 v10 releases.


    Should be interesting to see what Engineering log analysis comes up with.
     
  8. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,521
    Location:
    Northern Virginia, USA
    Update on this, two calls to support and all I have is they think a camera diag report is somehow involved. They say the logs report nothing that they can tell why the lock/unlock is occurring.

    Huh, I thought logs were useful. The camera issue appeared on the list of self-diag items when I took it in for two year service and they did nothing because AP worked fine. So much for actual testing. They though I was reporting a camera error, not that their own diags had found it.

    So, final answer from Tesla support is to make a SC appt and tell them everything.

    Note that the following have been ruled out by disabling each and all of these:
    TeslaFi
    Sentry
    Dashcam USB

    Have an appt for 12/2. This should be interesting. I’m sure it’s some weird interaction with the failing camera since this never happened in two years but why that would trigger an unlock lock sequence is probably just a fluke of programming.
     
  9. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,521
    Location:
    Northern Virginia, USA
    Finally got the form for the appointment on Monday and see their diags now think the culprit is the body controller. No-cost estimate (meaning $0.00) so hopefully that will be the end of this. Will report back when the replacement is completed next week.
     
  10. ShawnA

    ShawnA Supporting Member

    Joined:
    Nov 13, 2017
    Messages:
    847
    Location:
    Edwardsburg, MI
    Hi Lee,

    I have a question...
    If both fobs are in the Faraday bags and you don't use the app. to control the car,
    how do you drive the car without a fob and without the app.???

    My only idea about stimulus to cause the car to do something would be the charging wand
    on the Model 3...
    My wife's S seems to come to life when I press the wand to open the charge port on my X.
    Perhaps the charging wand on your GF 3 is waking up your car...

    Shawn
     
  11. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,521
    Location:
    Northern Virginia, USA
    This is nothing to do with using the car. :D The car is just sitting there and wakes up or when I check the charge cycle it starts this lock and unlock cycle. Before I turned off the honk-on-lock I would reboot it to stop it for a while but it drove my GF nuts so I disabled the honk and then left the car alone so Tesla could observe and diag it remotely.

    When I drive it, it doesn’t have the issue. I don’t notice the problem when parked away from home. It may be having Sentry mode on prevents the problem. But a faulty body controller could mean/cause anything.
     
  12. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,521
    Location:
    Northern Virginia, USA
    To respond to the charging wand idea: the only thing a charging wand will do to an X is open the port door. And the X is always plugged it, so it won’t even do that much.

    On the 3, I don’t even think it would wake it up if locked. I’ll have to check. But the culprit here is the X and pretty sure there the same applies. Car needs to be unlocked (fob nearby) before port door will open. In any case, the wand won’t unlock a car.
     
  13. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,521
    Location:
    Northern Virginia, USA
    So, after all this, it appears that it’s the fobs doing it. Even though they are in Faraday bags. They duplicated this at Tyson’s SC and I’ve now moved the Kitchen fob to the second floor and no issues over the first night (obviously something I should have tried but you expect a faraday bag to work and when I tested the bag by walking to the car with the fob in the bag, there was no reaction until I was within inches of the car).

    The SC said they think a firmware release in September lowered the signal level at which the cars could sense the fobs. Or made them more sensitive. Either way you want to look at it. That would be the early 2019.32.x which we are still getting versions of.

    The other interesting confirmation is that after reenabling TeslaFi when getting the car back, and moving both fobs further away, the car sleeps all the time. Which of course it never did before. Because it was randomly seeing the downstairs fob. Arg.

    So now the issue is what is going on with the car radio system that it is going into super-sensitive mode and detecting a fob over ten feet away though a wall in a folded faraday bag. But it is/was. They are now about 20 feet away upstairs in the same bag and no issue.

    I was also changing the batteries yesterday (another story) upstairs and the car woke up. Definitely seeing them 25 feet away through walls, etc. That was not happening months ago.

    The battery story is that both fobs now register as low. I have some spares I got from Amazon and neither work (reset the car alerts) even after rebooting the car. Getting fresh ones from local Batteries Plus where they cost $6 and you can return them vs. the $1 on Amazon and have no idea of age. (Love how both register as low and trigger the car through faraday bags; one is never used except by Tesla and lives in the bag.)
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC