TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Car keeps telling me to “Add a Wi-Fi Connection”

Discussion in 'Model S: User Interface' started by Stuart, May 7, 2014.

  1. Stuart

    Stuart Roadster#326, ModelS#1409

    Joined:
    May 23, 2009
    Messages:
    72
    Location:
    San Jose, CA
    Every time I get in my Model S in the morning, it displays a message telling me to “Add a Wi-Fi Connection”, despite the fact that it already has a perfectly good Wi-Fi Connection showing four bars of signal strength. No matter how many times I press the “Connect to Wi-Fi” button, delete and re-add the Wi-Fi Connection, etc., every day it still tells me to “Add a Wi-Fi Connection”.

    Have other people seen this?

    Add-a-Wi-Fi-Connection.jpg
     
  2. ChadS

    ChadS Petroleum is for sissies

    Joined:
    Jul 16, 2009
    Messages:
    2,401
    We didn't for a long time; but last week we saw it a couple of times.
     
  3. Gizmotoy

    Gizmotoy Active Member

    Joined:
    Sep 16, 2013
    Messages:
    3,144
    Location:
    Bay Area, CA
    Mine did this. It started when I deleted the original WiFi connection I added when the car was new, even though there were other connections.

    As you've found, simply removing and re-adding them didn't work. Seems ridiculous, but that's also what I found.

    What DID work was completely removing all the connections, and adding a new one that's different from the all previous ones. Something the car has never connected to before. I temporarily changed my phone's hotspot name to "DO NOT REMOVE" and added it as a new connection. Then I changed the hotspot name (on my phone) back to what I actually wanted and added that connection as well. Now I have a reminder that if I remove that "DO NOT REMOVE" connection I'm in for a cranky vehicle.
     
  4. nikwest

    nikwest Member

    Joined:
    Jun 14, 2011
    Messages:
    202
    Location:
    Munich, Germany
    I reported this behaviour to Tesla. The feedback I got was that once you connect it to a stationary wifi the message should go away. It does not go away if you connect it to a shared connection from a mobile phone or mobile hot spot.
    As I don't have a stationary wifi available I can't get rid of the message panel. Pretty annoying.
     
  5. jayman

    jayman Member

    Joined:
    Aug 31, 2013
    Messages:
    207
    Location:
    Illinois
    I'm getting it too just about every am and it's while it is connected to my home network. Definitely a bug...
     
  6. swegman

    swegman Member

    Joined:
    Mar 27, 2012
    Messages:
    962
    I was told today that Tesla is aware of this issue, and that a future s/w update will include the option of indicating not to ask the question again. I did not get this message until my car was updated to ver 5.9. Now I get the message everyday in my garage, and when I pull into certain shopping centers that I frequent and which apparently have wifi service in the parking lots.
     
  7. Thumper

    Thumper Member

    Joined:
    May 6, 2011
    Messages:
    581
    Location:
    Corvallis, OR
    swegman +1
     
  8. Gizmotoy

    Gizmotoy Active Member

    Joined:
    Sep 16, 2013
    Messages:
    3,144
    Location:
    Bay Area, CA
    There's no way for the car to differentiate between an access point that's moving and one that's stationary unless they check the GPS. Either way, this can't be true, given the process I followed to eliminate the nag screen (noted above). Sometimes I wish Tesla would just say "I don't know" rather than telling customers the wrong stuff.
     
  9. nikwest

    nikwest Member

    Joined:
    Jun 14, 2011
    Messages:
    202
    Location:
    Munich, Germany
    Well, I guess this could always determined by checking IP addresses originating from mobile networks.
     
  10. PhilBa

    PhilBa Active Member

    Joined:
    Apr 20, 2013
    Messages:
    1,355
    Location:
    Seattle
    I get this just about every time I park the car. There is wifi everywhere I go, it seems. Yesterday I got it at home, then at the mall, then Target, at home again and then the Food Store. I have actually set it up for home but the connection is too weak in the garage so it never actually connects. It also sees my neighbors unprotected wifi since my garage is close to where they have their router. (Yes, I've offered to help them put a password on it.)
     
  11. AmpedRealtor

    AmpedRealtor Active Member

    Joined:
    Jun 30, 2013
    Messages:
    4,705
    Location:
    Buckeye, AZ
    A reboot of the center screen cleared this up for me.
     
  12. SeattleSid

    SeattleSid Member

    Joined:
    Dec 28, 2013
    Messages:
    42
    Location:
    Pacific Northwest
    I look forward to if/when an update offers the "don't ask again" option. I get the message every morning. Compared to other things in life, it's a very minor annoyance, but still...

    My problem is that my home wifi isn't very powerful in the garage. The car detects it, but when I try to "join" the network it spins and spins and finally says "unable to connect." Fine. Not an issue. But then, every morning, it wants to go through it all again. The only reason to have wifi in the car at home is for the updates, but they work fine on 3G. I found I could have a strong signal in the garage by putting a "booster" there, but didn't see a reason to keep it plugged in for the occasional firmware update. So, far as I can tell, there's no solution until/unless there's a firmware update that addresses it. Here's hoping.
     
  13. Dukecat

    Dukecat Member

    Joined:
    Oct 13, 2013
    Messages:
    50
    Location:
    Carefree, AZ
    This issue just came up for me within the last week or so. Rebooting didn't help, but deleting my home network and then adding it again did the trick.
     
  14. Gizmotoy

    Gizmotoy Active Member

    Joined:
    Sep 16, 2013
    Messages:
    3,144
    Location:
    Bay Area, CA
    There are options. If your phone has a hotspot mode you can do what I posted earlier in the thread. Otherwise drive to a Starbucks or McDonald's parking lot (or any other place with free WiFi) and connect to their WiFi.

    Annoying, yes, but will eliminate the probably for you until Tesla has a real fix.
     
  15. Doug Gallarda

    Doug Gallarda P03915

    Joined:
    May 6, 2013
    Messages:
    58
    Location:
    Austin, TX
    I had the same problem. My service center explained that this happens when you connect to a mobile hotspot in "tether mode." You can see that you're in tether mode on your iPhone or iPad when you get two chain links instead of a wifi icon after connecting.

    I had both my home wifi and mobile hotspot configured, but kept getting the nag screen until I told my car to "forget" the iPad hotspot.
     
  16. Gizmotoy

    Gizmotoy Active Member

    Joined:
    Sep 16, 2013
    Messages:
    3,144
    Location:
    Bay Area, CA
    Some clarification from Tesla on this would be nice. I have two WiFi hotspots added to my Model S. Both are in "Tether Mode." No nag screen. Indeed, the car nagged me repeatedly UNTIL I connected to the tethered phone, and once I did it stopped.
     
  17. eelton

    eelton Member

    Joined:
    Sep 23, 2012
    Messages:
    190
    Location:
    Chicago, IL
    I get this every morning. I've never tethered, and the car is set up to connect to my home wifi. Perhaps the problem is that I live in a condo, and the car picks up maybe 10 different wifi networks from other units (or nearby buildings).
     

Share This Page