TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Car settings werdification

Discussion in 'Model S: User Interface' started by scaesare, Aug 4, 2017.

  1. scaesare

    scaesare Active Member

    Joined:
    Mar 14, 2013
    Messages:
    4,943
    Location:
    NoVA
    Got in my S this morning and noticed my HVAC setting was at 76 degrees, which definitely was not where I left it yesterday after my commute home in 90 degree weather. Nobody else had driven it, and I hadn't even opened up the Tesla app (or played with Visible Tesla on my PC).

    As I start my drive, I notice my Trip A/B counters weren't displayed on the dash. Went in to settings and they were unchecked. I definitely didn't do that.

    I decided to check the rest of the controls settings. Auto-lower had been set up at 100+MPH. I didn't do that either.

    No software update notification last night. No release notes this morning, so I don't think I got a firmware download. I'm at v8.1(17.26.17), although I don't remember what build I was at previously and when.

    Weird.
     
  2. MorrisonHiker

    MorrisonHiker S 90D 2017.28 c528869

    Joined:
    Mar 8, 2015
    Messages:
    2,995
    Location:
    Colorado
    Were there any additional miles on the odometer since you last drove it?
     
  3. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    1,269
    Location:
    Northern Virginia, USA
    17.26.17 hasn't had an update on ev-fw in a week. I would have thought it had been retired... :) That is very weird all those settings changed on you, especially the temperature. I assume you are the only app user...

    Edit: And David has an excellent question!
     
    • Like x 1
  4. scaesare

    scaesare Active Member

    Joined:
    Mar 14, 2013
    Messages:
    4,943
    Location:
    NoVA
    I don't note the odometer reading every time I get home, so not sure if extra miles there. But I looked at my Visible Tesla trip logs and nothing shows after my arrival home last night. And I don't plug in at home on weeknights, and my range this morning was right about where I expected it to be...

    I'm not the only app user (my wife has it on her phone as well), not only does the official Tesla app not support toggling trip counter display settings, the car's API doesn't even export that functionality, so that wouldn't seem likely.

    Hopefully I r not [email protected]!
     
  5. scottm

    scottm Active Member

    Joined:
    Jun 13, 2014
    Messages:
    1,713
    Location:
    Canada
    Somebody doesn't have to put miles on the car to change settings.

    They just have to sit in the car and fiddle.

    Can't change these settings from the official app.

    Got a dashcam? Re-roll to see if you had a nighttime visitor in the car.

    Have you given away your credentials to a 3rd party app?
     
  6. Snowstorm

    Snowstorm Member

    Joined:
    Dec 8, 2016
    Messages:
    295
    Location:
    Ontario Canada
    Did you change driver profile? I created a new profile for my wife's seating position and notice that some settings are tied to the profile and reset to factory default.
     
    • Like x 1
  7. Skysurfer

    Skysurfer Member

    Joined:
    Aug 14, 2016
    Messages:
    38
    Location:
    Iowa
    Strange, I am on 17.26.17 as well and I noticed the auto lowering speed was reset to 100+ (I always have it set at 70+). Hard to tell about the other settings though as my other half drove the car last.
     
  8. scaesare

    scaesare Active Member

    Joined:
    Mar 14, 2013
    Messages:
    4,943
    Location:
    NoVA
    True, but @MorrisonHiker asked if there were more miles on the odo.

    Right. As I also already noted in Post #4

    No dashcam... but was in my closed garage and my family didn't get in the car.

    As for credential information in a 3rd party app, as noted above, these aren't tweakable via the API...
     
  9. scaesare

    scaesare Active Member

    Joined:
    Mar 14, 2013
    Messages:
    4,943
    Location:
    NoVA
    No... and I don't think temp is linked to profiles...
     
  10. Gwgan

    Gwgan Almost a wagon

    Joined:
    Aug 11, 2013
    Messages:
    1,456
    Location:
    Maine
    I do think the HVAC is linked to profiles but cannot check right now . This sounds like a profile change.
     
  11. Zetopan

    Zetopan Member

    Joined:
    Oct 10, 2015
    Messages:
    77
    Location:
    Hillsboro, Oregon
    "... No software update notification last night. ..."

    I see at least two possibilities. 1. Do you have any children or neighbor children who might get into the car to have a look? 2. There may have been a system reset overnight, putting your settings back to some default state.
     
  12. scaesare

    scaesare Active Member

    Joined:
    Mar 14, 2013
    Messages:
    4,943
    Location:
    NoVA
    I have a 19 yr old son, however he doesn't have a key. He could have snagged my wife's or mine, but we were all hanging out together that night. After having the car for 4 yrs, it's not like he fascinated with the temperature controls or anything. I can hear my garage door openers, so I don't think any joy ride. And if he did, that boy would have set the temp far COLDER than 76, lol.

    The neighbor theory is equally difficult to imagine given the car is on auto-lock, keys in the house, and garage doors closed.

    I agree with you it's most likely a system of thing. Just weird in that manual reboots I've done never have had that kind of effect.
     
  13. mknox

    mknox Well-Known Member

    Joined:
    Aug 7, 2012
    Messages:
    8,975
    Location:
    Toronto, ON
    I've seen stuff like that, but not for several years now. You need to do a re-boot (hold both thumb wheels down until 17" screen goes dark) when weirdness like this starts to happen. If you don't it will just keep getting "weirder".
     

Share This Page