TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Certain websites can be detrimental to MCU performance.

Discussion in 'Model S' started by cartwright, Jul 3, 2018.

  1. cartwright

    cartwright Member

    Joined:
    Oct 7, 2017
    Messages:
    236
    Location:
    San Diego
    My car went pretty haywire a while back. MCU frozen or taking 30+ seconds to respond to touch, air suspension not working, turn signals not making a sound, odometer showing 0 miles, thermometer not working, all kind of stuff. The car did still drive. I took it to service center a few days before a scheduled appointment. They did a IC reset and everything seemed to come back up.

    A couple of days later it all happened again. I took it in for the scheduled annual service and showed the tech everything that was going on. Lots of people looked at it and nobody knew for sure what was going on. There was speculation the MCU would be replaced.

    Fast forward a few days and I pick up my car. The invoice shows:

    Concern: States that the LTE connectivity intermittently looses connection. Same with bluetooth connection, turn indicators sometimes make no audible noise, slow start up, GPS freezes, suspension not auto raising at saved locations. Last occurrence 6/18/18 at 9-11am. LTE issue happens more often. Touch screen does not respond to inputs 6/22/18 at 1:18pm

    Corrections: Firmware General Diagnosis

    Technician performed a hard reset. Certain websites can be detrimental to MCU performance.​

    I have no idea what website was loaded in the MCU because I just goofed around with it when there was an update to see if it performed any better (still not usable, IMO) so it isn't like I actively use the MCU browser. It was certainly not one of the active apps on the screen. That said, the issues haven't come back, so maybe there really was something going on with the browser.

    Anyone else every here of that sort of thing happening? Seems really odd that a website could cause such extreme issues.
     
  2. MarcusMaximus

    MarcusMaximus Active Member

    Joined:
    Jan 2, 2017
    Messages:
    1,470
    Location:
    San Jose
    Visiting Seeking Alpha on our MCU, are we?
     
    • Funny x 5
    • Like x 1
  3. thegruf

    thegruf Active Member

    Joined:
    Mar 24, 2015
    Messages:
    1,831
    Location:
    UK
    @cartwright - good find.
    Best call tech support on that one and give them an opportunity to review and report up to HQ
     
  4. idoco

    idoco Member

    Joined:
    May 7, 2013
    Messages:
    382
    Location:
    Outside Philly
  5. whitex

    whitex Active Member

    Joined:
    Sep 30, 2015
    Messages:
    3,374
    Location:
    Seattle area, WA
    The MCU is a computer. The more you run on it, the slower it will be. Browser can take up a lot of CPU power. In the past, having incompatible or simply slow or dying USB storage connected to MCU also caused issues (I had one USB drive which delayed bootup by a minute or two, which seems like eternity when waiting for the car to power on).
     
  6. boonedocks

    boonedocks Active Member

    Joined:
    May 1, 2015
    Messages:
    1,286
    Location:
    Gainesville, GA
    From an email in response to MCU issues I was having not too long ago:

    “Whatever you have running on the browser page is using 12% of your memory. That’s a good bit. You might try switching that to the Google home page and see if that helps before you do the factory reset.‘

    The irony in that email though....

    C72D301D-29F3-4085-8A44-9C1EE943C783.jpeg
     
    • Like x 1
  7. Patrick W

    Patrick W Active Member

    Joined:
    Mar 17, 2015
    Messages:
    1,262
    Location:
    SLC, UT
    I use the Google Translate site a lot while listening to German radio stations.
    Google Translate

    It's not uncommon for there to be a slight delay between when I enter text and when it shows up on the display. While the delay is usually short there have been times when it takes 20 or 30 seconds before what I've entered actually displays.

    I've not seen this on any other sites.
     
  8. Ande

    Ande Member

    Joined:
    Jul 28, 2017
    Messages:
    407
    Location:
    Norway
    Sounds like the ancient browser have some memory leaks.

    Tesla should consider using Opera's method of compacting the data.
     
  9. Silo1231

    Silo1231 New Member

    Joined:
    Apr 20, 2018
    Messages:
    3
    Location:
    Scarsdale, NY
    I had the same issue. When stuck in traffic in NYC, I would use browser which ultimately would cause LTE and bluetooth to fail. Usually would take 5 minutes for system to refind LTE and bluetooth. I noticed this became an issue after software update which increased browser speed. After a few trips to the service center, they decided to replace entire MCU (took days to complete). Since then, no LTE/bluetooth crashes, although system is slower - longer waits for browser to load, and sometimes browser favorite buttons don't work. Overall, I'm satisfied with the fix, although still not perfect. (By the way, I requested they upgrade to MCU 2 to fix the problem, they said nope, must stay with MCU 1 b/c MCU 2 requires different software and hardware - oh well, I tried).
     
  10. JohnnyG

    JohnnyG Weee!

    Joined:
    Jun 24, 2016
    Messages:
    796
    Location:
    Columbus, OH
    Yes... I use the browser a lot for different Tesla related apps, and well, they *all* cause issues; which means it's the browser, not the sites. Essentially, don't use the browser after a hard reboot, and you're fine. Use the browser for most anything, and expect gremlins to come crawling out of the vents!
     
  11. S4WRXTTCS

    S4WRXTTCS Active Member

    Joined:
    May 3, 2015
    Messages:
    3,216
    Location:
    Snohomish, WA
    It is a little odd that the browser wasn't sandboxed in some type of way to prevent any MCU performance issues due to some site.

    I would have vastly preferred apps instead of a browser. That way the app could be vetted, and released instead of "your mileage might very" thing with a website.

    Now I've never had an issue, but I barely ever use the browser. I did for Waze, but it never really had the performance that would make it useful.

    As to blaming it for a reset? Who knows. USB sticks have also been blamed for resets, or not clearing out the navigation history, etc.
     
  12. Sander1977

    Sander1977 Member

    Joined:
    Jan 29, 2017
    Messages:
    18
    Location:
    Netherlands
    I had the same experience, after my previous update (21.9) every few days my airbag light would show up, radio would not respond anymore, indicators made no sound and the car had no clue of speed limits or what so ever. Also, my parking beepers would not react properly and my rear camera did not work at all (also hit another car (soft) with parking that week).
    I took it to the service center (after calling Tesla several times) and had it back with the same comment. Apparently I had tested youtube in the browser, and they claimed this took unneeded data and the car experienced trouble from that. I really am doubting this but ok. I also have a teslafi account, so maybe that does not let the car sleep and causes something. Just went over the settings of teslafi and changed something.
    Also, after getting it back from the svc I now have the latest software (24.1) and all is good for the last 3 days.
    Fingers crossed.
     
  13. Shateam

    Shateam Member

    Joined:
    Apr 13, 2016
    Messages:
    200
    Location:
    NJ
    It also helps to leave the browser on a site that doesn't consume a lot of memory while it's not in use. This is because at times the site will try to refresh in the background.

    Something like google.com should suffice.
     
  14. AustinP

    AustinP Member

    Joined:
    Apr 6, 2015
    Messages:
    329
    Location:
    Belgium
    I have th exact same experiences.

    I’m on 21.9, hope 24.1 indeed fixes this.
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC