TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Charge Port lights have gone crazy.

Discussion in 'Roadster' started by dhrivnak, Apr 13, 2014.

  1. dhrivnak

    dhrivnak Active Member

    Joined:
    Jan 8, 2011
    Messages:
    2,150
    Location:
    NE Tennessee
    The last few days when I unplug the Roadster it is showing red not green, which normally means a problem but all appears well as I am at a full charge. When charging it shows a blinking red, again I would expect green. Then instead of the Blue waiting to charge I am seeing purple (blue and red). Has anyone else experienced crazy behavior in the charging lights? I am not seeing any error codes or any indication of a problem. But it is disconcerting the behavior has changed for no apparent reason.
     
  2. asgard

    asgard Member

    Joined:
    Aug 17, 2013
    Messages:
    296
    Location:
    CA
    A full reset usually fixes it. I don't know how to do it and it may not be possible.
    It is very likely a software issue (LED states are controlled by the charge firmware).
     
  3. hcsharp

    hcsharp Active Member

    Joined:
    Jun 7, 2011
    Messages:
    2,532
    Location:
    Vermont
    This happened to somebody else but I can't find the thread now. The different colors are produced by combining LED colors. I don't know what Tesla uses to make green but it might be a combination of red and something else - perhaps blue? If you've lost your blue then it will be red. The colors are not the same as paint (where blue + yellow makes green), and may not be the same as RGB color schemes but I'm not sure.

     
  4. VolkerP

    VolkerP EU Model S P-37

    Joined:
    Jul 6, 2011
    Messages:
    2,455
    Location:
    Germany
    The orange is likely produced by combining red and green, and white is all colors (RGB) at full power. The color shift reported by OP cannot be produced by one color missing in a contribution. It is more plausible that the status to color conversion got its output channels mixed up.
     
  5. djp

    djp Roadster 2.0 VIN939

    Joined:
    Aug 28, 2011
    Messages:
    1,108
    Location:
    Toronto, Canada
    Here is the other thread, which sounds similar, but was caused by a missing green channel. I agree with VolkerP that your problem is more likely to be software since the colours can't be explained by a missing channel.

    Roadster ChargePortRing Colors
     
  6. dhrivnak

    dhrivnak Active Member

    Joined:
    Jan 8, 2011
    Messages:
    2,150
    Location:
    NE Tennessee
    Well now with the exception of the white to help one to plug in I have no lights. So I think it is likely a wiring issue. I have tried to contact service twice with no luck. So by chance does anyone know anything about the charge port lights and/or how the wires are routed? Thank you
     
  7. smorgasbord

    smorgasbord Active Member

    Joined:
    Jun 3, 2011
    Messages:
    2,379
    Location:
    SF Bay Area
    That's the behavior when the doors are locked.
     
  8. dhrivnak

    dhrivnak Active Member

    Joined:
    Jan 8, 2011
    Messages:
    2,150
    Location:
    NE Tennessee
    Except they are not locked. There is a plug that comes from the PEM I will need to test.
     
  9. dhrivnak

    dhrivnak Active Member

    Joined:
    Jan 8, 2011
    Messages:
    2,150
    Location:
    NE Tennessee
    At my annual servicing they replaced the charge port lights for about $475. I was expecting worse being out of warranty and there was no issue with getting the replacement part. So all is good. They did a great job on the annual servicing even giving me a Model S loaner. The Model S was nicely refined and I see a very bright future for Tesla.
     
  10. Botbldr45

    Botbldr45 Member

    Joined:
    Oct 11, 2011
    Messages:
    513
    Location:
    Sedona, Az
    Thats good news ..... as we all are starting to roll out of warranty. Model S loaner is a great tease.:cool:
     
  11. dhrivnak

    dhrivnak Active Member

    Joined:
    Jan 8, 2011
    Messages:
    2,150
    Location:
    NE Tennessee
    Yes in a way very cruel to have the Model S for 2 days ;)
     

Share This Page