Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
  • Want to remove ads? Register an account and login to see fewer ads, and become a Supporting Member to remove almost all ads.
  • We are looking for another podcast participant who can act as a lead co-host to join the TMC Podcast. If you are interested in participating please see this thread.

Charge port not locking my home charger (but SC's are fine) on my MS, but M3 has no problem.

About two weeks ago, I started having a problem where, when I plug my gen-3 wall connector into my 2018 Model S, I get an alert on my phone about the charger not being locked in the port and charge rate is limited and I also see a pulsing orange light at the charge port. Sure enough, I can pull on the handle and it slides right out. Here's a rundown of my diagnostic steps, so far:
  • I took the Model S to a supercharger and the charger locked just fine (suggesting that it's a problem with my wall charger, right? Well....)
  • I put my 2018 Model 3 on the wall charger and that locked fine (suggesting that the problem is the car).
  • I've examined the charging handle for dents or malformations in the locking slot, but it looks fine.
  • I've looked in the charging port as I plugged the handle in and I can see and hear the locking tab moving to try to engage.
  • I've used compressed air to blow out any debris from the charge port and the charging handle (even though it feels like the handle is reaching as far into the port as it ever has)
  • I've tried pushing the handle in while pushing it to either side and up and down in an attempt to present the locking slot in a way that the locking tab can "find" it
  • Note that the charger is in my garage here in California, so this isn't a "cold" issue.
None of these have solved the problem. Has anybody else had a problem like this and has tracked down the cause? Any other things I can try?
Not sure if you have found a solution yet, but it seems like maybe there's a tolerance issue between the Model S port and Gen 3 wall connector plug. Did you try pulling the plug out of the port a tiny bit after inserting it? Perhaps it inserts a bit too far to allow latching. It's this same setup worked fine before and there's no debris in any of the interfaces, perhaps the locking pin actuator is now weak in the Model S and it does not have enough force to lock into certain plugs.
I had the same problem with my 2017 Model X. I pulled on it, and it slipped out. So I plugged it back in and tried to pull it back out, and it had locked. Now, every time I plug it in, I pull back on it to make sure it is locked in. So far I haven't had any more problems.

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.