TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Charging Equipment Fault

Discussion in 'Model 3' started by Tessaract, Oct 11, 2019.

  1. Tessaract

    Tessaract Member

    Joined:
    Aug 12, 2019
    Messages:
    329
    Location:
    Ottawa
    During driving, my Tesla M3 produces a 3-beep warning chime with the message "Charging Equipment Fault. Try different charging equipment". I get multiple warnings, and then they will stop for while (sometimes for 100's of miles) and start up at seemingly random times. This are bizarre warnings, occurring while I'm actually driving at highway speeds, and no charging equipment is (obviously) connected. My car was upgraded to V10 a day or two before this started. After experiencing these warning intermittently, and sometimes frequently during a 2-day, 1100 mile trip, I think I've noticed two correlations: these warnings seem to be triggered by bumpy ride (over railway tracks, highways with regular section-to-section bumps, "rumble" strips, ...) and at high speeds (> 60mph/100km/h). The car mostly charges normally either at Superchargers, or at level2 chargers, but will occasionally abort, but then charge normally after a charging restart.

    My hypothesis is that there's a loose connection in charging system sensor somewhere (perhaps from the charging receptacle to the on-board charger).

    I have a service appointment in a week, so I'll have a more definitive diagnosis after that.

    Anyone else experience something similar?
     
  2. jdcollins5

    jdcollins5 Member

    Joined:
    Aug 14, 2018
    Messages:
    746
    Location:
    Wilmington, NC
    Have you tried a reboot?
     
  3. ngogas

    ngogas Active Member

    Joined:
    Sep 19, 2018
    Messages:
    1,725
    Location:
    Utah
    Check your wall outlet. Might be bad connection.
     
  4. Tessaract

    Tessaract Member

    Joined:
    Aug 12, 2019
    Messages:
    329
    Location:
    Ottawa
    Yes. Didn't solve problem.
     
  5. Tessaract

    Tessaract Member

    Joined:
    Aug 12, 2019
    Messages:
    329
    Location:
    Ottawa
    The warnings occur while driving...
     
    • Like x 2
  6. jdcollins5

    jdcollins5 Member

    Joined:
    Aug 14, 2018
    Messages:
    746
    Location:
    Wilmington, NC
    Looking forward to SC diagnosis. Good luck.
     
    • Like x 1
  7. jamanlong

    jamanlong New Member

    Joined:
    Oct 13, 2019
    Messages:
    1
    Location:
    Oakville Ontario
    I have had the same issue occur and now I am unable to charge at all using my mobile charging cables. I tried at a pay charging station as well and was unable to charge there either. I am heading to a Tesla Supercharger to see if that works. The warnings started last week but i was able to continue charging. Have made a service appointment but won't be until OCTOBER 28!!!! Not a happy Tesla owner right now.
     
  8. SammichLover

    SammichLover Banned

    Joined:
    Dec 8, 2018
    Messages:
    2,618
    Location:
    Yup
    How close is the nearest Service Center to you? If not too far out of the way I'd just roll up during the day and say "dudes/dudettes, I can't charge my car". :)

    Because waiting 2 weeks before you can "fuel up" isn't close to acceptable. Also, customer service does vary SC to SC but any that I've been to I am very confident they'd figure out how to get on that right away if I showed up. If you don't get this fixed now by them they'll eventually be on the hook for a flatbed tow, too.
     
    • Like x 2
  9. qdeathstar

    qdeathstar Active Member

    Joined:
    May 17, 2019
    Messages:
    1,515
    Location:
    VB
    i agree with @SammichLover

    The service request page isn’t capable of dealing with emergencies like this i think. Hopefully your SC can get you a loaner while you wait.
     
  10. ajdelange

    ajdelange Banned

    Joined:
    Dec 10, 2018
    Messages:
    1,077
    Location:
    Virginia/Quebec
    The box that interfaces between the charge port, your battery and the rest of the car has diagnostic circuits in it intended to detect various problem situations should one arise. Clearly one of those circuits is not happy for whatever reason. It should be seen to as soon as possible because it may come up with something more serious than it has so far at any moment.
     
    • Like x 1
    • Love x 1
  11. --1--

    --1-- Member

    Joined:
    Apr 10, 2019
    Messages:
    79
    Location:
    Chester, VA
    #11 --1--, Oct 13, 2019
    Last edited: Oct 13, 2019
    :(I have the same issue, started last Wednesday. Car drives fine, but down to 76 mile range. I have a HPWC and a Leviton 40a EVSE. Neither will charge and show a fault. Initially, I thought it was a problem with the console USB charger until I saw this post. I was unable to get the latest 12.2 software update on Friday. No luck with soft and hard reboot.
     
  12. slate_319

    slate_319 New Member

    Joined:
    Oct 14, 2019
    Messages:
    1
    Location:
    fremont, ca
    I have the same 'Charging Equipment Fault.' message show up once in a while. It still continues to show up after v10. And it never shows up when I am charging :)
    I am looking forward to Tessaract's findings from their service appointment.
     
  13. --1--

    --1-- Member

    Joined:
    Apr 10, 2019
    Messages:
    79
    Location:
    Chester, VA
    :)I'll speak to the local SC center this morning. Speculating, I would assume it's a software issue, with three recent updates. Started receiving the error message on Wednesday, stays on constantly. I have not charged in almost two weeks.
     
  14. --1--

    --1-- Member

    Joined:
    Apr 10, 2019
    Messages:
    79
    Location:
    Chester, VA
    :)UPDATE. Spoke to Tesla yesterday. They forced the 32.12.2 software update and I installed via phone at work. When I got home, still had the "Charge Equipment Fault" message. Did another hard reboot, no luck. Technician suggested I "power off & on" the vehicle as another option. still no luck. Tried to charge, no luck. Frustrated. I scheduled a appointment a week out at the local service center. This morning, I decided to check the car again, when I opened the door, I noticed, NO "charge equipment fault message. I decided to try charging, BINGO. Currently charging as long as I can prior to work. Not sure if it's fixed or will be intermittent. Will drive today and see. I felt from the beginning it was a software issue, not a mechanical failure. We'll see. BTW, I received my passive Tesla key FOB yesterday and love it. It replaces the old style. Well worth the additional $157.00.
     
  15. ajdelange

    ajdelange Banned

    Joined:
    Dec 10, 2018
    Messages:
    1,077
    Location:
    Virginia/Quebec
    It's probably neither a software or mechanical problem but rather an electrical one such as a loose connector or op amp whose gain is drifting. In any case it is intermittent and those are the hardest problems to diagnose. I would push to get it run down though that may be tough. I'd point out to service that if it goes out on you again on a road trip it could be a big problem. The car evidently logs everything (to the point that it eventually wears out its flash memory). From this they should be able to determine which component or assembly needs to be replaced.
     
  16. --1--

    --1-- Member

    Joined:
    Apr 10, 2019
    Messages:
    79
    Location:
    Chester, VA
    :(My excitement was short lived. My car charged for an added eight mile and shut off. Fault message is back.
     
  17. --1--

    --1-- Member

    Joined:
    Apr 10, 2019
    Messages:
    79
    Location:
    Chester, VA
    ;)For those interested. Surprisingly, I received a call at work today from my local Tesla Service Center in Richmond, VA. The technician was following up on my request last night for a service appointment, and asking questions about my charging problem. He recommended I try my 110V Tesla supplied charger and also local Supercharging. Sadly, I cannot charge my Model 3 using any available means. I have less than 70 miles of range and will conserve for my trip to the service center next Wednesday. Obviously, a charging hardware malfunction.
     
    • Like x 1
  18. --1--

    --1-- Member

    Joined:
    Apr 10, 2019
    Messages:
    79
    Location:
    Chester, VA
    :)I received my third unsolicited phone call from the service person at Richmond, VA SC yesterday. Wanted to verify my charging effort with supercharging the night before which was unsuccessful. Said he'd be in touch after talking with a technician. Call later in the afternoon, and wanted me to bring my car in that afternoon, even though I had a scheduled appointment next week. I took it in, said they'd trouble shoot and let me know something. If parts are available, possibly pick up today, if not, early next week. Loaned me a Model S. I'm impressed with the effort of service so far. Realizing that a EV that won't charge with low range is very serious. My experience with the Richmond SC has been excellent. I'm fortunate that the SC is only thirty minutes away and I have a supercharger five miles from home, although only needed to check charging.
     
    • Informative x 1
  19. 5_+JqckQttqck

    5_+JqckQttqck Active Member

    Joined:
    Apr 27, 2018
    Messages:
    1,851
    Location:
    Toronto
    Sounds like a glitch with the regen charger if it's happening during vehicle movement. Also not charging plugged in equals issue with the charging circuit.

    V10 did something to your cars if it was working prior to update. All fingers point to software unless mechanical gremlins all decided to visit your cars at the same time.

    VIN range?
     
  20. --1--

    --1-- Member

    Joined:
    Apr 10, 2019
    Messages:
    79
    Location:
    Chester, VA
    :)I received a text message from the Richmond, VA service center this morning, my Model 3 is charging and ready for pick up. They replaced the charge port electronic control module. Picked it up this afternoon and was charged to 90%. After driving the 2015 Model S P85 for two days, my P3D is so quick, nimble, and refined in comparison. My sincere thanks to the Richmond, VA service center for their initiative to troubleshoot and repair my Tesla, six day prior to the scheduled appointment. To answer the questions in the post above, I also suspected a software issue, with three software updates and no charging in the past two weeks. Date of vehicle manufacture 04/19.
     
    • Like x 1

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC