Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Clicking sound coming from climate system fan

shred86

Member
Dec 18, 2018
243
217
USA
I actually started noticing this last year around this time but it mostly went away during the summer months because the fan speeds were usually much higher. It's a high pitch, high frequency, "clicking" sound coming from the climate system. It's not a very loud sound, but very noticeable at fan speeds between 1-5 and the frequency of the sound changes with fan speed. Even with the music up to a volume of 4+, it's noticeable and starting to become very annoying. Above a fan speed of about 5, it's almost completely gone but you'll still hear it fade in and out every once in a while. It doesn't seem to be affected by having recirc enabled, changing vents or turning the air conditioning off or on. It only seems to be based on fan speed.

This is on a 2015 Model S 85D. Here's a video I took earlier today of the sound but you'll probably have to turn up your volume a bit and enable sound on the video (imgur mutes audio by default). Any other Model S owners experience this issue? If so, any idea what causes it and if the service center was able to fix it?

I did some searching around and there's a lot of other "clicking" noise issues I found but no threads that seem to match this one. I did find one user that replied to a thread a couple years ago with a video that has the same noise. @talhas3 if you're still around, any updates on this issue?
 

shred86

Member
Dec 18, 2018
243
217
USA
Had my appointment today for this issue but unfortunately it’s something the service center is not willing to repair as they don’t consider it anything abnormal. Their reasoning was as the car ages, things will make different noises and it’s normal. They diagnosed it as the blower fan that is making the noise.

I obviously disagree hence making an appoint and based on the fact the noise wasn’t present the first year I owned the car, I don’t hear this in other MS (loaner I’ve had and friends MS) and it only occurs at certain fan speeds and ambient temperatures. I did ask how much it would cost to pay for the blower fan to be replaced and it was just under $300. I decided to just wait since I still have two years left on the warranty and perhaps it will get worse.

It’s definitely frustrating but given the state of Tesla service (overwhelmed), I’m also not surprised. Everything functions fine and it’s a noise that isn’t loud but just very noticeable and annoying. I personally would classify it as abnormal. Of the several cars I’ve owned over they years, I’ve never heard a blower fan make a clicking sound like this.

For what it’s worth, what I’ve noticed is:
  • The noise only occurs at fan speeds of about 1-4. Usually anything above a setting of 5 it goes away.
  • It only seems to occurs when the ambient temperature is around 60-80 F, even if I manually set the fan speed to 1-4.
  • It’s not always a constant sound. Sometimes you’ll hear it occur for just a few seconds then it goes away. Other times it will happen for weeks at a time.
  • Typically it only occurs with recirc enabled. However, there have been times even without recirc enabled it’s occurring.
 

aerodyne

Active Member
Nov 19, 2018
2,801
2,944
Los Angeles
It is quite possible a bit of FOD. ( Foreign Object Debris) has entered through the filter, and is hitting the fan at certain airflows...

If so, removing, cleaning and reinstalling the fan should fix it.
 
  • Like
Reactions: nativespinner

shred86

Member
Dec 18, 2018
243
217
USA
Yeah that’s a good point, it actually does sound like something small is just stuck in the blower fan. Any tips or ideas on how to access the blower fan?
 

aerodyne

Active Member
Nov 19, 2018
2,801
2,944
Los Angeles
Check out epc.tesla.com for how the system is put together.

I would try a vacuum hose or compressed air through the air filter inlet, if the epc shows that as possible
 

shred86

Member
Dec 18, 2018
243
217
USA
I took out the blower fan earlier today and didn't find any debris inside it or in the duct area where it sits. However, when I was putting the lower passenger ducting back in, I could hear some sort of plastic/paper sitting up in the area around where this ducting runs. I couldn't see it but I was able to get my arm up there and grab a hold of it which ended up being an approximately 3x1.5 inch label likely for some part. Only half of it was stuck on as the adhesive on the other half wasn't really holding (looks like a bunch of dirt/debris was stuck to the adhesive side). It was near what I think is the air inlet for when recirc is on, so I'm wondering if this clicking sound was this label flapping around and the sound was traveling through the HVAC ducts. Driving too and from dinner tonight I didn't hear the sound at all so I'm hoping this was it.

The blower fan itself was a bit dirty so I carefully rinsed it off and made sure it was completely dry before reassembling everything. The fan itself seemed to spin freely and I couldn't hear any noises when I spun it by hand, so I'm assuming the fan itself is fine. Unfortunately I didn't take any pictures of the process but here's a quick run down for anyone that might run into a similar issue in the future.

1) Remove the lower passenger side footwell trim. It's held in by two screws that use a small hex pattern bit. One of the screws is easily accessible but the other one (closest to the center of the car) is hidden behind the center console trim. I had to remove the side center console trim and the side carpet trim piece (basically the side of the center console in the passenger footwell area), number 6 and 4 in the diagram below. Both of these console trim pieces are just held in by clips so just pull away from the center console and they should unclip. It did take a little bit of force.

Screen Shot 2020-11-14 at 7.08.17 PM.png

2) Loosen the passenger footwell HVAC ducting. It's held in place by two screws as well (phillips) and is attached to the main center HVAC system. It took a bit of force to get it to disconnect from the main center HVAC system ducting. You don't need to take it out completely but you just need it to be loose/move freely in order to get the blower fan out. There is a sensor on top of this ducting so don't try to take it out completely unless you obviously disconnect the sensor (won't be able to see it but you can get your hand up there). This passenger footwell HVAC ducting I'm referring too is circled in red in the picture below. This is a picture of the HVAC assembly as if you were looking at it standing just outside the front passenger door facing the dash.

Screen Shot 2020-11-14 at 7.10.21 PM.png

3) Remove the blower fan. It's held in place by three screws (phillips). One of the screws closest to the front of the vehicle is difficult to get to with a normal size screw driver. You'll need either a really short screw driver or a small ratchet with a philips socket. It also has an electrical connector that you'll see that needs to be disconnected. Removing the blower fan will take a bit of work as the passenger footwell HVAC ducting gets in the way hence the reason it needs to be loosened.

Reassembling everything was straight forward except the passenger footwell HVAC ducting. It's tough to see, but there is a small cut out in one of the brackets underneath the dash that provides line of sight to where the HVAC ducting connects to the main HVAC assembly. Initially, I thought the HVAC duct that I loosened went inside the main HVAC assembly duct, but it actually goes around it. In other words, the duct piece I loosened (circled in red) is the female connection and the ducting that comes out of the main HVAC assembly is the male connection. Once I figured that out, it took some work but I was able to get it back into place.

Anyways, I wish I would have taken some pictures or a short video but hopefully the description above makes some sense. I'll post an update in the near future with whether or not the sound comes back.
 
Oct 25, 2015
245
143
Chicago, IL
I have the same noise on my 2014 P85D, occurring under nearly the same conditions. I have had it on and off for at least 2 years but only recently noticed the conditions under which it occurs.

I have various other rattles and squeaks which I can deal with.. but this high pitched chirping is really annoying.

I have found that my car only produces the noise after the battery is warm. If the battery is cold soaked, the noise will not occur until the car has been driven for a while. So it usually only happens in the spring and fall, when ambient temperatures around here are 50-70 degrees and the battery never gets too cold.

If the cabin is much colder than the HVAC setpoint, the car will turn on the resistive heater and the sound will never occur. If the cabin is within a few degrees of the set point *and* the battery is warm, the car seems to try to transfer heat from the battery pack into the cabin. I reliably get the noise then.

Do you observe the same or detect any other pattern?

I had a service appointment for this a few weeks back... the day of the appointment was cold (~freezing) so on my way there, I took my time and got the car into a state where it reproduces reliably. The service advisor test drove the car right away. She heard the noise, said it was a new one to her (she said she has been with Tesla since 2013), and would try to keep the battery warm so it reproduces when it was time for a mechanic to diagnose. Unfortunately, the mechanic didn't look at my car until several hours later and by that time was unable to replicate the noise. They ran some HVAC diagnostics, said everything is functioning normally, and told me to book another appointment if it gets worse or reproduces more reliably.

Unfortunately it reproduces quite reliably for me... it's just a matter of not being able to reliably predict the weather 1 month into the future, which is how far in advance the service centers are booked!!!

I really hope removing the loose label fixes the noise for you - please keep all of us updated.
 

shred86

Member
Dec 18, 2018
243
217
USA
That's basically the exact situation for me. There have been some instances though that everything met the criteria you and I described but it still wouldn't happen. I've also noticed there's times where if I turn off recirc, the sound goes away and when I enable recirc, it comes back. However, there's been times where it occurs with both recirc on and off.

When I had my service appointment, I sat in the car with their service advisor and another service technician. The advisor said he couldn't hear anything but the technician said he could hear it and that it was coming from the blower fan, but it was "normal"...

I'll definitely provide an update with whether or not the noise comes back. I'm really hoping the loose label was it because the sound is very annoying and audible even with the music up to a volume setting of 5-6.
 

aerodyne

Active Member
Nov 19, 2018
2,801
2,944
Los Angeles
Its normal for the SvC to say all sounds, vibrations, wind leaks, etc are...

"Normal"

Don't blame the workers, this comes from the top....and we know who is still in charge of CS....
 

shred86

Member
Dec 18, 2018
243
217
USA
Unfortunately the sound is back. Three days of no issue and I've been driving with the music off just to see if I could hear it. Of course I turn the music on and about 10 minutes later, I start hearing the sound. I don't think it has anything to do with having the music on as it doesn't go away when I turn it off. When I first noticed it again, it was very faint but when I enabled recirc, it become much more audible. I also noticed with recirc off, the frequency is much higher and when I turn recirc on, the frequency is lower but much louder. Anyways, I don't know what else it could be. That's frustrating to hear even with a new blower fan, it didn't fix it.
 
Oct 25, 2015
245
143
Chicago, IL
That's disappointing, but very much appreciate the update.

What was the ambient temperature outside when you tried turning recirc on/off? I wonder if recirc is affecting the frequency and volume of the noise solely because recirc on/off is affecting the temperature of the input air to the air handler.

For me, I only get the sound when the battery is warm. So my pet theory is that some valve or other component in the coolant system is emitting this noise when it lets battery coolant flow to the HVAC heat exchanger.

A difference between cabin air temperature and outdoor temperature could result in different coolant system behavior in recirc on vs off.

Anyone have a diagram of the Model S coolant system and the location of the various components? From the driver's seat, it sounds like it's coming from the passenger dashboard.
 

shred86

Member
Dec 18, 2018
243
217
USA
That's disappointing, but very much appreciate the update.

What was the ambient temperature outside when you tried turning recirc on/off? I wonder if recirc is affecting the frequency and volume of the noise solely because recirc on/off is affecting the temperature of the input air to the air handler.

For me, I only get the sound when the battery is warm. So my pet theory is that some valve or other component in the coolant system is emitting this noise when it lets battery coolant flow to the HVAC heat exchanger.

A difference between cabin air temperature and outdoor temperature could result in different coolant system behavior in recirc on vs off.

Anyone have a diagram of the Model S coolant system and the location of the various components? From the driver's seat, it sounds like it's coming from the passenger dashboard.

Yesterday the ambient temperatures were around 67 F. Today it was around 74 F. I noticed when I turned recirc off, it doesn't completely eliminate the sound. It might for a bit, but I still hear it coming back but it seems to be for only a short period then it goes away. This will keep repeating every 10-15 seconds (it's really random). I also lowered the cabin temperature to 68 F just to make sure I was getting cold air from the climate control system and the sound was still occurring.

Check out this thread on the Tesla forums, specifically the Theory of Operations Guide. I don't think the battery coolant is connected to the HVAC. It looks like the Model S uses a Positive Temperature Coefficient (PTC) Heater. I might try to do some more troubleshooting this weekend to see if I can better isolate where the sound is coming from. It does sound like it's coming from the passenger dashboard as well, which is where the PTC heater is located. I'm also wondering if maybe it's something weird where one of the door actuators that direct the airflow doesn't close completely causing it to slightly flap around, but that doesn't make sense since it only occurs after the car is "warmed up". The only other thing is perhaps something in the evaporator but that doesn't look like something that can be replaced without replacing the entire HVAC unit. The sound also occurs with A/C turned off so I would assume that should rule out the evaporator.

@OVB1 when they replaced your blower fan, did the sound go away for a while then come back or did it pretty much come back right away?
 
Last edited:
Oct 25, 2015
245
143
Chicago, IL
Nice work!

I studied this diagnostic screen earlier today and came to the same conclusion you did: there is no way for the system to transfer heat from the battery/drive unit into the cabin HVAC.

Tesla Thermal Management System - explanation

I'll have to read up on the Theory of Operations Guide. Thanks for the link!

Since I only get the sound when the battery is warm, it may have something to do with the thermal control system being configured to actively cool the battery with the AC compressor (which is shared with the cabin HVAC). But the sound also never seems to happen when HVAC blower fan speeds are high (when cabin cooling demand is high) or when the HVAC is turned off.

So it seems the noise only occurs when there exists *some* refrigerant demand for battery cooling AND when there is a small refrigerant demand from cabin HVAC (because when we turn off HVAC, it goes away).

I'll study the Theory of Operations Guide and see if there's any clues there.
 

Alrobot

New Member
Aug 30, 2020
4
2
La Verne, CA
Hi, I am experiencing same symptoms in my 2013 MS P85. Had the chirping at low fan speeds, it would "go away" at higher speeds. Can't say I noticed difference hot or cold. My heater doesn't work, so I just shut off the system when its cold and use seat heater. Anyhow, this week, the blower stopped working totally, so I am going to be replacing the blower motor this weekend. Luckily there are a few guys on Craigslist parting MS's in my area. I will update, and know I appreciate all you have done on this thread already.
 
  • Like
Reactions: shred86
Oct 25, 2015
245
143
Chicago, IL
I had two extended drives over the past few days in cooler weather (40’s). I did not get the chirping with recirculation set to fresh air. Thinking of this thread, I tried recirculation and then I reliably got the chirping. Perhaps any dependence on recirculation mode is only due to input air temperature to the hvac unit... during my drive, fresh air would have been much colder than the cabin set point. Recirc air was close to the cabin set point. This aligns with the observation that the noise happens (most often) during mild ambient temperatures.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top