Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Connectivity trouble with the app and software downloads

SheriffMoose

Member
Oct 31, 2019
56
7
Virginia, US
All,

Sometime in the last several months I started noticing that my app was having trouble connecting to Sansa, my Model 3. Its basically never an issue when I'm away from home, but its almost impossible for me to get the app to connect to the car when I'm on my wifi. It also seems like the app has a hard time connecting to the car when the car is on wifi as well.

Adding to those issues, I'm on my second software download in a row where the download is stuck at 50-51%. The first time it happened I tried pretty much all of the troubleshooting steps below before creating a service request with Tesla. They ended up clearing the download cache on the car and a day or so later it received and successfully downloaded the update. However, today I'm in the same boat, the car downloaded to 50% and has stayed there for over 24 hours, despite being on wifi.

I get the impression that there is something funky going on with my wifi network, as it seems to be the constant in the issues I'm having. Here are the following toubleshooting steps I've taken:

car:
-disconnect and reconnect to wifi (including forgetting the network and readding)
-Moving the car closer to try and get a better signal
-did a soft reset by holding both steering wheel buttons until the computer rebooted
-Powered off the vehicle, waiting a couple minutes before pressing the brake to turn the vehicle back on
-connected the car to my hotspot's wifi network (after the download was already stuck - no improvement)

home network:
-Rebooted the router
-Bought a wifi extender and placed it pretty close to the driveway (increased average signal from 1 bar to 2 bars)
-Reset the wifi extender
-Disabled DNS filtering on the PiHole (see below)

Here's where the plot thickens. Being an IT guy, like many IT guys, I decided to make my network a bit more complicated. I installed a PiHole DNS filter which I've configured to act as my DHCP server as well as send all DNS traffic through cloudflare (1.1.1.1, 1.0.0.1). I've done a couple of security changes as well, like using DNSSEC. I'm not actually positive that this is the culprit, as I've checked the logs, and I see no blocking of any tesla related DNS request, nor do I see any blocked traffic when I look at all of the requests coming from the car of the DNS logs.

Saying all that, I will admit that I haven't tried removing the PiHole from the network all together, but as I noted, I did disable the DNS filtering, which made no difference. I suspect it is possible that DNSSEC is causing an issue, but the logs show no problems. I will also point out that I don't think the range extender as actually required. I had previously downloaded updates on my network before with just the router, but I find my phone sometimes loses wifi in my driveway, so it was really more of shoring things up than finding actual issues with connection previously.

Geez, I'm long winded. I have a couple of troubleshooting steps I need to try (mainly, try removing the PiHole from the DNS loop altogether) to see if my DNS server is causing the issue. However, I wanted to ask you guys if you've had any similar experiences and know of some other possible solutions. Also, I just found @Seth2020 's The definitive guide to RESET on Tesla Model 3 so I'm looking through that to consider next steps as well.

Thanks!
 
Last edited:

SheriffMoose

Member
Oct 31, 2019
56
7
Virginia, US
Ok, having looked at the definitive guide, I have done the first two steps, but not the high voltage disconnect. I'm not really under the impression that would fix things, and I'm less inclined to take that step at the moment. What would really be nice is another private network I could connect to that I trust. I believe my mom's house at home would be a good test of this, so I might try that and see if I get any difference, though I think once the download is stuck, I'm pretty much stuck until Tesla resets it from there end.

Really I'm hoping to figure out what might be causing the downloads to stick and how to prevent them from sticking, as well as what might be keeping me from connecting to the car when I'm on the same network. I mean ugh!
 

SheriffMoose

Member
Oct 31, 2019
56
7
Virginia, US
Update: I disabled DNSSEC on my network, and the app started magically talking to the car again without issues. I still don't understand why DNSSEC would cause the app not to be able to talk to the car, particularly when I didn't see any failed authentication or filtered requests but there it is.

The issue regarding the stuck download is still up in the air, though. Tesla just reached out today after I'd submitted a service request, but I probably won't know if DNSSEC is a culprit on the stuck downloads until the next one comes out and downloads without issue.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top