Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
  • Want to remove ads? Register an account and login to see fewer ads, and become a Supporting Member to remove almost all ads.
  • We are looking for another podcast participant who can act as a lead co-host to join the TMC Podcast. If you are interested in participating please see this thread.

CP_a151 - AC Converter fail and my experience with Service (Possible life hack?)


Active Member
Dec 30, 2021
So here's the story. Maybe to much, but maybe it will be useful for some.

TLDR: CP_a151 error even shows that AC charging is not possible - UMC still works! It also makes car off-road - meaning that tesla deems it cannot be used... In such case call for roadside assistance and deem car off road - this makes gears to spin faster...

Beginning: had various rattles in my car (coming from rear seat divider wobble etc.) and booked for appointment with SC in Nottingham... earliest date they had, when booking in September, was end of October. By end of October, due to part requirements and availability, it was pushed to 14th of December (Wednesday). So 3 months using car with horrible rattles was the thing which made me losing faith in tesla.. Anyhow.

In the meantime, while I was driving, I had an error on the screen: "charging port door not communicating". which resulted that charging port door did not open while touching it for few times...

A weekend before the appointment date (night from Sunday to Monday) my car stopped charging. Without any error, nothing, while plugged in my 7 kw wall charger. I am using IO. So I had some slots from 22:30 to 23:00 and then 23:00 to 5:30 (needed roughly 60% charge). After first slot was done, car just stopped charging ~23:10
When I went to my PodPoint Solo wall charger it was showing red led, indicating general fault. I have tried various things: reset the charger fuse, few times, rebooted charger - result the same:
- charger shows blue/pink indicating it is in OK operation
- Once I plug in my car, I hear click in the car, click at the charger and then - red indicator. car is showing 0/1 V, not charging.

My first instinct - charger issue. More over, I then plugged my UMC to 3 pin socket, to my car and voila - it is charging. Slowly, 2.3 KW, but charging. There is still no error in the car.

In the morning I called to the podPoint - although they claimed that all good from their side, we did trouble shooting (is cable not in water, are there any damage on the cable etc.). I also claimed that "it must be charger, because UMC works just fine"

Nevertheless, later that day I went to the one of public chargers in our town, same PodPoint 7 kw. After plugging in I suddenly have the same Red led on their charger. Strange! but hey, maybe that charger is faulty, because, remember, UMC charges car no issues, just slow (as you would expect from 13 A socket)

Once again, drove to another public charger. this time BP - same type of fault there.

And then - car started to display error:

CP_a151 Charge port error detected - Service is required​

AC charging may not function / OK to Supercharge​


So apparently, when your AC converter or whatever there fails, you still can DC super charge (no help as it is 30 min drive to nearest one) and you can still charge with UMC, but normal AC 7KW charger is not operational due to communication issue (or something like that) Model 3 Owner's Manual | Tesla

All in all, I need car, I cannot charge it fast enough for my use and at the same time my service is moved forward to 15th of December (due to charge port error??),,, I have like 30% battery, charging it full day to get a bit more... calling tesla SC, they cannot do anything,.. and even on the 15th they cannot give me a loaner, as they have none available, and the job will be more than 1 day (expected) so maybe I can use UBER vouchers?
My answer is yeah - I need UBER Vouchers for like 150 gbp as I live 30 min away from the nearest SC... and then a suggestion from the rep from the SC:

- call roadside assistance and tell that car is off the road / non operational. In such case, when car is actually off-road and if Tesla SC cannot provide you with the loaner (due to no availability), they will offer you a rental as replacement, which might be non necessary an EV, but at least you will be able to travel where needed. It also, in such case, makes all things move faster and SC contacts you a bit more proactively.

So as result, after call to road assistance, a loaner became available within one hour... from the same SC which "had no loaners available" and all repair works were done in a day, including replacement of ECU - Charge Port
Strange that the UMC was working but other AC chargers weren't, I wonder what is different there that it wasn't an issue. The UMC should be standard charger in the same way the PodPoint etc ones are 🤷
I have a hunch that the UMC somehow bypasses the (faulty) ECU that otherwise is used to communicate between the car and the EVSE to negotiate the charge rate etc. That could be designed-in by Tesla as the fallback AC charging measure.

Hence why the OP could still get a charge at home.

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.