Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Dash cam front camera low quality

Mrklaw

Member
Mar 5, 2020
421
223
Berkshire
Needed a reboot to get my viewer working but testing this morning the rear/side cameras are fine and clear but the front camera is very low quality - blurry and blocky.

might be water? Is it something that clears up or something I need to check/wipe before trips?

edit :
 

VanillaAir_UK

Well-Known Member
Jun 17, 2019
8,211
5,733
Surrey, UK
It could just be normal - they are not great quality and are highly compressed when recording. If you want dashcam quality, buy a proper dashcam.

Or it could just be that the windscreen needs a flick wipe or two, or if frosty, a bit of time to defrost/demist.

I would however recommend to anyone to test the camera heater functionality whilst still getting the frosty mornings. Remotely turning sentry on for 15 minutes or so prior to using the car should trigger the camera demister and create a clear block around the front cameras and along top and side edges of windscreen on front passenger/near side of the car.
 
Last edited:

Andy718

Member
Nov 2, 2020
36
21
Hampshire
I would however recommend to anyone to test the camera heater functionality whilst still getting the frosty mornings. Remotely turning sentry on for 15 minutes or so prior to using the car should trigger the camera demister and create a clear block around the front cameras and along top and side edges of windscreen on front passenger/near side of the car.

Along with the issue I've experienced with the windscreen camera demister not working (mentioned here), I was also concerned about the front camera quality.

The Service Centre checked the demister and reported that it is a known issue awaiting an update:

Concern: When we had icy weather, when pre- conditioning the car, the area at the top of the windscreen where the​
camera are located did not defrost​
Unable to replicate customer concern due to weather.​
Carried out windshield camera heater function test, test passed with no issues.​
Manually tested heater grid with multimeter, values as expected indicating no issues.​
Checked operation of interior and exterior temperature sensors as these are used to determine heater function. Both​
reading correct values, no issues found.​
Searched known issue database and found a entry for this specific issue. This issue is due to a firmware bug affecting
model 3's and is currently under investigation by engineering. A fix for this will be implemented in a future firmware​
release.​
The SC checked the camera and reported the following:

Concern: Forward facing camera is sometimes blurred​
This issue is likely attributed to the camera heater grid mentioned in the line above​
Proactively removed camera assembly and removed residual glue from glass manufacturing process​
Used image capture to review image quality, no issues found image quality within specification​
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top