Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • The latest TMC Podcast (#14) is now available on YouTube and all major podcast networks. We covered FSD Beta's exciting v11 update, Enhanced Autopilot coming to the U.S. and Canada, and more!

Dashcam is unavailable when sentry mode is on and events occurred

Having issue with Sentry Mode.

Sentry mode was working without issue when I got the delivery of Model 3 LR on 01/21/2022. It was recording events when the car was parked at malls.

I am assuming...after updating my first software update.. Sentry mode is not working properly.

Dashcam is recording when I am driving, however, wherever there are event occurred when the car is parked at the malls..It shows an error mark on dashcam icon every time I come back to the car.

Took the car to SC last week. They said there is no issue on clove box neither USB cable along with the glove box. They said it is because some virus on a Tesla USB. So they gave me a new one and tested GOOD. But.. still getting same issue. I have done USB formatting on the car and Mac many times.

Also yesterday, I got an alert saying Dashcam usb is not plugged in the glove box for the first time..

I am not sure it is related to Tesla USB I am using..(but it was saving footages begging..),, or software issue or hardware issue..

Any thoughts?
 

Attachments

  • Skype_Picture_2022_03_23T15_40_49_323Z.jpeg
    Skype_Picture_2022_03_23T15_40_49_323Z.jpeg
    487.8 KB · Views: 116
  • Skype_Picture_2022_03_23T15_40_50_758Z.jpeg
    Skype_Picture_2022_03_23T15_40_50_758Z.jpeg
    694.7 KB · Views: 67
  • Skype_Picture_2022_03_23T15_43_54_242Z.jpeg
    Skype_Picture_2022_03_23T15_43_54_242Z.jpeg
    814.4 KB · Views: 67
They said it is because some virus on a Tesla USB.

I work in Cyber Security and this smells like bullshit. TBF, the technician probably doesn't understand what the actual issue is, heard/misheard/misunderstood an explanation and is repeating it back to you with telephone-game-levels of reinterpretation. I wouldn't put much weight on this.

When you say the dashcam works when driving, can you pull the USB drive off, insert it into a computer, and see the driving footage? And then when it fails to record when parked, do the same, and confirm no files were created for the time frame of the parked event?

Though I don't know the details of how the Sentry Mode system works, I would also do a couple of tests when parked and see if it matters at all how much time passes since the car is "off". I.e. you power it off and walk away, then immediately come back without a key to trigger a Sentry Mode event and see if it records. Repeat a few intervals later, like 5 min, 10 min, 15 min, 30 min, 60 min, 2 hrs, and make a note if it fails to write footage at each of these intervals.

I think this info should help when you contact the SC again, their techs may not know the answer but may be able to escalate it to someone who does.
 
  • Like
Reactions: jjrandorin

Knightshade

Well-Known Member
Jul 31, 2017
15,708
29,852
NC
For clarity-

Sentry does not record video. Only dashcam does.

All sentry does (video wise) is, if it goes to alert mode, move the previous 10 minutes of dashcam footage to the sentry folder.

So the OPs issue appears to be entirely around dashcam (or the USB device in general from the error message).



Also yeah the virus thing is nonsense- for one how would it get there? For another, the car doesn't run software on the key no matter what kind of software it is, so even if "the key had a virus on it" it wouldn't DO anything inserted into the car.
 

jjrandorin

Moderator, Model 3, Tesla Energy Forums
Moderator
Nov 28, 2018
14,656
18,773
Riverside Co. CA
"There is a virus on the USB" is such nonsense, I am assuming that we are dealing with "telephone game" repeating here from the OP. If the technician said "There is corruption on the USB" or "The USB is corrupt" none of us would be batting an eyelash at the statement... but "its not working because there is a VIRUS on it?"

If the technician actually said those specific words, they should never be allowed to talk to a customer again. With that being said, its extremely (extremely extremely) common for people repeating what someone else said to substitute words, either on purpose or accidently.

It would be super common for someone to hear "corruption" and substitute "virus" when repeating it (have seen that many times before in fact).

If tesla actually thought "it was a virus" there would have been no reason for them to give the OP a new one, because "virus" = software, and re partitioning and re formatting the same drive would remove any "virus" so I am doubting they said that specific word.

Back to what the OP describes though. My wifes brand new Model Y is still on factory firmware, and the included USB drive that tesla gave gave " drive too slow" errors like some others reported. I had planned to swap it to the same setup I have in my model 3 anyway, which is a microSD card (a samsung pro endurance card specifically) along with a microSD to USB adapter.

That combo has been working in my model 3 since about may of 2019, so I ordered the same items for my wifes model Y. Put them in, formatted the card using the car, no more error message about drive being too slow (which I think was a car firmware issue anyway).
 
Last edited:
Well, not quite right... it records any time the car is awake.

Sentry keeps the car awake anytime it's on... but so do some other modes (and it stays awake for a few minutes regardless when you get out)

Not quite right either. 🙂 There's a difference between awake and powered on, and (according to the manual) dashcam only runs when the car is powered on. According to TeslaFi, my car is sometimes awake (idle) when parked at home, but it's not powered on and the dashcam isn't running.
 
  • Informative
Reactions: Knightshade

Knightshade

Well-Known Member
Jul 31, 2017
15,708
29,852
NC
That's actually a really interesting distinction- I'd been using the terms interchangeably.

Checking the manual the only time they use the term "awake" is

Model 3 manual said:
Power is available whenever the vehicle is considered "awake". The vehicle may be awake for many reasons. For example, when using features such as Summon, or when features such as Preconditioning, Cabin Overheat Protection, Keep Climate On, Dog Mode, Camp Mode, Sentry Mode, etc. are enabled. The vehicle is also awake whenever the low voltage battery is being charged or is in use, during HV charging, when the vehicle is communicating with the mobile app, etc. Leaving an accessory plugged in does not deplete the low voltage battery.


AFAIK the only thing on that list for which it wouldn't also be "on" would be maybe the battery charge bit or communicating with the app?

Be curious if you have any more data on that.
 
Having issue with Sentry Mode.

Sentry mode was working without issue when I got the delivery of Model 3 LR on 01/21/2022. It was recording events when the car was parked at malls.

I am assuming...after updating my first software update.. Sentry mode is not working properly.

Dashcam is recording when I am driving, however, wherever there are event occurred when the car is parked at the malls..It shows an error mark on dashcam icon every time I come back to the car.

Took the car to SC last week. They said there is no issue on clove box neither USB cable along with the glove box. They said it is because some virus on a Tesla USB. So they gave me a new one and tested GOOD. But.. still getting same issue. I have done USB formatting on the car and Mac many times.

Also yesterday, I got an alert saying Dashcam usb is not plugged in the glove box for the first time..

I am not sure it is related to Tesla USB I am using..(but it was saving footages begging..),, or software issue or hardware issue..

Any thoughts?

Mine has worked perfect for 2 weeks since I got it but just like you I got an error yesterday saying that USB wasn't plugged in. THEN it told me to use a USB larger than 32 gig but the one Tesla installs is 128gig.

I pulled out the USB and plugged back in and reformatted and the errors went away. This was at home where I do not use Sentry Mode.

Maybe from a update?
 
Last edited:
That's actually a really interesting distinction- I'd been using the terms interchangeably.

Checking the manual the only time they use the term "awake" is




AFAIK the only thing on that list for which it wouldn't also be "on" would be maybe the battery charge bit or communicating with the app?

Be curious if you have any more data on that.
I interpret “powered on” to mean the touchscreen is on, usually when you’re in the car, but maybe also for other features like dog mode. I don’t know if the dashcam records in dog mode (if Sentry Mode is off). Sentry Mode doesn’t keep the car “powered on” but it does keep the dashcam on.
 
I see frequent errors about the dashcam not working, and there’s nothing wrong with my USB. This happens in both my S and my wife’s 3. The 3 is a 2018, so there’s no glovebox USB. The dashcam is just quirky. I agree that the virus explanation is BS.

First of all, Sorry to highjack your thread Clairebear.

@ EVRider-FL

I have a 2018 M3 as well. My dashcam recording is quirky also. This started after certain updates. My current software version is 2022.8.2. I unpluged all my USB and just insert a 128 GB or 256 GB Samsung USB drive. Did the in-car format. Sentry mode is flawless. I am having major issue with dash cam recording. It's a hit and missed. The only way I can force the recording is go into quick control and tap on the recording while I am driving. It will save the clip at the time of tapping on the recording thus saving the video. The in-car format will format with exFat. So I decided to use a 3rd party tool (Paragon HD management) and format my entire drive usb (128 gb or 256 gb) with fat 32. Created a folder called TeslaCam, I have a MP3 folder for my music and lightshow folder with some custom lightshow files. I am still having this issue where TeslaCam recording. It's a hit and missed. There is no error about it can't read my USB. Again Sentry Mode records just fine. I can't see my USB for my MP3 folder. The lightshow custom file is not being read since it's playing the default lightshow.


I even try to partition my 256 GB to two partition in thinking maybe one partition dedicated to TeslaCam and the second partition for MP3. Will I can't mount the second partition for some reason. That's a different issue/story.

What give? Can someone tell me what I am doing wrong. This used to work flawlessly. Now I can't even play my USB music because it does not see my USB.

Help Help Help
Much appreciated in advance. For anyone that don't have this issue. Can someone tell my if the entire drive should be in FAT32 format? Also can I have three folders TeslaCam, MP3, Lightshow. Is all three working for you?
 

stopcrazypp

Well-Known Member
Dec 8, 2007
12,170
8,014
First of all, Sorry to highjack your thread Clairebear.

@ EVRider-FL

I have a 2018 M3 as well. My dashcam recording is quirky also. This started after certain updates. My current software version is 2022.8.2. I unpluged all my USB and just insert a 128 GB or 256 GB Samsung USB drive. Did the in-car format. Sentry mode is flawless. I am having major issue with dash cam recording. It's a hit and missed. The only way I can force the recording is go into quick control and tap on the recording while I am driving. It will save the clip at the time of tapping on the recording thus saving the video.

Does the icon show red in the controls and say "Recording" as below? If it shows gray, recording is paused and you need to tap it for it to turn on so that it records whenever you are driving. If you tap it once again it saves a clip. If you hold it, it will pause.
GUID-C919FD4D-10B9-49FE-A124-7B36EAB93290-online-en-US.png

Model 3 Owner's Manual | Tesla
1*zNdNui2-s30EEAqCDy8vRA.jpeg

The in-car format will format with exFat. So I decided to use a 3rd party tool (Paragon HD management) and format my entire drive usb (128 gb or 256 gb) with fat 32. Created a folder called TeslaCam, I have a MP3 folder for my music and lightshow folder with some custom lightshow files. I am still having this issue where TeslaCam recording. It's a hit and missed. There is no error about it can't read my USB. Again Sentry Mode records just fine. I can't see my USB for my MP3 folder. The lightshow custom file is not being read since it's playing the default lightshow.


I even try to partition my 256 GB to two partition in thinking maybe one partition dedicated to TeslaCam and the second partition for MP3. Will I can't mount the second partition for some reason. That's a different issue/story.

What give? Can someone tell me what I am doing wrong. This used to work flawlessly. Now I can't even play my USB music because it does not see my USB.

Help Help Help
Much appreciated in advance. For anyone that don't have this issue. Can someone tell my if the entire drive should be in FAT32 format? Also can I have three folders TeslaCam, MP3, Lightshow. Is all three working for you?
AFAIK, you can't share TeslaCam with other features. So you need to make multiple partitions if you want to use only one drive. As you noticed the default format is now Exfat, I would format multiple Exfat partitions and have a separate partition for each folder.
 
Does the icon show red in the controls and say "Recording" as below? If it shows gray, recording is paused and you need to tap it for it to turn on so that it records whenever you are driving. If you tap it once again it saves a clip. If you hold it, it will pause.
GUID-C919FD4D-10B9-49FE-A124-7B36EAB93290-online-en-US.png

Model 3 Owner's Manual | Tesla
1*zNdNui2-s30EEAqCDy8vRA.jpeg


AFAIK, you can't share TeslaCam with other features. So you need to make multiple partitions if you want to use only one drive. As you noticed the default format is now Exfat, I would format multiple Exfat partitions and have a separate partition for each folder.
Okay will give this a try. Can I have multiple USB drives if that's the case?

Recording is red hence I am able to tap and save the clips.
 
Last edited:
Mine has worked perfect for 2 weeks since I got it but just like you I got an error yesterday saying that USB wasn't plugged in. THEN it told me to use a USB larger than 32 gig but the one Tesla installs is 128gig.

I pulled out the USB and plugged back in and reformatted and the errors went away. This was at home where I do not use Sentry Mode.

Maybe from a update?

Update on mine. Just had service appointment and they replace do USB stick and the entire “glove box” which I guess includes the hub?

Receipt attached

586053A7-93E0-4FBB-92E2-81BD8F735601.jpeg
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top