TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

DE Supercharger

Discussion in 'Model S: Battery & Charging' started by digitaltim, Jan 27, 2014.

  1. digitaltim

    digitaltim Sig737 VIN628

    Joined:
    May 2, 2012
    Messages:
    550
    Location:
    MD, USA
    Did they swap out the charging cables/adapters at the DE supercharger? They seemed different to me this morning in route to NJ/NY.

    If so, I wonder what prompted it.
     
  2. scaesare

    scaesare Active Member

    Joined:
    Mar 14, 2013
    Messages:
    3,940
    Location:
    NoVA
    Can you quantify how they seem different?
     
  3. digitaltim

    digitaltim Sig737 VIN628

    Joined:
    May 2, 2012
    Messages:
    550
    Location:
    MD, USA
    Quantify? Not really...

    More subjective - seemed to be a different feel to the adapter when I plugged in. The four stalls had different charging adapters in the past. I will check the others when I do my return trip later this week.
     
  4. rlang59

    rlang59 Member

    Joined:
    Feb 27, 2013
    Messages:
    923
    Location:
    US
    I wouldn't be surprised if they did. Last time I used it they seemed pretty beat up, unlock button on the one stall hardly worked.
     
  5. digitaltim

    digitaltim Sig737 VIN628

    Joined:
    May 2, 2012
    Messages:
    550
    Location:
    MD, USA
    I had problems charging there the week before last - called it in and they said 3 out of 4 were reporting "health" issues.
     
  6. paulkva

    paulkva Member

    Joined:
    Jul 22, 2013
    Messages:
    567
    Location:
    Falls Church, VA
    I don't use superchargers often, in fact I've used the DE supercharger for two trips so far and that's it. I had no problems on either trip, and I don't remember a difference between them. One trip was back in September, but my 2nd trip was recent. I think I charged in the first and third spaces, and in fact I got ~97 kW / 330 mph on Monday 1/20. Maybe they fixed whatever the problem was just before MLK weekend.
     

Share This Page