TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC
Start a Discussionhttps://teslamotorsclub.com/tmc/tags/

Driver's side mirror not correctly repositioning after being in reverse

Discussion in 'Model S: Interior & Exterior' started by AcidTest, Jun 4, 2017.

  1. AcidTest

    AcidTest Member

    Joined:
    Apr 6, 2017
    Messages:
    47
    Location:
    Raleigh, NC
    (Apologies if this issue has been discussed elsewhere; I searched a couple of times but couldn't find it.)

    I've had my 2014 CPO MS for just under 4 weeks. A couple of weeks ago I started noticing that after going from Reverse to Drive, the side mirror on the driver side does not always return to the correct position saved in the driver profile. It ends up angled further out and down, sort of between the R and D positions. If I make a quick change, the profile tab pops up and I can press Restore and it goes back to the saved position.

    I contacted the local service center and they recommended doing a reboot of the touchscreen, though admitted that they didn't think this was likely to address it. It didn't. I do have an appointment to drop the car off, apparently for a mirror assembly replacement to resolve this.

    Just curous if anyone has seen this and especially if any solution is known other than replacing parts. Seems like it could be a software issue as it's intermittent and Restore always works, though I guess there could be something in the mechanism that's sticking or something.
     
  2. Thumper

    Thumper Member

    Joined:
    May 6, 2011
    Messages:
    667
    Location:
    Corvallis, OR
    Same thing happened to me on a 2012 non-SIG yesterday only it was the passenger side mirror. I flicked it into reverse again while at a light and then back into drive. That fixed it. I don't remember that happening before. Must be a zeitgeist.
     
  3. araxara

    araxara S-P85#3,218 X-90D#3,299

    Joined:
    May 11, 2012
    Messages:
    755
    Location:
    Tucson, AZ
    I've had this problem on my 2016 Model X for about six months. I was finally able to get the service center to be able to reproduce it on my car and another one in the service bay.

    I don't have this problem in my 2012 Model S.

    The service center said they would be contacting Tesla engineering to get a resolution.

    It seems that the problem is reproducible when going from reverse to drive. If the mirrors have not gone down all the way when one goes into drive, the mirrors will be stuck in the halfway position.
     
  4. Alex D

    Alex D Member

    Joined:
    Mar 31, 2016
    Messages:
    249
    Location:
    Lake Worth, FL
    I had the same problem on my 2016 MS on the passenger side. The Service Center replaced the mirror and everything is working fine now.
     
  5. benaj

    benaj Member

    Joined:
    Aug 13, 2015
    Messages:
    24
    Location:
    Chicago
    When the auto tilt mirror feature is selected on my 2014 MS, the mirror actually actively tilts up (!) and not down when the car's in reverse. Not worth yet another trip to my local SC so it's sat on my list of minor annoyances to be addressed next time I'm in for something more major. In the mean time I just leave the feature off so I at least have a ballpark clue where the curb is when parallel parking the car.
     
  6. araxara

    araxara S-P85#3,218 X-90D#3,299

    Joined:
    May 11, 2012
    Messages:
    755
    Location:
    Tucson, AZ
    I don't know if you have set your reverse auto-tilt mirrors correctly, but you should put your car in reverse and then set them to the position you desire and save your settings in your driver profile. It sounds like your auto-tilt settings were saved with the mirror in the up position.
     
  7. Doc Savage

    Doc Savage Member

    Joined:
    Feb 5, 2017
    Messages:
    33
    Location:
    S. Louisiana
    My passenger side mirror did that for a month or so on my 2016 S, but it seems to have resolved itself. I'm going for the annual check next weekend, I will mention it. Thanks for reminding me.

    Oh yeah, nice licence plate, by the way. Go Tigers, all the way to Omaha!
     
  8. RayCzar

    RayCzar Member

    Joined:
    Apr 26, 2015
    Messages:
    8
    Location:
    Canada
    Looking forward to any updates from the SC. I've recently been having a similar issue where my driver's side mirror wouldn't tilt down properly when I'm in Reverse. If I set to Drive then back to Reverse again, it usually fixes it. That being said, had a slightly different behaviour this morning where I found my driver's mirror was tilted as if I was in Reverse position even though I was in driving. At the next stop, I quickly set the car to R and then back to D and that resolved the issue...
     
  9. AcidTest

    AcidTest Member

    Joined:
    Apr 6, 2017
    Messages:
    47
    Location:
    Raleigh, NC
    So I took my MS in to the SC last week, and they did the mirror assembly replacement. It didn't take long before I saw it malfunction again, and I can reproduce it about 20-25% of the time when going from R to D. It's back at the SC this morning where I demonstrated to the SC manager, again, what happens. It's very disappointing that they released the car back to me last week with this not being fixed.

    (OTOH, the loaner they gave me is a P85D with AP in "seaside blue", which is a blue I like better than the really dark metallic blue that I have, which looks black in low light. Wonder if I could finagle an exchange, lol.)
     
  10. AcidTest

    AcidTest Member

    Joined:
    Apr 6, 2017
    Messages:
    47
    Location:
    Raleigh, NC
    Update - SC replaced the front door control unit (from the service invoice: "Fault scan found 19 faults in drivers front door control unit. Determined to replace this module.") and says they performed 30 function tests with no failure. So hopefully this is it.

    But this is the 2nd issue I've taken my MS to the SC for in the month I've had it, and in both cases it took 2 attempts to fix the issue. That's not good.
     
  11. snd92

    snd92 Member

    Joined:
    Oct 27, 2016
    Messages:
    145
    Location:
    Norway
    Had SC to replace mine on passenger side. Worked for a year and now the issue is back on the same side. I have a feeling that it is failing after pressure washing. Not an issue when dry.
     

Share This Page