TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

EQ keeps resetting on latest firmware update

Discussion in 'Model S' started by Mike K, Dec 26, 2016.

  1. Mike K

    Mike K Member

    Joined:
    May 15, 2013
    Messages:
    759
    Location:
    Los Angeles
    Am I the only one? On 7.1 and 8.0 I learned to live with surround turning off randomly but this is much more annoying. Almost every time I get in the car the EQ is flat and it's not always flat at 0. Sometimes they're all at 6.5, sometimes 7.5, and sometimes 0 but all the time annoying.

    Just me?
     
  2. pilotSteve

    pilotSteve Member

    Joined:
    Jul 14, 2012
    Messages:
    868
    Location:
    Vancouver WA
    No. And Yes.
     
  3. MGMDaware

    MGMDaware Member

    Joined:
    Jun 23, 2016
    Messages:
    294
    Location:
    DC
    yup. Got in the car this morning and my EQ was reset to 6.5 across the board. I was a little confused. I changed it again before our road trip. I'm curious to see if it changes tomorrow!
     
  4. hmmm

    hmmm Member

    Joined:
    May 12, 2015
    Messages:
    678
    Location:
    Driver Seat
  5. Ames

    Ames Member

    Joined:
    May 27, 2013
    Messages:
    517
    Location:
    Abu Dhabi, UAE
    Same here. Euro spec with Spotify. Both the radio and Spotify reset to 6 or 7
     
  6. Haxster

    Haxster Member

    Joined:
    Apr 4, 2016
    Messages:
    516
    Location:
    Silicon Valley
    Oh no! It's a back-door test by Russian hackers and car theft rings. They want to take control of our AP2 cars whenever they're unoccupied and near a shipping port, then self-drive them to load into cargo ship containers and send off to buyers in Asia. Or... maybe just an innocent software bug.
     
  7. JohnnyG

    JohnnyG Weee!

    Joined:
    Jun 24, 2016
    Messages:
    277
    Location:
    Columbus, OH
    Mine resets to a flat 2.0 every time I get in the car. Very annoying.
     
  8. TexasEV

    TexasEV Well-Known Member

    Joined:
    Jun 5, 2013
    Messages:
    5,110
    Location:
    Austin, TX
    In another thread it was reported that rebooting will stop the equalizer from resetting.
     
  9. PaulR

    PaulR Supporting Member

    Joined:
    Feb 5, 2015
    Messages:
    157
    Location:
    Atlanta, GA
    "In another thread it was reported that rebooting will stop the equalizer from resetting."

    Sorry to say that doesn't work. It's not data corruption, it's bad design or bad QA.....

    I am on 2.50.114 - and It seems that I have the following media player problems:

    1. a. Still having my USB rescan unpredictably. (Every couple of days) Thought they fixed it, but not so....
    The good news here is that it seems to reload in about 1/5th of the time it used to take. No change of file structure or hardware on my part, just loads faster for some reason.

    1. b. My favorites get erased during the rescan. :( thinking of making a "folder" of my favorites and title it "AAAFavorites" or something like that to make it easy to find. That way I can use shuffle and repeat if I want and they won't be lost during a reboot or re-scan. Clumbsy, but might work better than their way.

    2. Fader control (the balance between front and rear and left and right) seems to randomly set itself to the right-rear of the car even though I had it set in the middle of the front two seats. Doesn't seem to happen every time the Equalizer goes wacko, but it does happen.

    3. Equalizer randomly resets itself (no logic to the settings though - different each time) That has been seen many times in this thread and others.

    None of these stop me from enjoying driving the car, but it would be so much nicer if it worked as designed. Yes, I can criticize the design, but I am willing to live with it's idiosyncrasies if it would just work that way.....

    I just hope that someone in Tesla really reads these comments and is empowered to do something about them.
     
    • Like x 2
  10. outie

    outie Active Member

    Joined:
    May 22, 2016
    Messages:
    1,009
    Location:
    SoCal
    Send them an email with your findings, otherwise they just go to deaf ears.

    [email protected]
     
    • Like x 1
  11. theslimshadyist

    theslimshadyist NashVegas!

    Joined:
    Jan 4, 2016
    Messages:
    1,005
    Location:
    Franklin, TN
    FWIW, My car received the 2.50.180 update on Friday evening and my EQ settings are still holding.
     
    • Informative x 1
  12. bucksport

    bucksport Member

    Joined:
    Oct 28, 2013
    Messages:
    29
    Location:
    Indiana
    Since my latest update, 2.50.114, I have joined the club. Sent TESLA a note. Seems like every update has a bug of some kind. Poor.
     
  13. purduelion

    purduelion Member

    Joined:
    Dec 9, 2016
    Messages:
    23
    Location:
    Illinois
    Save a "tree" and skip email. Just use voice command in your car. Start your report with "Note:" and then follow with the problem. That takes a snapshot of your car and the bug report and sends it to Tesla automagically.

    You will then see a "alert" on the small dashscreen thanking you for submitting feedback.
     
  14. PaulR

    PaulR Supporting Member

    Joined:
    Feb 5, 2015
    Messages:
    157
    Location:
    Atlanta, GA
    I knew of this, but (and maybe it isn't true) "common knowledge" is that Tesla gets so many of them that they don't pay attention to them. Though it does seem like the best way to go. At least with the email I got a polite response assuring me that they would forward it to the appropriate party. Who knows, they might ignore that also.....

    Granted, better to send something than to not send something.
     
  15. Shorty

    Shorty Member

    Joined:
    Nov 16, 2012
    Messages:
    183
    Location:
    Victoria BC
    If Tesla was inclined to ignore bug reports (which I don't believe they do), it is easy enough to script a response to your email as well!
     
  16. hmmm

    hmmm Member

    Joined:
    May 12, 2015
    Messages:
    678
    Location:
    Driver Seat
    Oh I see how it is, the P100Ds are getting preferential treatment...or is it that others are in fact getting preferential treatment since you're doing the debugging for the rest of us? :)
     
  17. SomeJoe7777

    SomeJoe7777 Marginally-Known Member

    Joined:
    Mar 28, 2015
    Messages:
    892
    Location:
    Houston, TX
    I've seen a lot of posts of this issue, so I should add my data point here that this is not affecting everyone.

    I have an Apr 2015 build 85D, UHFS, running firmware 2.50.114. My EQ settings have never reset -- I set them to 5 different values and they've maintained those values ever since, and that's including through 2-3 CID & IC reboots.

    It must be something specific to different builds of the vehicle, other configuration items, or something with cached data that is causing this issue on some cars and not others.
     
  18. ig_epower

    ig_epower Member

    Joined:
    Sep 10, 2016
    Messages:
    146
    Location:
    Oakville
    I've got an '15 P85D with 2.50.114 and my EQ resets all the time. Also strange is that a lot of my driver assist settings (lane departure warning, collision avoidance detection, etc) all changed as well. Perhaps my kids have been getting into my car and changed all my settings?
     
  19. PaulR

    PaulR Supporting Member

    Joined:
    Feb 5, 2015
    Messages:
    157
    Location:
    Atlanta, GA
    After an update, every update, I have found it necessary to check all the settings to see what might have changed. Sometimes they are changed on purpose by Tesla ("as a safety measure" to start with what they think might be the safest default setting). Sometimes they get reset to their "default" setting for some unknown (at least unknown to me) reason. But this kind of resetting isn't unique to a particular update.

    I haven't noticed anyone else complaining about settings outside of the media player for 2.50.114.

    Funny though, initially I complained about constant rescans and loss of favorites, etc. which went on for a couple of weeks, but, all of a sudden all of that went away and I have stability, no rescans, no loss of favorites for the last week and a half. No explanation for this as I have done nothing different to bring about that stability. Not even a reboot of the CID. Still on 2.50.114..... Just seems to be working now :)

    I do still have problems with the equalizer resetting to a "random" uniform value. Unfortunately that hasn't cured itself. It seems that Tesla is aware of the problem and claims that it will be fixed in another update.

    We have to trust them, I guess.....
     

Share This Page