TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Error 1428 "coolant system problem"

Discussion in 'Roadster' started by scapescape, Feb 16, 2017.

  1. scapescape

    scapescape Member

    Joined:
    Oct 18, 2012
    Messages:
    31
    Location:
    California
    Received this error after taking it in to Monterey Tesla for annual service. Fans don't come on - driving or charging. Worried that it's a PEM issue ... but 1428 doesn't appear in forum threads (usually 1144?). Any ideas?
     
  2. thefortunes

    thefortunes Member

    Joined:
    Jun 14, 2013
    Messages:
    580
    Location:
    Wisconsin
    1426 is a coolant pump error which would fit the description you noted. I don't see anything for 1428.

    The PEM is air cooled, not liquid, so that wouldn't be the problem. It could be as simple as your coolant level is low.

    What does your battery temp do?
     
  3. scapescape

    scapescape Member

    Joined:
    Oct 18, 2012
    Messages:
    31
    Location:
    California
    Thanks. Strange - it didn't get hot on the 15 mile trip back to the service center. I thought it could be just a software glitch, but the fans have always come on when I plug in to 240v/70a at rabobank in Salinas.
     
  4. PV-EV

    PV-EV Member

    Joined:
    Jun 3, 2011
    Messages:
    227
    Location:
    Alaska
    1428 HVAC "HVAC: Consolidated Compressor Fault(s)" Yellow Fault 1 HVAC - High Voltage Contoller Failure Check for other compressor faults

    Not sure what the implications are.
     
    • Informative x 1
  5. jeremyz

    jeremyz Member

    Joined:
    Apr 5, 2013
    Messages:
    225
    Location:
    .
    I got that error message when my compressor gave up the ghost. Unfortunately, it was fairly expensive to get replaced (like $2800). Hopefully, that's not the case for you though.
     
  6. scapescape

    scapescape Member

    Joined:
    Oct 18, 2012
    Messages:
    31
    Location:
    California
    Thanks. I'll post when I find out the damage done
     
  7. scapescape

    scapescape Member

    Joined:
    Oct 18, 2012
    Messages:
    31
    Location:
    California
    Diagnosis: high voltage controller. 1600 installed. This car is so much fun, but so fragile
     
    • Informative x 1
  8. DeedWest

    DeedWest Too Many Roadsters

    Joined:
    Feb 5, 2014
    Messages:
    267
    Location:
    North Dallas, TX
    Sorry to hear about your issue. I had my 400V controller fail the second day after I got Roadster 1438. $1,600 as well. Not fun.

    Seems to me like a lot can go wrong with just that one part. Only difference was mine was throwing 276 and 287 errors left and right.
     
  9. markwj

    markwj Moderator, Asia Pacific

    Joined:
    Apr 10, 2011
    Messages:
    3,922
    Location:
    Hong Kong
    Could yourself lucky. Mine failed and blew the fuse in the battery - that required pulling the battery and internal repair.
     

Share This Page