Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.

Error codes on 2014 P85 MS, Please help

I bought a used Tesla Model S P85 2014 with 135k miles in July. It has been so much fun! Last night, I drove 20 miles from a bar to my house, and as I was pulling into my house, it came up with a warning.. I can't remember exactly what it said, but something about "may not restart".

I pull into my garage, plug it in and go to sleep. I woke up this morning to use it, and the screen tried to turn on but then shut off...

I googled and figured out how to do a "soft reset" (hold steering wheels plus brake for up to 2 minutes), nothing. Something about a 4 finger wheel reset (2 on wheels, 2 buttons above and hold brake). Nothing.

I tried doing a hard reset... Which is disconnecting the 12v battery, waiting 2+ minutes, then reconnecting it.

I got the screens to turn on, and enough to grab error codes, but after about 60 seconds... It goes back to shutting off.

Error codes:
BMS_f008 - Vehicle may not restart
BMS_w008 - Vehicle may not restart
BMS_w009 - Service is required
GTW_w017 - Electrical system power reduced
GTW_w018 - Electrical system power reduced
GTW_w157 - Power reduced (vehicle systems shutting down)
DI_u014 - Unable to drive (voltage supply too low)

I set an appointment up with Tesla, but the soonest I can get in is Tuesday morning. I checked the voltage on my 12v, and got 11.92... But I'm not sure whether the main battery is constantly charging my 12v battery (so it will always show 12v, even if it can't hold?).

PLEASE NOTE IM NOT VERY SMART AT THIS. In no way am I professional. I was simply curious whether I could buy a new 12v battery to stick in so I have a car for the weekend.

Sounds like they will charge $88 to do a diagnosis. I will have to tow it to them as well (17 miles).

Anyway, just curious if anyone has seen these errors before, and what I could try while I wait for Tuesday.

I appreciate any comments or advice! Thank you :)

It seems the smartest thing to do is to wait until Tuesday, pay the $88 for them to diagnose it, and hopefully it is something under warranty?


  • 242506668_909556509768645_2078122190207530025_n.jpg
    7.2 KB · Views: 182
Other people have had this same message:

My bet is it might be a failing 12V battery as that's similar to the message other users have been getting when theirs was failing. If you can buy a 12V battery and change it yourself (buy it from Tesla, or at least make sure it's compatible, it's not the same as every 12V on any car) - try that first. At worst, you'll waste $100-ish for the battery. But it should be cheaper than the tow and diagnostic, and you'll have a fresh 12V battery.

If you try that, update us on the results so that others might know if that fixed the issue!
Hey sorry for the delay on responding! I posted the same question on reddit and had a lot of feedback there.

Turns out your guess was 100% right! I went to Tesla and bought a 12v battery for $160 (South Salt Lake Tesla Service Center), and changed it myself. The hardest part was getting it out and in where it sits at (very tucked in, jigsaw puzzle to get out).

After about 2 hours of tinkering around, I got it installed and everything is back in working order (I'm not very skilled).

Thank you again!

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.