TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Finding an original 110V yellow charging cable?

Discussion in 'Roadster: Technical' started by VIN271, Sep 21, 2019.

  1. VIN271

    VIN271 New Member

    Joined:
    Oct 27, 2013
    Messages:
    1
    Location:
    Seattle
    Like the person in April, I am interested in getting a replacement for my original yellow 110V charging cable. Might anyone be able to suggest a way to get hold of one? With thanks. R
     
  2. X.l.r.8

    X.l.r.8 Supporting Member

    Joined:
    Feb 18, 2018
    Messages:
    1,392
    Location:
    Toronto/Miami
    They are rare and ultra expensive when they do come up. if you have a can sr or Jr you can make a lead up with either a ji772 or a tesla plug to use a 110v outlet, other wise I think you will be in for a long wait or an expensive purchase.
     
  3. Roadster

    Roadster JdeMO Powered

    Joined:
    Dec 10, 2016
    Messages:
    1,488
    Location:
    SoCal
    More impressively, that's your first post since joining back in 2013 :cool: Hope #271 has been treating you well!

    FWIW, it never hurts to call your local SC and ask their parts dept. if they have any spares in the system. Best of luck.
     
  4. dhrivnak

    dhrivnak Active Member

    Joined:
    Jan 8, 2011
    Messages:
    4,346
    Location:
    NE Tennessee
    If you just have a broken one the GFI end is known to go bad. You can replace the GFI plug for like $15 at most any home improvement store. A DAR cheaper alternative.
     
  5. X.l.r.8

    X.l.r.8 Supporting Member

    Joined:
    Feb 18, 2018
    Messages:
    1,392
    Location:
    Toronto/Miami
    Never thought of that, If you have the original one I'm sure its repairable.
     
  6. Roadster637

    Roadster637 Member

    Joined:
    Jan 25, 2020
    Messages:
    9
    Location:
    California
    I had to do this the day I brought 637 home... it worked fine charging at the dealership, then wouldn't charge at home. The GFI end had went bad some how! Very glad it was a $15 fix and not something more substantial!
     
    • Like x 1

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC