TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Front hood latch is stuck

Discussion in 'Roadster' started by znino, Dec 14, 2013.

  1. znino

    znino Member

    Joined:
    Jan 10, 2011
    Messages:
    487
    Location:
    Montreal, Canada
    The latch on the left side of the Roadster front hood is not releasing making it impossible for me to open the good to put washer fluid in and I'm empty! The right side un-pops fine but I can't seem to get the left one to pop open, even when applying some upward pressure while pulling on the latch release inside the car. Has anyone had this happen to them? Any ideas in what I could try?
     
  2. wiztecy

    wiztecy Active Member

    Joined:
    Apr 29, 2012
    Messages:
    2,721
    Location:
    Santa Cruz, California, United States
    Instead of upward pressure, did you try downward pressure on the left side right where the latch assembly is on the hood right before and right as your pulling on the latch handle? In most cases you have to remove the pressure downward not add to the pressure by pulling upward on the hood.
     
  3. znino

    znino Member

    Joined:
    Jan 10, 2011
    Messages:
    487
    Location:
    Montreal, Canada
    I did try both thanks. It feels like the little latch is not even trying to move
     
  4. wiztecy

    wiztecy Active Member

    Joined:
    Apr 29, 2012
    Messages:
    2,721
    Location:
    Santa Cruz, California, United States
    Ok... try jiggling it side to side while pulling. And if that doesn't work it sounds like you need to jack the car up, remove the left front wheel, then remove the inside fender lining to access the latch and work from the inside out:

    S1 Stuck Front Bonnet - Technical Talk - Midlands Lotus Owners Club (MLOC)
     
  5. znino

    znino Member

    Joined:
    Jan 10, 2011
    Messages:
    487
    Location:
    Montreal, Canada
    Thanks. I will try that. If not, the service center will have to try and figure it out from the inside out as you say. Car is still under warranty :)
     
  6. dhrivnak

    dhrivnak Active Member

    Joined:
    Jan 8, 2011
    Messages:
    2,150
    Location:
    NE Tennessee
    That happened to me and the cable slid out of it's guide. I had to jack up the car, remove the wheel liner to see the cable. It sounds more complicated than it actually was. And it took about an hour of time.
     

Share This Page