Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

General issues with the X or?

Aug 8, 2019
8
2
Denmark
Hi all,

I am looking for other peoples experiences with their Model X model 2017 P100D.

So far I've been having the following issues, which are persistent, even after getting the MCU replaced*.
1: About once per song, i get lags. Like old school cd's with a scratch. As far as I can repro, this is only when streaming Spotify. (Before replacing the MCU, I had it like every 1-2 minute in any song)
2: My FOBs gets "unpaired" about every 3-4 month. Not running out of battery, not in a pocket with mobile phone, not lying too close to the car. It just stops recognizing the fobs.
3: I need to reboot the car about once a week. (Sometimes more, sometimes less). Because either the backwards camera is frozen, the music player is stuck or other features that are unresponsive.
4: When using Voice commands, it just crashes the interface. 9 outa 10 times. Need to reboot to get back into operation.

*Before MCU replacement i had random 1-2 seconds of lag on most features. Blinkers, blinker sound, Door open, Anything in the user interface etc.

Besides that I have experienced:
A: Sentry mode "crashes" multiple times. At least once a week, sometimes more often.
B: Sentry mode triggers the alert, when sitting inside the car. I presume it's because of 2. (Btw, that alarm is scary!)
C: Wifi is living it's own life. Sometimes working, sometimes not, sometimes hanging.
D: Different lags in the interface. Not sure its just bad user experience or its an issue.

I'd say the car has been at Tesla service for about a month, if not more.
Overall I really really love this car. It's a dream to drive and the comfort of it its just five star - when behaving normally.

Any suggestions, advice or feedback on your experience with your Tesla X?
 
  • Like
Reactions: DanCar

ajdelange

Active Member
Dec 10, 2018
1,077
638
Virginia/Quebec
I've not had any of those problems (December 2018 X100D) except the fairly frequent need to reboot early on. This problem went away. I don't think I've had to reboot since last spring.
 

jboy210

Supporting Member
Supporting Member
Dec 2, 2016
5,459
3,467
Northern California
Except for Wifi I have none of these issues with my 2018 X75 (manufactured 05/2018).

Wifi seems to be very insensitive. Had issues getting reliable connection to Wifi Access Point in the house. But my phone and iPad were fine with this Access Point when sitting in the car. I fixed the issue by putting a Wifi access point in the garage. It is on the ceiling and about 10 feet from the car.

FWIW, you can set Sentry Mode to not activate at your "Home" location.

Also, you might try replacing the battery in the Fob. I had some strangeness before I did that. Battery Plus stores stock the right battery, not sure if you have those in Denmark.
 
Last edited:
  • Informative
Reactions: Silicon Desert

BigMskiman

Active Member
Mar 14, 2016
1,146
711
Pleasanton, CA
I have similar make & date, but none of those issues. Fob battery lasts ~9months but un-pairing never, even when replacing battery.

I have MCU1 and browser is slow a h_ll, I got used to not using that function.
 

Keiki

Member
Jul 30, 2015
89
32
Roslyn, New York
I have an early 2017 (April) model X P100D and experience many of the same issues. They seem to come and go with the upgrades. With 32.12.7 I no longer have access to internet. I love the teslawaze on internet but have no more access to it OR any other internet connection. Oh Well, took it in for service. Hope they can resolve that issue.
By the way, Service rep said no retrofit for computer or screen. I guess I just missed out by getting an early model X ($165,000+ taxes). Oh Well, feeling bad for next owner as mine goes in from lease next May.
 

chacha72

Member
Sep 18, 2019
29
1
East Bay
I have 2019 X and have constant reboot so during rain and snow almost got stranded as could not have visibility to drive. Service updated firmware but still did not resolve the issue. I guess need MCU to replace?
 
Aug 8, 2019
8
2
Denmark
Just to follow up my old thread here.
Regarding MCU, i have been digging a bit. It seems my previous MCU was creating "corrupted files" on the storage, which couldn't get deleted. Replacing the MCU should remedy this, however it seems that I have just started over. So seeing same issues as in the beginning, less frequently, but building up. I am issued a return vehicle on Warranty, so it will be interesting to see how Tesla reacts to this.

Besides that I can add that I have had a ton of malformed rubber lists, which was out of place, making doors sqeek, unable to open properly and additional my falcon doors now smell of burned plastic whenever I open them....
 
  • Like
Reactions: DanCar

billion

Member
Dec 25, 2017
11
5
33715
I have a 2017 MX 100 and think it's an amazing vehicle. However, I have had some bad luck with tires and I had a 12 v battery that totally died with no warning. The replace battery alert failed. The car was an unmoveable brick. The bad tire and battery made the roadside service guy and I best friends last summer. I have the usual issues with some streaming channels not loading on 4G.

Also, it seems as though every time I get an update the voice command system gets buggy. The earliest updates definitely improved the EAP but recently it feels a bit less comfortable to use and I've had to intervene.

The service here in Tampa has improved and more responsive. As I said, I love the car.
 

Silicon Desert

Active Member
Oct 1, 2018
3,640
3,682
Sparks NV / GF 1
I must be really lucky. Late 2016 MX and never any issues of any kind at 30,000 miles. I think I recall having to reboot the car once a couple years ago. I've had 43 firmware updates since purchased. Oh wait, there was one issue. Needed to have the 12 V battery replaced after 3 years.
 

BigMskiman

Active Member
Mar 14, 2016
1,146
711
Pleasanton, CA
I must be really lucky. Late 2016 MX and never any issues of any kind at 30,000 miles. I think I recall having to reboot the car once a couple years ago. I've had 43 firmware updates since purchased. Oh wait, there was one issue. Needed to have the 12 V battery replaced after 3 years.
Then I'm lucky too. Some other door latch & window issues happened, but 60k miles so far w/o major issues.
We are not lucky, we are proud!

old |v2020.12.11.5|AP2,MCU1,PUP|
new |v2020.16.2.1|AP2,MCU1,PUP|
 
  • Helpful
Reactions: Silicon Desert
Aug 8, 2019
8
2
Denmark
And another update.
The latest update on this is that its a known issue, that some parts will create these corrupted files, slowly filling up the cars resources. I was told, that they are working on a fix in the US. However not available in EU yet, where my car is located.
So I have filed a claim on warranty to get car replaced. (Danish law states, that if the car you bought was defect from the beginning, the car seller should be given reasonable time to sort it. If they cannot sort it out, you are entitled to get the car redelivered. Same make, model, as purchased.

First offer from Tesla was 600.000dk. kr. from a new price of 1.396.000 dk.kr., so about 800.000dk.kr. price reduction on 2½ year, while they tried to fix their issue...

Needless to say, I am not impressed...
 

RedXowner

Member
Mar 24, 2020
214
109
Springfield, Virginia
Mine is a late 2016 MXP100D that I bought from Tesla with 47K on it, and the only one of those issues I've ever experienced is the need to reboot about once per software upgrade. Other than that, the car is super. Love it.
 

EV-Fixme

Vendor
Supporting Member
Oct 24, 2019
617
702
Orange County, CA
Just to follow up my old thread here.
Regarding MCU, i have been digging a bit. It seems my previous MCU was creating "corrupted files" on the storage, which couldn't get deleted. Replacing the MCU should remedy this, however it seems that I have just started over. So seeing same issues as in the beginning, less frequently, but building up. I am issued a return vehicle on Warranty, so it will be interesting to see how Tesla reacts to this.

Besides that I can add that I have had a ton of malformed rubber lists, which was out of place, making doors sqeek, unable to open properly and additional my falcon doors now smell of burned plastic whenever I open them....

Did all your save seat settings and travel history, trip odometers, etc get transferred over? If so you may want to try a factory reset as the corrupted files containing that data was likely to have transferred over.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top