TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

GPS problems since 7.0 update?

Discussion in 'Model S' started by MikeS85D, Oct 16, 2015.

  1. MikeS85D

    MikeS85D Member

    Joined:
    Aug 7, 2015
    Messages:
    34
    Location:
    Los Gatos CA
    Since I got the 7.0 update yesterday, I have had problems with my location in Maps not working. While driving, the arrow thingy was stuck at the same location - a place I had never been before about 5 miles from my actual location. I'm guessing the GPS was not able to get a real location and was using a coarse grained approximate location instead. This was happening in the middle of Silicon Valley where I have never had GPS or LTE coverage problems before.

    Rebooting the 17" didn't help, but the problem seems to clear up on its own after a while. This has happened 3 times since the 7.0 update yesterday morning. Anyone else seeing anything like this?
     
  2. emmlex

    emmlex Member

    Joined:
    Jul 26, 2015
    Messages:
    8
    Location:
    NJ
    After updating to 7.0 last night, I had the map freeze several times today. Then Slacker froze, then the entire 17". I rebooted 4 times, and Slacker was ok, but map still kept freezing. When i got home tonight, car didn't recognize my location (since map was frozen) or my charging preferences.
     
  3. glschmid

    glschmid New Member

    Joined:
    Jun 25, 2013
    Messages:
    1
    Location:
    Celebration, Fl
    Gps not connecting to sat. Let's hope telites

    I have had the same problem since we picked up our 85D a few months ago. We have been on three major trips where the GPS stopped working and could not locate any satellites. (thanks to our phone GPS we were able to navigate). This has occasionally reset itself days later but this last time, weeks later the car thinks it's in Maryland, vs being in NY in my driveway.

    We are bringing the car in for service for the 3rd time. Let's hope they can fix it this time since their attempt to wiggle the wiring harness obviously did not help.
     
  4. Merrill

    Merrill Active Member

    Joined:
    Jan 23, 2013
    Messages:
    2,096
    Location:
    Sonoma, California
    Since the update my navigation screen goes blank even with full bars, after 10 minutes it usually starts working. Rebooted twice with same issue.
     
  5. glhs272

    glhs272 Unnamed plug faced villian

    Joined:
    Aug 21, 2013
    Messages:
    781
    Location:
    Burlington, WI
    I have had similar issues in the past with the GPS system... it getting lost or not accurately getting the position of the car, having navigation freeze up or go wonky which also effected slacker for some reason, or just not picking up any satellites... all intermittently. Turns out the GPS antenna harness was flaky or intermittent. Replacing the harness and antenna (which required rear glass removal as well as center brake light replacement) fixed the issue. No problems since.
     
  6. MikeS85D

    MikeS85D Member

    Joined:
    Aug 7, 2015
    Messages:
    34
    Location:
    Los Gatos CA
    I just got my car back from the service center. It turned out to be a loose connection to the GPS antenna - not related to 7.0. They did upgrade me to 2.7.77, so now I have the clock back on the IC!
     
  7. Merrill

    Merrill Active Member

    Joined:
    Jan 23, 2013
    Messages:
    2,096
    Location:
    Sonoma, California
    I was told by service that my intermittent nav screen going blank had been reported by several owners and a new update should fix that problem, can anyone confirm that.
     

Share This Page