Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Hansshow Model Y Power Frunk V4.2 (maybe 4.3?) - does anyone know how to program it?

Yonki

Member
Supporting Member
Mar 31, 2015
601
1,771
Pacific Grove, CA
You're supposed to be able to adjust height, speed, and I don't know what else. But the abysmal "documentation" is pretty close to useless. I don't see any buttons or controls.

Half of the troubleshooting steps end up saying "contact the engineer to update the software." Is it opening too fast or too slow? "There may be an error in the system software, please contact after-sales to update the software."

Also, on my kit they seem to have removed the emergency manual frunk open link. Is it not needed any more? Was it ever needed in the first place? They had it on all their other kits.

What I would give for a web poage with an organzied FAQ. I'd settle for a disorganized FAQ. I'm pretty good at figuring thinbgs out for myself if I'm given at least a few clues...

Here's my controller version. 4.2. Or maybe 4.3. I don't know. And I don't know if it matters.
IMG_6518.jpg
 
To initialize the V4.3, you have to long press the button in the Frunk for 10+ seconds until it beeps twice. open/close the Frunk and it should automatically set the necessary strength. I've had to do it after periods where it works fine and then suddenly goes really slow/weak and doesn't open all the way.
 
  • Like
Reactions: Yonki

Yonki

Member
Supporting Member
Mar 31, 2015
601
1,771
Pacific Grove, CA
To initialize the V4.3, you have to long press the button in the Frunk for 10+ seconds until it beeps twice. open/close the Frunk and it should automatically set the necessary strength. I've had to do it after periods where it works fine and then suddenly goes really slow/weak and doesn't open all the way.
Thanks! I previously tried pressing the button for ~10 seconds for it to get itself back in sync (i.e. not trying to close with the latch already closed, etc.), and that worked. Will experiment some more. SOMETHING happened (probably due to pressing that button) that caused it to get weak, since it was initially working fine.

I was sort of thinking you would hold the button down for longer than 10 seconds and it would beep out different strength settings (1 for weakest through 5 for strongest or something like that), but holding it past the 10 second mark didn't seem to do anything.

It's just so frustrating - would it KILL Hansshow to release a few lines of instructions for how to adjust the things their own installation instructions say are adjustable?
 
Weird! It worked for me so that's annoying that it's not helping you. I did the whole install and was so proud and everything worked and was buttoned up... and then I got in the car and saw a front latch error warning. The frunk showed that it was open even though it was definitely closed so I couldn't even drive if I wanted to. I panicked and went to uninstall the whole thing prior to bringing it to Tesla for a latch fix and when I unhooked the first wiring harness plug (near the latch), it did like a loud clicking back and forth and seemed to have reset itself... and the code was gone. :) The code came on the other day but all seems to be functioning correctly and the open/close status is showing correctly on the screen so I am ignoring it for now. Good luck, Yonki! Please update here when you figure it all out.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top