Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Help Needed - Issue when trading in my current Model X Plaid

Hi All,

I'm looking for some advice here as I've been having a technical issue with my Model X Plaid for more than two weeks. I currently own a Model X Plaid and I decided to order a new one in a different color. I had a change of heart on the color and I was hoping to get some of new add ons like the matrix headlights.

On Delivery day in early August, I take my current MXP for trade-in. They accept my trade-in and I lose app access. They then inform me the vehicle is ready, at this point in the past I remember a Tesla rep would walk around the car with me. This time I was in a bit of a rush so I wasn't thinking straight. The rep said to go take a look at the car. I head over to the car and it's locked. I let the rep know and he simply says to tap the button in the app and you'll have controls to unlock the car. Now as you know the blue button means you accept delivery. This is where I made the mistake, I accepted delivery before even having a chance to look at the car.

I start taking a look at the car, it has normal issues, a bit dirty, panel gaps, etc. Those issues don't concern me as I've owned Tesla's since 2015. The issue I faced was the right rear captain seat was in the forward position and none of the seat controls worked. I have two kids and I needed to put their car seats in. With the seat in the forward position, it was not possible to put the seats. In addition, the right rear falcon door would not close unless forced. It would stop about halfway every time.

I ask the rep to come to take a look at the car and he said to go in the app and make a service appointment. They simply refused, this was at the Marina Del Ray delivery center by the way. So at this point, I'm a bit annoyed but I know that would not get me anywhere so I decided to ask if they could help me place my car seat in. They come out and see the issue and then inform me that they will take it inside to see if they can fix it.

A few hours go by and nothing. They need to keep it overnight. Now I've traded in my vehicle so I had to convince the delivery center vehicle to give me my old car back temporarily. They finally agree and fast forward to the next day, the issue is more severe than originally thought so they said it could take about a week to fix because they need to order a new seat. Then some additional time for the door. They let me know that the deal can be canceled and I could be put back in the queue for a new car. I decide to go that route. We cancel the deal and I get my current MXP back officially.

Now here is where the issue begins. I no longer have app access to the vehicle so I have to rely on the key to unlock/start the car. Also, my premium connectivity was disabled so I know no longer have access to the theatre in the back seats when driving, traffic data, and other things. Also, FSD was removed as well because it's no longer linked to my account.

I cannot see it on the tesla.com account page or in the app. I've tried logging in and ou and deleting the app numerous times.

Support said it has to do with the fact that the trade-in was accepted and it's stuck in this limbo state. I'm not getting many details from tesla so I don't have full details on the problem. They suggest I go back to the delivery center and have them fix it. I go there and they say there is nothing they can do and refuse to even talk to me about it. They were extremely rude but I didn't say much because I had my kid with me.

So for about 5 days, I call tesla support each day. They walk me through the usual steps of deleting and reinstalling the app. They say everything looks good on their end and it's linked to my email address. One of the reps told me I need to talk to the change of ownership team and they can only be contacted via email. So I send them an email and the automated response is we will respond in 3-5 days. They finally call me 5 days later. This team was supposed to be the one that can fix it. They have me run through the same steps, delete the app and log back in. At this point, I'm not confident in their solution because the car wasn't even showing up on the tesla.com site. When I let them know of that they had me try to remove app access. I put in my email and password and I get an error stating this car is not linked to the provided email address. So I cannot unlink it.

So this is where I've been stuck for 2-3 weeks now. I'm beginning to worry that it will never be fixed and I'm not sure who or even how to escalate it. I keep getting suggestions like tweeting at Elon. I'm not a fan of that route because I don't post on social media.

Would any on this forum be able to offer any guidance or help? The only thing I can think of is getting an attorney involved.

Again any help or ideas would be greatly appreciated.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top