Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • We just completed a significant update, but we still have some fixes and adjustments to make. Please see this thread for more details and to find out how to revert to the old design. Cheers!

Homelink woes

apacheguy

S Sig #255
Oct 21, 2012
5,096
1,296
So Cal
I programmed my first homelink flawlessly on the first try. The second homelink refuses to take. The vehicle says it can’t find a signal. FWIW, both homelinks work fine on my Model S. Here’s what I’ve tried:

1. Reproduced the steps at least 6 times exactly as indicated in the instructions
2. Rebooted ICE
3. Opened the frunk and held the remote in there
4. Stood 3 feet away from bumper
5. Repeated all of this on another day
6. I’ve tried 3 separate remotes

Anyone else had trouble getting it to read the signal? What’s the fix?
 
Upvote 0

apacheguy

S Sig #255
Oct 21, 2012
5,096
1,296
So Cal
Did you first program the remote to the Homelink and then add the opener? Also, did you fail and then not clear the Homelink button memory?

Not sure what you mean. Yes, the remote was already programmed and has been working to open the gate for two years. What is the memory? I assume you mean on the vehicle? If so, it just reads “Not programmed”

I had all kinds of problems with mine till i changed the remote batteries. it would open the door just fine but the car wouldn't see it. Changed batteries and it worked almost immediately.

I used the same remote to program both homelinks. One worked the other did not. I also tried 3 different remotes. It’s not the batteries.

I had a lot of trouble with mine...just couldn't get it to take. Turns out, my garage door opener was 'full' of codes...had to do a reset to clear it. Once I did that, the 3 programmed just fine. But I did have to re-program all of my clickers, and my S

What are these codes and how do you clear them?
 
What are these codes and how do you clear them?

Maybe codes was the wrong word to use there....my garage door opener had been linked with it's maximum number of devices (nothing I found actually said what that number was). I found directions for my specific model, on how to reset to clear it's memory. That's the only way I could get it to work, but it worked great - just had to reset everything up.
 
  • Helpful
Reactions: apacheguy
I used the same remote to program both homelinks. One worked the other did not. I also tried 3 different remotes. It’s not the batteries.

I also had trouble programming. All of my remotes seemed to have decent batteries as they would open/close the garage but none would program homelink on my 3 (despite opening the frunk; holding the remote near the headlight, etc). Finally, I replaced the batteries in one of the remotes and that did the trick. I'll note also that once programmed, homelink on the 3 has about half of the range of the standalone remote.
 
The issue I have with Homelink, is that unless I am misunderstanding how it is supposed to work, the door should automatically open or close when you get within the preselected distance of the garage. Mine does not do this. I have to manually select open/close.

Have you tried decreasing the distance? It didn't work for me beyond about 30 feet. Farther away and the signal wasn't strong enough to reach the garage opener.
 

Nathanael

Member
May 10, 2018
55
89
Toronto
Hey! Just solved my problem. I have an old shitty remote / garage door system in a condo, so I wasnt sure if it was even going to work. I read someone had luck with programming the remote right underneath the headlight. My sweet spot was right up against the passenger door headlight.
 
  • Like
Reactions: mknoebel
After reading and rereading this multiple times since my last post (and going to the link I was referred to), I decided to redo the programming. As I went through the programming, I found myself holding the garage door opener in front of the bumper as instructed in another video I found. At this point, I realized that I could not recall having done that with the original programming. Once this was complete and it was set up, I gave it a test run. It worked perfectly. Now I have to figure out why the tone does not sound when it is set to open/close.
 

rodrego66

Member
Jul 29, 2018
56
14
Phoenix
I am wondering if anyone else has had this problem. Brought my Model 3 home a while ago and was programming Homelink. My other car is a ICE vehicle, so I need garage door remote still. Programming Homelink went fairly well, but when I did, the remotes stopped working as did the key pad. I switched back to remotes, and forgot about it, but would really like to get homelink working as I am planning to get another Tesla soon. Any idea what went wrong?
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top