Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

IC replacement not working

Gu$ G

Member
May 7, 2018
159
69
Kaneohe, HI
My buddy purchased an IC from Realdeel and he just got it installed. The car is only illuminating about half of the screen, and the image is pretty distorted and not working. Anyone seen this happen before? He initially tried swapping the IC without disconnecting the HV, but even after removing HV / 12V power he still can't get this issue to clear with a reset. Anyone seen this before?
 

Attachments

  • IC.jpg
    IC.jpg
    503.4 KB · Views: 53

KyleDay

Active Member
Oct 29, 2016
1,377
3,104
AZ
assuming this is on an mcu1 car, IC is a standalone computer that has to be firmware matched to the cid. Depending upon the firmware both the Ic and cid are currently running, and if you have Ethernet access to the car network, this can be easy or hard.

But I just want to warn you that assuming you get the lcd issues resolved, the ic will need a firmware redeploy before it’ll talk to the car correctly.

oh, and until you get it working, gateway will NOT charge your 12v battery until the redeploy is successful. So watch your 12v battery voltage because you could kill your 12v battery in a few hours.
 

Doanster1

Active Member
Feb 14, 2018
1,050
566
Oregon
assuming this is on an mcu1 car, IC is a standalone computer that has to be firmware matched to the cid. Depending upon the firmware both the Ic and cid are currently running, and if you have Ethernet access to the car network, this can be easy or hard.

But I just want to warn you that assuming you get the lcd issues resolved, the ic will need a firmware redeploy before it’ll talk to the car correctly.

oh, and until you get it working, gateway will NOT charge your 12v battery until the redeploy is successful. So watch your 12v battery voltage because you could kill your 12v battery in a few hours.
Realdeel not sold replacement screens, not the entire IC so if the prob just is a loose/misaligned connection they should be golden.
 

uscgreel

Member
Apr 7, 2019
41
15
Tampa, FL
Chad from reeldeal messaged us back and thinks this is a misaligned ribbon cable. Will report back, thank you for the quick reply Chad!
You are welcome, we actually added an update to our site about your scenario, just be extra sure the ribbon cables are completely seated. ;)
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top