Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Instrument cluster not working - unconnected wire behind left dash

Jeecups

Member
Oct 1, 2020
8
0
USA
Hi all,

My out of warranty 2012 Model S was recently at the service center for a Service Required issue. I was told it needs a new DC DC converter and given an estimate, which I declined. Upon the tow company dropping my car off, the smaller instrument cluster display was black (it had worked fine before.)

The left side panel of the dash was left hanging off by its wire connection. I also see this small white connector not connected to anything. Could this be the reason my instrument panel doesn't work?

Looking for some info before I start pulling the dash apart to see where/if this should be connected. Thanks!
 

Attachments

  • 0936CFCD-27EA-4677-892A-02894E144A25.jpeg
    0936CFCD-27EA-4677-892A-02894E144A25.jpeg
    426.7 KB · Views: 37

Jeecups

Member
Oct 1, 2020
8
0
USA
Just updating this - I was able to get in touch with someone at the service center and was told that connector is the Ethernet, and unrelated to the instrument cluster.
 

freeewilly

Member
Jul 22, 2015
567
173
Brea, CA
Hi all,

My out of warranty 2012 Model S was recently at the service center for a Service Required issue. I was told it needs a new DC DC converter and given an estimate, which I declined. Upon the tow company dropping my car off, the smaller instrument cluster display was black (it had worked fine before.)

The left side panel of the dash was left hanging off by its wire connection. I also see this small white connector not connected to anything. Could this be the reason my instrument panel doesn't work?

Looking for some info before I start pulling the dash apart to see where/if this should be connected. Thanks!
Have you find out why the screen went black? My 2013 instrument cluster went black a few days ago and never came back. I have reboot the instrument cluster and MCU1 many times, but can't bring the instrument cluster back. MCU1 works fine, the steering wheel buttons are not working, only working function is to reboot MCU1.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top