Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

iPhone X suddenly not connecting for media

rincewind

Member
Nov 5, 2019
527
291
London England
Hi all,

Had the car for over a year, 16k miles and no problems. Yesterday, I washed the car, got in it to move it and as I pressed the brake pedal, the Frunk popped open (twice)and the screen became glitchy. I did a hard reboot, which fixed those issues. However, since then it won't connect to my phone for media - although it's still fine as a phone key. It won't even let me forget the connection, I just get the donut whizzing around for ages. I've since hard booted again, still no joy. The Bluetooth icon on the top left of the screen is greyed out.

So, no telephone or iPhone music in the car. :-(

I've booked a mobile appointment, but it's two weeks away.
 

NewbieT

Active Member
Aug 16, 2019
1,027
625
North West
I pressed the brake pedal, the Frunk popped open (twice)
If it’s water ingress in a connector I could see how (electrically) that could conceivably happen. The usual behaviour before the ‘fix’ was lots of error messages and a car that wouldn’t drive. However, if the computer is somehow causing that behaviour it’s massively screwed up & very worrying! You’d sort of hope something like brakes would be a dedicated / highly resilient/ independent sub-system, not erm… shared with the frunk. Eek.

Had you tried to open the frunk to clean? Could it have been a delayed command?
 
  • Like
Reactions: Jez_GB

rincewind

Member
Nov 5, 2019
527
291
London England
Had you tried to open the frunk to clean? Could it have been a delayed command?
Ironically, I cleaned the Frunk becuase it popped open. All good today - after a bit more faffing this morning, it finally let me drop the existing connection, then after 3 attemps, it finally found and connected to my iPhone. I think the iPnone is only discoverable for bluetooth for a short time after bluetooth is enabled, as I turned the phones BT off and on, then it connected. Yesterday it refused to do anything phone wise.
 
  • Like
Reactions: NewbieT

Rich135

Member
Jan 23, 2020
34
11
Surrey
Strangely my iphone 11 wouldn't connect this morning. I tried to play a podcast and the phone just played through itself, not through the car. Odd
 

rincewind

Member
Nov 5, 2019
527
291
London England
Strangely my iphone 11 wouldn't connect this morning. I tried to play a podcast and the phone just played through itself, not through the car. Odd
Exactly the situation I had, along with no actual phone connection. If it persists, drop the connection and re make it - make sure the iPhones bluetooth has just been turned on so it's in discoverable mode.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top